Seite 1 von 1

[gelöst] Opensuse 11.4 und Sichtbarkeit

Verfasst: 24. Mär 2011, 21:26
von tuxfornas
Hallo,

ich habe bisher die Version 11.3 eingesetzt und war recht zufrieden, d.h. alles funktionierte so wie es sollte. Nun habe ich meinen Samba-Server neu mit 11.4 aufgesetzt. Die Samba-Konfigurationsdateien habe ich direkt aus der alten Version übernommen. Nun habe ich das Problem, dass der Samba-Server im Netz nicht mehr sichtbar ist.

Ich habe so einiges ausprobiert .... eine Lösung habe ich aber nicht gefunden.

Hat jemand eine Idee ??

Gruß
TuxforNAS

Re: Opensuse 11.4 und Sichtbarkeit

Verfasst: 25. Mär 2011, 09:23
von stka
Die Konfigurationsdateien von einer Version auf die andere zu übernehmen ist keine gute Idee, wenn man nicht die Releasnotes der verschiedenen Version gelesen hat. Von Version zu Version ändern sich dort manchmal die default-werte der einzelnen Parameter um das verhalten immer mehr mit einem Windows-Server vergleichbar zu machen. Du solltet dir deshalb mal die Releasenotes auf samba.org anschauen. Da du keinerlei Informationen über die verwendete Version oder die Konfiguration gegeben hast, wird dir hier keiner helfen können. Wir sind alle keine Hellseher.

Re: Opensuse 11.4 und Sichtbarkeit

Verfasst: 25. Mär 2011, 10:53
von DaBossDaChef
Schalte mal Apparmor aus. Unter 11.4 gab (bzw. gibt es noch?) einen Bug in Zusammenhang mit Samba.

Re: Opensuse 11.4 und Sichtbarkeit

Verfasst: 25. Mär 2011, 16:51
von tuxfornas
Hallo,

meine Samba.conf sieht so aus:

Code: Alles auswählen

# Samba config file created using SWAT
# from UNKNOWN ()
# Date: 2009/01/28 16:07:15

[global]
	workgroup = ARBEITSGRUPPE
	server string = Samba from Tuxbox
	interfaces = eth0, 127.0.0.1
	bind interfaces only = Yes
	passdb backend = tdbsam
	force user = admin
	read only = No
	hosts allow = 127.0.0.1, 192.168.178.0/24
	hosts deny = 0.0.0.0/0
	wins support = No
	netbios name = Tuxbox
	wins server = 

[bilder]
	comment = Unsere Bilder
	path = /nas/nas2/bilder
	valid users = admin

[daten]
	comment = Eigene Dateien
	path = /nas/nas2/daten
	valid users = admin
...
 
... also nichts wildes ...

Mir ist aber aufgefallen, dass in der Log-Datei 'messages' etwas anderes drin steht als früher:

Code: Alles auswählen

Mar 25 16:29:42 Tuxbox SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Mar 25 16:29:42 Tuxbox SuSEfirewall2: Firewall rules successfully set
Mar 25 16:29:42 Tuxbox kernel: [   34.760670] bootsplash: status on console 0 changed to on
Mar 25 16:29:51 Tuxbox nmbd[2108]: [2011/03/25 16:29:51.185887,  0] nmbd/nmbd_become_lmb.c:395(become_local_master_stage2)
Mar 25 16:29:51 Tuxbox nmbd[2108]:   *****
Mar 25 16:29:51 Tuxbox nmbd[2108]:   
Mar 25 16:29:51 Tuxbox nmbd[2108]:   Samba name server TUXBOX is now a local master browser for workgroup ARBEITSGRUPPE on subnet 192.168.178.21
Mar 25 16:29:51 Tuxbox nmbd[2108]:   
Mar 25 16:29:51 Tuxbox nmbd[2108]:   *****
Mar 25 16:29:53 Tuxbox dhclient: XMT: Solicit on eth0, interval 35460ms.
Mar 25 16:30:28 Tuxbox dhclient: XMT: Solicit on eth0, interval 70930ms.
Mar 25 16:31:39 Tuxbox dhclient: XMT: Solicit on eth0, interval 126580ms.
Mar 25 16:33:46 Tuxbox dhclient: XMT: Solicit on eth0, interval 123500ms.
Mar 25 16:35:50 Tuxbox dhclient: XMT: Solicit on eth0, interval 119300ms.
Mar 25 16:37:47 Tuxbox polkitd[4969]: started daemon version 0.99 using authority implementation `local' version `0.99'
Mar 25 16:37:48 Tuxbox kernel: [  520.396338] start_kdeinit (5099): /proc/5099/oom_adj is deprecated, please use /proc/5099/oom_score_adj instead.
Mar 25 16:37:49 Tuxbox kernel: [  521.514969] EXT4-fs (sda1): re-mounted. Opts: acl,user_xattr,commit=0
Mar 25 16:37:49 Tuxbox dhclient: XMT: Solicit on eth0, interval 110360ms.
Mar 25 16:37:55 Tuxbox rtkit-daemon[5306]: Sucessfully called chroot.
Mar 25 16:37:55 Tuxbox rtkit-daemon[5306]: Sucessfully dropped privileges.
Mar 25 16:37:55 Tuxbox rtkit-daemon[5306]: Sucessfully limited resources.
Mar 25 16:37:55 Tuxbox rtkit-daemon[5306]: Running.
Mar 25 16:37:55 Tuxbox rtkit-daemon[5306]: Canary thread running.
Mar 25 16:37:55 Tuxbox rtkit-daemon[5306]: Failed to make ourselves RT: Operation not permitted
Mar 25 16:37:55 Tuxbox rtkit-daemon[5306]: Watchdog thread running.
Mar 25 16:37:55 Tuxbox kernel: [  527.601706] hda-intel: IRQ timing workaround is activated for card #1. Suggest a bigger bdl_pos_adj.
Mar 25 16:37:55 Tuxbox pulseaudio[5325]: pid.c: Daemon already running.
Mar 25 16:37:55 Tuxbox pulseaudio[5330]: pid.c: Daemon already running.
Mar 25 16:38:00 Tuxbox pulseaudio[5302]: ratelimit.c: 16 events suppressed
Mar 25 16:38:20 Tuxbox polkitd(authority=local): Registered Authentication Agent for unix-session:/org/freedesktop/ConsoleKit/Session1 (system bus name :1.26 [/usr/lib64/kde4/libexec/polkit-kde-authentication-agent-1], object path /org/kde/PolicyKit1/AuthenticationAgent, locale de_DE.UTF-8)
Mar 25 16:38:26 Tuxbox kernel: [  558.994537] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=00:1f:d0:9d:48:80:00:24:fe:3d:27:91:08:00 SRC=192.168.178.1 DST=192.168.178.21 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=15750 DF PROTO=TCP SPT=3227 DPT=14013 WINDOW=5840 RES=0x00 SYN URGP=0 OPT (020405B40402080A0F696C910000000001030303) 
Mar 25 16:38:27 Tuxbox kernel: [  559.463519] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=00:1f:d0:9d:48:80:00:24:fe:3d:27:91:08:00 SRC=192.168.178.1 DST=192.168.178.21 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=11515 DF PROTO=TCP SPT=1672 DPT=14013 WINDOW=5840 RES=0x00 SYN URGP=0 OPT (020405B40402080A0F696CC00000000001030303) 
Mar 25 16:38:29 Tuxbox kernel: [  561.985232] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=00:1f:d0:9d:48:80:00:24:fe:3d:27:91:08:00 SRC=192.168.178.1 DST=192.168.178.21 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=15751 DF PROTO=TCP SPT=3227 DPT=14013 WINDOW=5840 RES=0x00 SYN URGP=0 OPT (020405B40402080A0F696DBD0000000001030303) 
Mar 25 16:38:29 Tuxbox kernel: [  562.000715] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=00:1f:d0:9d:48:80:00:24:fe:3d:27:91:08:00 SRC=192.168.178.1 DST=192.168.178.21 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=26840 DF PROTO=TCP SPT=1119 DPT=14013 WINDOW=5840 RES=0x00 SYN URGP=0 OPT (020405B40402080A0F696DBE0000000001030303) 
Mar 25 16:38:30 Tuxbox kernel: [  562.455250] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=00:1f:d0:9d:48:80:00:24:fe:3d:27:91:08:00 SRC=192.168.178.1 DST=192.168.178.21 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=11516 DF PROTO=TCP SPT=1672 DPT=14013 WINDOW=5840 RES=0x00 SYN URGP=0 OPT (020405B40402080A0F696DEC0000000001030303) 
Mar 25 16:38:50 Tuxbox kernel: [  582.847355] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=00:1f:d0:9d:48:80:00:24:fe:3d:27:91:08:00 SRC=192.168.178.1 DST=192.168.178.21 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=21115 DF PROTO=TCP SPT=4502 DPT=14013 WINDOW=5840 RES=0x00 SYN URGP=0 OPT (020405B40402080A0F6975E30000000001030303) 
Mar 25 16:39:26 Tuxbox kernel: [  618.849115] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=00:1f:d0:9d:48:80:00:24:fe:3d:27:91:08:00 SRC=192.168.178.1 DST=192.168.178.21 LEN=60 TOS=0x00 PREC=0x00 TTL=64 ID=59239 DF PROTO=TCP SPT=4151 DPT=14013 WINDOW=5840 RES=0x00 SYN URGP=0 OPT (020405B40402080A0F6983F30000000001030303)  
Die letzten Zeilen wiederholen sich dann immer wieder .... da scheint ja etwas nicht in Ordnung zu sein, oder ????

Gruß
TuxforNAS

..... ach so : Apparmor ist ausgeschaltet und das Samba-Profil gelöscht .....

Re: Opensuse 11.4 und Sichtbarkeit

Verfasst: 25. Mär 2011, 20:37
von stka
Diese Meldungen sind Firewall-Meldungen. irgendwas will auf den Port 14013 zugreifen. Hast du auch Meldungen in der /var/log/samba/log.smbd?

Re: Opensuse 11.4 und Sichtbarkeit

Verfasst: 27. Mär 2011, 11:50
von tuxfornas
Hallo,

das Problem ist gelöst ...
Aber zuerst zu stka: Die Meldungen der Firewall waren immer Verbindungsversuche von den angeschlossenen Rechner (Samba).

Wie im Beitraghttp://www.linux-club.de/viewtopic.php?f=6&t=112904 beschrieben, hatte ich vorher schon das Samba Profil von AppArmor gelöscht, was aber bei der Sichtbarkeit keine Hilfe brachte. Nach all meinen erfolglosen Versuchen hatte ich dann rein aus Frust alle Profile von AppArmor gelöscht ... und siehe da: es ward Licht und Samba wurde plötzlich sichtbar.
Da ich einfach alles gelöscht habe kann ich nicht sagen, welches der Profile nun dafür verantwortlich war .... aber irgendwie ist es schon traurig, dass ein neues Release mit so einem Bug überhaupt über den RC-Status hinaus kommen konnte ... und offensichtlich ist der Fehler auch noch nicht behoben, oder ???

Gruß
TUXforNAS