Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

VSFTPD-Server lässt sich nicht stoppen?!?

Alles rund um das Internet, Internet-Anwendungen (E-Mail, Surfen, Cloud usw.) und das Einrichten von Netzwerken einschl. VPN unter Linux

Moderator: Moderatoren

Antworten
Schmitty
Member
Member
Beiträge: 153
Registriert: 6. Nov 2007, 17:08

VSFTPD-Server lässt sich nicht stoppen?!?

Beitrag von Schmitty »

Hallöchen alle zusammen,

habe momentan ein bisschen Probleme mit meinem VSFTPD-Server. Habe gerade apt-get install vsftpd ausgeführt, und den FTP Server installiert.
Danach habe ich die vsftpd.conf Datei ein bisschen angepasst, und immer wenn ich den Server nun stoppen und wieder starten will kommt beim stoppen folgende Meldung:

/etc/init.d/vsftpd stop
Stopping FTP server: vsftpdNo /usr/sbin/vsftpd found running; none killed.

Ich führe den Befehl als Root aus.

Habe jetzt wieder die alte conf zurück gespielt, doch die Meldung erscheint immer noch. Habe den Server auch einfach mal starten lassen, und dann beendet, doch selbe Fehlermeldung.


Was kann ich tun? Wäre schon nicht schlecht, wenn ich den FTP-Server bald laufen hätte. Weil Apache, PHP, Webmin, alles kein Problem. Aber der kleine blöde FTP-Server macht Stress. Dabei läuft der sonst immer tadellos bei mir.

Vielen Dank für eure Hilfe!
mfg Schmitty
Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2484
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Re: VSFTPD-Server lässt sich nicht stoppen?!?

Beitrag von TomcatMJ »

Hi!
Vermutlich wird dein vsftpd neuerdings nicht wie bisher im Standalonemodus betrieben wo du das Start-/Stopscript nutzen könntest sondern läuft inzwischen über xinetd bzw. inetd als Service. Da müsstest du den schon dort in der Konfiguration deaktivieren und den xinetd bzw. inetd reloaden oder restarten.

Bis denne,
Tom
Schmitty
Member
Member
Beiträge: 153
Registriert: 6. Nov 2007, 17:08

Re: VSFTPD-Server lässt sich nicht stoppen?!?

Beitrag von Schmitty »

Hi Tom,

ich frage mich nur grade, wie der vsftpd standalone server zu einem service von xinetd oder inetd geworden ist. Das geht ja nicht einfach mal so nebenbei(hoffe ich).

Wie bekomme ich den vsftpd server wieder in den standalone betrieb gekloppt?
Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2484
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Re: VSFTPD-Server lässt sich nicht stoppen?!?

Beitrag von TomcatMJ »

Da ich ja nun nicht genau weiss welche Distri du einsetzt vermute ich einfach mal daß da vielleicht etwas im bei der Installation per apt im Konfigurationsscript stand was da eine Date unter /etc/xinet.d angelegt hat wodurch der vsftpd im xinetd aktiviert wurde. Wenn der vsftpd dort also drinsteht müsstest du nur in der dort liegenden zu vsftpd gehörigen Datei den vsftpd eben wieder disablen damit er gemäß seiner wohl von dir selbst bearbeiteten Konfiguration im reinen daemon-Mode (also standalone) laufen kann udn somit auch wieder gezielt start- und stopbar ist.

Bis denne,
Tom
Schmitty
Member
Member
Beiträge: 153
Registriert: 6. Nov 2007, 17:08

Re: VSFTPD-Server lässt sich nicht stoppen?!?

Beitrag von Schmitty »

also ich habe jetzt mal den vsftpd server neuinstalliert, (deinstalliert, und installiert) aber irgendwie läuft noch immer nichts ordendlich.

nach der neuinstallation bin ich jetzt soweit, dass ich mich per anonymus mit dem server verbinden kann (was ich aber eig nicht brauche XD)

dies hier ist meine conf

Code: Alles auswählen

# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
#
# Run standalone?  vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
listen=YES
#
# Run standalone with IPv6?
# Like the listen parameter, except vsftpd will listen on an IPv6 socket
# instead of an IPv4 one. This parameter and the listen parameter are mutually
# exclusive.
#listen_ipv6=YES
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=YES
#
# Uncomment this to allow local users to log in.
#local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
#write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format
#xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may restrict local users to their home directories.  See the FAQ for
# the possible risks in this before using chroot_local_user or
# chroot_list_enable below.
#chroot_local_user=YES
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
#
# Debian customization
#
# Some of vsftpd's settings don't fit the Debian filesystem layout by
# default.  These settings are more Debian-friendly.
#
# This option should be the name of a directory which is empty.  Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
secure_chroot_dir=/var/run/vsftpd
#
# This string is the name of the PAM service vsftpd will use.
pam_service_name=vsftpd
#
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.
rsa_cert_file=/etc/ssl/certs/vsftpd.pem
Ist aber die originale konfiguriation XD

wenn ich den server nun beenden, und wieder starten will, kommt beim beenden folgende meldung:

root@vs2064092:/etc# vsftpd stop
500 OOPS: vsftpd: cannot open config file:stop
root@vs2064092:/etc# vsftpd stop /etc/vsftpd.conf
500 OOPS: vsftpd: too many arguments (I take an optional config file only)


wie bekomme ich den server nun neugestartet.

laut netstat -tulpen läuft vsftpd auf den port 21. also kein inet oder xineds....

langsam machts mir kein spaß mehr ;-)

danke!
mfg Schmitty =)
Schmitty
Member
Member
Beiträge: 153
Registriert: 6. Nov 2007, 17:08

Re: VSFTPD-Server lässt sich nicht stoppen?!?

Beitrag von Schmitty »

TomcatMJ hat geschrieben:Da ich ja nun nicht genau weiss welche Distri du einsetzt vermute ich einfach mal daß da vielleicht etwas im bei der Installation per apt im Konfigurationsscript stand was da eine Date unter /etc/xinet.d angelegt hat wodurch der vsftpd im xinetd aktiviert wurde. Wenn der vsftpd dort also drinsteht müsstest du nur in der dort liegenden zu vsftpd gehörigen Datei den vsftpd eben wieder disablen damit er gemäß seiner wohl von dir selbst bearbeiteten Konfiguration im reinen daemon-Mode (also standalone) laufen kann udn somit auch wieder gezielt start- und stopbar ist.

Bis denne,
Tom
Hallo Tom =)

Ich nutze Debian 4.0 64-bit Version.


Ich weiß nicht ob das bei vServer vllt normal ist, aber ich finde keine inetd oder xinetd datei ....

in der top sehe ich allerdings inetd arbeiten. und eine inetd.conf finde ich auhc. dort ist ftp allerdings nicht eingetragen...


*EDIT*!!!!

Habe nun den inetd dienst gefunden, und bin nun auch in der lage ihn zu restarten usw... =)

xinetd scheint allerdings nicht installiert zu sein. sollte ich dies installieren? ist es wichtig? oder funktioniert der vsftpd server auch ohne?
Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2484
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Re: VSFTPD-Server lässt sich nicht stoppen?!?

Beitrag von TomcatMJ »

vsftpd läuft am besten ohne die nutzung von indetd oder xinetd udn zwar egal ob als eigener daemon oder im (x)inietd eingebunden per default immer auf den normalen ftp-ports. Bei der Wahl zwischen inetd oder xinetd (beide machen im Grunde dasselbe, xinetd nur etwas genauer einstellbar und mit paar konzeptbedingten Unsicherheitsmöglichkeiten weniger) würede ich aus Sicherheits-, Modularitäts- und Konfigurierbarkeitsgründen zum xinetd tendieren. Für vsftpd wäre das alelrdings nicht wirklich für die Nutzung sinnvoll da bei einem per inetd bzw. xinetd auf jede anfrage ein kompületter vsftpd gestartet werden würde was bei mehreren Zugriffen zugleich schnell zu performanceengpässen im System führen kann.http://www.linupedia.org/opensuse/Vsftpd und die zugehörigen Musterkonfigurationen zum vsftpd für die Erklärung der diversen möglichen Parameter auf deutsch hast du dir schonmal angesehen nehme ich an,oder?

Bis denne,
Tom
Schmitty
Member
Member
Beiträge: 153
Registriert: 6. Nov 2007, 17:08

Re: VSFTPD-Server lässt sich nicht stoppen?!?

Beitrag von Schmitty »

also mir is das jetzt mit vsftpd langsam zu doof. ich hab mir grad mal proftpd installiert. sieht aber irgendwie auch alles nicht besser aus :-/

das wiki hab ich natürlich schon geguckt =) aber da gabs ja nur sachen zu der konfig. der vsftpd server lief ja nichtmal mit der original konfig sauber ;-)
was soll ich dann noch an der konfig rumspielen? :P

naja, jetzt probiere ich mal ob ich den proftpd server ans rennen bekomme.

ansonsten bekomm ich hier noch die kriese XD
cero
Guru
Guru
Beiträge: 2292
Registriert: 5. Mai 2004, 20:33
Wohnort: nähe Buchholz i.d.N.

Re: VSFTPD-Server lässt sich nicht stoppen?!?

Beitrag von cero »

Ich hatte neulich unter Debian 5.0 das selbe Problem. Ich hatte aber keine Lust und Zeit
mich damit genauer zu beschäftigen.
Ich habe meine vsftpd.conf gesichert und ein

Code: Alles auswählen

apt-get --purge remove vsftpd
gemacht. Danach wieder neu installiert, .config rein und alles ging wieder.
Ist zwar nicht die richtige Art, aber es passte und mehr wollte ich nicht.
Wissen, was man weiß,
und wissen, was man nicht weiß,
das ist wahres Wissen.
(Konfuzius)


"Auf der dunklen Seite gibt es keine Kekse, Luke! Bleib lieber hier!" - Obi-Wan Kenobi
Schmitty
Member
Member
Beiträge: 153
Registriert: 6. Nov 2007, 17:08

Re: VSFTPD-Server lässt sich nicht stoppen?!?

Beitrag von Schmitty »

hat das problem bei mir leider nicht gelöst. habe das unter der funktion "neuinstallation" deklariert.

proftpd scheint momentan ganz gut zu laufen. habe nur leider noch ein problem damit. hatte das selbe problem auch bei vsftpd, wobei ich dachte dass das daran läge, dass ich noch fehler in der conf hatte.

wenn ich mich mit einem user auf dem server einlogge, dann sehe ich dort keinerlei daten. folgendes gibt der / die / das client log aus:

Code: Alles auswählen

Suche IP Adresse von 85.25.64.92
Versuche 85.25.64.92:21
Verbindung mit 85.25.64.92 erfolgreich:21
220 ProFTPD 1.3.0 Server (Songs-Love-Videoclips) [85.25.64.92]
USER admin

331 Password required for admin.
PASS xxxx
530 Login incorrect.
Beende Verbindung mit Gegenstelle 85.25.64.92
Suche IP Adresse von 85.25.64.92
Versuche 85.xx.xx.xx:21
Verbindung mit xx.xx.xx.xx erfolgreich:21
220 ProFTPD 1.3.0 Server (Songs-Love-Videoclips) [85.25.64.92]
USER XX

331 Password required for XXX.
PASS xxxx
230 User XXX logged in.
SYST

215 UNIX Type: L8
TYPE A

200 Type set to A
PWD

257 "/" is current directory.
Lade Verzeichnisliste / von der Gegenstelle (LC_TIME=de_DE.UTF-8)
PASV

227 Entering Passive Mode (85,25,64,92,159,94).
Ab dann kommt nichts mehr. Bekomme keine auflistung der Verzeichnisse :-/

Hat jemand eine Idee?

Danke =)


*edit*
Serverlog aus dem Zeitraum

Code: Alles auswählen

Apr 05 20:34:37 vs2064092.vserver.de proftpd[3544] vs2064092.vserver.de (91.57.246.128[91.57.246.128]): FTP session opened.
Apr 05 20:34:37 vs2064092.vserver.de proftpd[3544] vs2064092.vserver.de (91.57.246.128[91.57.246.128]): mod_delay/0.5: delaying for 43 usecs
Apr 05 20:34:37 vs2064092.vserver.de proftpd[3544] vs2064092.vserver.de (91.57.246.128[91.57.246.128]): USER admin: Login successful.
Apr 05 20:34:37 vs2064092.vserver.de proftpd[3544] vs2064092.vserver.de (91.57.246.128[91.57.246.128]): wtmp /var/log/wtmp: No such file or directory
Apr 05 20:34:37 vs2064092.vserver.de proftpd[3544] vs2064092.vserver.de (91.57.246.128[91.57.246.128]): Preparing to chroot to directory '/var/www'
Apr 05 20:36:32 vs2064092.vserver.de proftpd[3544] vs2064092.vserver.de (91.57.246.128[91.57.246.128]): wtmp /var/log/wtmp: No such file or directory
Apr 05 20:36:32 vs2064092.vserver.de proftpd[3544] vs2064092.vserver.de (91.57.246.128[91.57.246.128]): FTP session closed.
was ist dises wtmp???
Antworten