Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Nach Update startet apache nicht bei Neustart

Alles rund um die verschiedenen Konsolen und shells sowie die Programmierung unter Linux

Moderator: Moderatoren

Antworten
Benutzeravatar
DerArne
Member
Member
Beiträge: 81
Registriert: 25. Feb 2007, 22:15
Wohnort: Dortmund

[gelöst] Nach Update startet apache nicht bei Neustart

Beitrag von DerArne »

Hi,
nach dem Updaten von Suse 11.4 auf 12.1 startete der apache2-Dienst bei mir nicht beim Neustart des Systems.
Im Yast-Runlevel-Editor ist apache2 für die Runlevel 3 und 5 eingetragen. Nützt aber nichts.

Lösung:
Mittels systemctl is-enabled zeigt sich, dass der Dienst nicht angemeldet ist

Code: Alles auswählen

linux:~ # systemctl is-enabled apache2.service
disabled
apache2  off
Eine gute Übersicht, welche Dienste prinzipiell existieren, und ob sie laufen oder nicht, könnt Ihr mit einem einfachen systemctl ohne weitere Parameter erfahren.
Alles ist für cron im SDB-Artikel http://en.opensuse.org/SDB:Systemd beschrieben.
Mittels systemctl kann man dann den Dienst auch anmelden/einschalten.

Code: Alles auswählen

linux:~ # systemctl enable apache2.service
ln -s '/lib/systemd/system/apache2.service' '/etc/systemd/system/multi-user.target.wants/apache2.service'

der Dienst ist nun angemeldet und startet beim Neustart mit.

Code: Alles auswählen

linux:~ # systemctl is-enabled apache2.service
enabled

Mein Tipp: Sollten also irgendwelche Dienste nicht richtig starten, schaut nicht im Yast-Runlevel-Editor nach, sondern nehmt systemctl.

Viele Grüße
Arne
Werbung:
Antworten