Seite 1 von 1

[ERLEDIGT] Samba gibt Home doppelt frei

Verfasst: 28. Jan 2019, 11:29
von bunter fisch
Hallo,

ich hab unter Xubuntu 18.04 mit Samba den Home-Ordner immer doppelt, einmal als 'Homes' und einmal mit dem Benutzernamen. Ich in der smb.conf nichts weiter gemacht als die voreingestellten settings auszukommentieren. Da steht dann nur

Code: Alles auswählen

writeable = yes
Kein Pfad und auch kein zweiter Eintrag der home doppelt erstellt. Kommentierte ich den wieder aus, sind beide weg. Ich kann mit beiden alles machen vom clienten aus.

Was muss ich einstellen, damit der nur einmal angezeigt wird?

Re: Samba gibt Home doppelt frei

Verfasst: 28. Jan 2019, 18:24
von Sauerland
Mal die /etc/samba/smb.conf posten?

Re: Samba gibt Home doppelt frei

Verfasst: 1. Feb 2019, 17:11
von bunter fisch
Ich poste jetzt mal nur den von mir geänderten Teil, der Rest ist default.

Code: Alles auswählen

[homes]
browseable = yes
writeable = yes
;   read only = yes

[data1]
path = /media/data1
writeable = yes
read-only = no

[data2]
path = /media/data2
writeable = yes
read-only = no

Re: Samba gibt Home doppelt frei

Verfasst: 2. Feb 2019, 18:20
von spoensche
Der Abschnitt [homes] gilt für alle Benutzer und deren Home Verzeichnisse.

Du hast in diesem Abschnitt die Option

Code: Alles auswählen

browsable = yes
gesetzt und daher bekommst du dein Home Verzeichnis zwei mal angezeigt.

Re: Samba gibt Home doppelt frei

Verfasst: 6. Feb 2019, 15:56
von bunter fisch
OK, scheint so zu gehen. Danke.

Re: Samba gibt Home doppelt frei

Verfasst: 8. Feb 2019, 19:44
von spoensche
Erledige bitte noch die "Formalitäten" und setze den Thread auf gelöst. Danke.

Re: [gelöst] Samba gibt Home doppelt frei

Verfasst: 11. Feb 2019, 13:29
von bunter fisch
Auf einem anderen Rechner, auch mit Ubuntu, geht das irgendwie nicht. Die smb.conf ist die gleiche wie oben. Gibt es noch andere Sachen die das beeinflussen?

Re: Samba gibt Home doppelt frei

Verfasst: 12. Feb 2019, 18:16
von spoensche
Dort musst du auch

Code: Alles auswählen

browseable = no
setzen. Poste mal die smb.conf

Re: Samba gibt Home doppelt frei

Verfasst: 13. Feb 2019, 11:58
von bunter fisch
So geht es jetzt, bin mir aber sicher, dass ich bei dem anderen auch browseable einfach gelöscht hab statt auf no zu setzen.

Re: [ERLEDIGT] Samba gibt Home doppelt frei

Verfasst: 13. Feb 2019, 12:53
von marce
https://www.samba.org/samba/docs/curren ... BROWSEABLE

-> default: yes

... kann aber gut sein, daß das jede Distri für sich ein wenig anders in den "default-Konfigs" setzt

-> Empfehlung des Tages: sich nie auf Default-Values verlassen, Werte immer setzen.