Seite 1 von 1

[gelöst]als normaler Benutzer kein Zugriff auf NFS mount

Verfasst: 3. Feb 2018, 22:26
von mafg
Hallo,

von meinem PC, auf dem openSUSE 42.3 läuft möchte ich gerne auf ein Synology NAS (DS214play) auf der die aktuell verfügbare DSM-Version läuft per NFS mount zugreifen.
Dazu ist der NFS-Client auf dem PC eingerichtet und der Port in der Firewall geöffnet. Auf dem NAS sind die entsprechenden Freigaben eingerichtet. Das Laufwerk ist mit folgendem Eintrag in /etc/fstab versehen:

Code: Alles auswählen

192.168.178.28:/volume1/Musik   /media/Musik    nfs     rw,suid,dev,exec,noauto,user 0 0
Der Mount-Vorgang erfolgt erst, wenn das Laufwerk, z.B. in Dolphin angeklickt wird. Allerdings kann ich als Nutzer ohne Administratorenrechte nicht darauf zugreifen, obwohl ich es als solcher mounten kann.

Der Zielordner "gehört" dem normalen Nutzer, wird aber, sobald gemountet wird root zugewiesen.

Wie kann ich das verhindern?

Dank und Gruß,
mafg

Re: als normaler Benutzer kein Zugriff auf NFS mount

Verfasst: 3. Feb 2018, 23:21
von josef-wien
Ich nehme an, es ist ein Linux-Dateisystem. Mit dem Einhängen wird dem Einhängepunkt die Berechtigung des Dateisystems zugewiesen (und solange das nicht geändert wird, ist der Eigentümer üblicherweise root). Was ein Benutzer dann dort machen darf, entspricht den vergebenen Berechtigungen. Denke daran, daß Benutzer- und Gruppennamen Schall und Rauch sind und nur die numerischen UID bzw. GID gelten.

Re: als normaler Benutzer kein Zugriff auf NFS mount

Verfasst: 4. Feb 2018, 11:08
von spezi
Hast Du das HIER mal angeschaut? Auch die Sache mit den UID's.

mfg
spezi

Re: als normaler Benutzer kein Zugriff auf NFS mount

Verfasst: 4. Feb 2018, 19:11
von spoensche
mafg hat geschrieben:
3. Feb 2018, 22:26

Code: Alles auswählen

192.168.178.28:/volume1/Musik   /media/Musik    nfs     rw,suid,dev,exec,noauto,user 0 0
Die Option suid nimmst du ganz schnell wieder raus. Du weisst was SUID bewirkt?

Zu deinem Problem:

1. Vergleiche mal die User ID deines Benutzers vom SuSI Rechner mit der auf dem NAS. Damit du 1:1 die gleichen Berechtigungen hast, muss die User ID gleich sein.

2. Wenn sie nicht gleich ist, dann musst du mittels idmap die User ID mappen.

Re: als normaler Benutzer kein Zugriff auf NFS mount

Verfasst: 5. Feb 2018, 19:15
von mafg
Hallo,
der Link von spezi war hilfreich. Nach dem Angleichen der UID funktioniert es problemlos.
Danke!

@spoensche

Code: Alles auswählen

man mount(8)

Code: Alles auswählen

defaults
              Use the default options: rw, suid, dev, exec, auto, nouser, and async.

Code: Alles auswählen

suid   Allow set-user-ID or set-group-ID bits to take effect.
Nachdem suid in den mount options bei den defaults aufgelistet ist, habe ich es einfach übernommen, da yast den NFS-mount nur mit der Option "defaults" in /etc/fstab eingetragen hatte. Dort habe ich es geändert, weil ich kein automount haben möchte. Was es tatsächlich bewirkt ist mir zugegebenermaßen nicht klar, da mir der Eintrag in man mount auch nicht wirklich weiter geholfen hat.
Ich habe es auf deinen dringend erscheinenden Rat wieder gestrichen.

Gruß,
mafg

Re: [gelöst]als normaler Benutzer kein Zugriff auf NFS mount

Verfasst: 7. Feb 2018, 10:55
von stka
Ohne "suid" als mount-Option funktioniert es nicht mehr den Gruppenbesitz an eine bestimmte Gruppe zu übergeben. Wenn ich als ein Verzeichnis mit "4770 root g1" anlege, dann werden alle Einträge immer der Gruppe "g1" gehören, egal welche default-Gruppe der Benutzer selber hat. Setzt du das "suid" nicht, funktioniert das nicht mehr.