Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

lamp aufsetzen: apache lässt sich nicht konfigurieren.

Alles rund um die Server (Web-, Mail-, Datenbank-, Datenaustausch-, etc.) die man unter Linux betreiben kann

Moderator: Moderatoren

Antworten
lin
Hacker
Hacker
Beiträge: 623
Registriert: 24. Mai 2010, 19:16

lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von lin » 7. Mär 2014, 22:21

hallo u. guten abend


will auf 13 .1 den Lamp aufsetzen - und bin nach dieser Anleitung vorgegangen:

http://mntechblog.de/artikelserie-webse ... tallieren/

habe auf opensuse 13.1 die FRAGE wie man den http konfiguriert?

Frage: geht das (mit dem http-konfigurieren) denn auch wenn ich den knetworkmanager am laufen habe oder komme ich unter diesen Umstaendne nicht auf die Konfigurationsoptioen?

Ich kann:
a. nicht den firewall hinzufuegen
b. auch nicht 127.0.0.1 hinzufuegen

das geht alles nicht.

Wie kann ich verfahren? Was kann ich tun?

btw: alles alles andere was ich zu dem lamp noch brauche geht
mysql ist eingerichtet, runlevel läuft und mysql
der phpmyadmin ist auch installiert.


wenn ich aber den localhost aufrufen will - dann krieg ich nur eine Fehlermeldung;

Fehler: Verbindung fehlgeschlagen
Firefox kann keine Verbindung zu dem Server unter localhost aufbauen.


was kann ich machen - wie soll ich vorgehen.

freu mich auf einen tipp

viele Gruesse
lin ;)
- lin

Notebooks:
Akoya - P 6512 15" OpenSuse Leap: AMD Athlon X2 P320, 2,10 GHz, 4 GB
HP Notebook hp 14 r 103ng - Versuch OpenSuse Leap 42.1
Samsunng q 210, 12,1" OpenSuse 13.2: Intel® Core™ 2 Duo Proz. P8400 2,26 GHz 1066 MHz FSB 3 MB

Werbung:
luwa
Member
Member
Beiträge: 151
Registriert: 6. Mär 2009, 18:01

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von luwa » 18. Mär 2014, 01:43

warum lamp?
Linux bietet alles um einen Web bzw. und, MySql Server auf zu setzen. lamp ist die Trial-Version, das heißt probieren OK, funktioniert sofort, aber unsicher. Ließ Apache für Dummies und wenn Du mehr wissen willst gib Geld aus für Fachliteratur.
In der Hilfe von SuSE, kann man installieren, kannst Du auch lesen.
Deine Frage wie man den httpd konfiguriert kann ich nicht beantworten. Ich weiß nicht was Du vorhast.
Der Network-Manager hat nix mit dem Apache zu tun.
Unter Windows läuft der "XAMMP" ohne irgendetwas zu konfigurieren. Problem, ohne SQL-Kenntnisse, ohne PHP, ohne HTML geht es nicht. Du willst lernen OK aber so ganz ohne Basics geht es nicht.
In der Standard Konfig unter Linux machst Du den Apache im Runlevel-Editor an und bekommst im Browser mit IP des Servers ein "IT WORKS". Kriegst Du nicht? Yast-Sicherheit-Firewall, Firewall nach intern? Port 80 aufmachen.
Wenn das nicht reicht, bitte mehr Infos. Was hast Du wo gemacht und warum? Was hast Du vor, erwartest Du.

Und Verzeihung, es wird nicht reichen zu lesen. Du musst auch verstehen was Du ließt. Sorry ließ dies hier drei mal. Und langsam.
Ok ich bin Scheiße.

Gruß aus dem Norden

marce
Advanced Hacker
Advanced Hacker
Beiträge: 1209
Registriert: 19. Jun 2008, 13:16
Wohnort: Dettenhausen
Kontaktdaten:

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von marce » 18. Mär 2014, 09:12

@Luwa: zuerst: Lamp != XAMP. Und wenn Du den Link des TE gelesen hättest, wüsstest Du, daß er die normalen Suse-Pakete verwendet.

@TE: Läuft denn der Apache? Schau mal in dei Prozessliste (ps -fe an der Konsole)
Wenn er nicht läuft -> Schau in die Logs.

luwa
Member
Member
Beiträge: 151
Registriert: 6. Mär 2009, 18:01

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von luwa » 18. Mär 2014, 15:16

@marce
Verdammte Axt, erwischt.

@lin
andere Frage, ne ganz blöde. Ich weiß nicht wo der lamp hin installiert wird aber in /etc/apache/ ist die http.conf schnell zu finden. Falls Du diese editiert hast hat es keine Auswirkungen auf den lamp. Im Eifer des Gefechts kann so was aber schon mal passieren.

Grüße aus dem Norden

lin
Hacker
Hacker
Beiträge: 623
Registriert: 24. Mai 2010, 19:16

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von lin » 30. Mär 2014, 23:20

hallo LuWa und marce

vlelen Dank für die Tipps / die guten Fragen und die Kommentare: also besser muss ich sagen, dass ich versucht habe den Apache hier auf der opensuse 13.1 einzurichten.

bin nach der folgenden Anleitung vorgegangen:

Code: Alles auswählen

linux-70ce:/home/martin # Passwort:
If 'Passwort:' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf Passwort:
linux-70ce:/home/martin # zypper in apache2 php5
Metadaten von Repository 'Packman' werden abgerufen ........................................................................................................................[fertig]
Zwischenspeicher für Repository 'Packman' wird erzeugt .....................................................................................................................[fertig]
Metadaten von Repository 'openSUSE 13.1 OSS Update' werden abgerufen .......................................................................................................[fertig]
Zwischenspeicher für Repository 'openSUSE 13.1 OSS Update' wird erzeugt ....................................................................................................[fertig]
Daten des Repositories laden ...
Installierte Pakete lesen ...
'apache2' ist bereits installiert.
Kein Aktualisierungskandidat für 'apache2-2.4.6-6.10.1.i586'. Die neueste Version ist bereits installiert.
'php5' ist bereits installiert.
Kein Aktualisierungskandidat für 'php5-5.4.20-4.1.i586'. Die neueste Version ist bereits installiert.
Paketabhängigkeiten auflösen ...
Keine auszuführenden Aktionen.
linux-70ce:/home/martin #
dann das hier noch.....

Code: Alles auswählen


linux-70ce:/home/martin #  systemctl start apache2.service
Job for apache2.service failed. See 'systemctl status apache2.service' and 'journalctl -xn' for details.
linux-70ce:/home/martin # 
linux-70ce:/home/martin # systemctl status apache2.service
apache2.service - The Apache Webserver
   Loaded: loaded (/usr/lib/systemd/system/apache2.service; enabled)
   Active: failed (Result: exit-code) since Mo 2014-03-10 00:29:06 CET; 42s ago
  Process: 15667 ExecStop=/usr/sbin/start_apache2 -D SYSTEMD -DFOREGROUND -k graceful-stop (code=exited, status=1/FAILURE)
  Process: 15649 ExecStart=/usr/sbin/start_apache2 -D SYSTEMD -DFOREGROUND -k start (code=exited, status=1/FAILURE)
 Main PID: 15649 (code=exited, status=1/FAILURE)

Mär 10 00:29:06 linux-70ce.site start_apache2[15649]: httpd2-prefork: Syntax error on line 179 of /etc/apache2/httpd.conf: Syntax error on line 102 of /etc/apache2/de... required)
Mär 10 00:29:06 linux-70ce.site systemd[1]: apache2.service: main process exited, code=exited, status=1/FAILURE
Mär 10 00:29:06 linux-70ce.site start_apache2[15667]: httpd2-prefork: Syntax error on line 179 of /etc/apache2/httpd.conf: Syntax error on line 102 of /etc/apache2/de... required)
Mär 10 00:29:06 linux-70ce.site systemd[1]: apache2.service: control process exited, code=exited status=1
Mär 10 00:29:06 linux-70ce.site systemd[1]: Failed to start The Apache Webserver.
Mär 10 00:29:06 linux-70ce.site systemd[1]: Unit apache2.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.
linux-70ce:/home/martin #
und zuletzt noch das hier


Code: Alles auswählen

                                                  
linux-70ce:/home/martin # systemctl status mysql.service                                                                                                                           
mysql.service - LSB: Start the MySQL database server                                                                                                                               
   Loaded: loaded (/etc/init.d/mysql)                                                                                                                                               
   Active: active (running) since Fr 2014-03-07 19:39:48 CET; 2 days ago                                                                                                           
   CGroup: /system.slice/mysql.service                                                                                                                                             
           +- 854 /bin/sh /usr/bin/mysqld_safe --mysqld=mysqld --user=mysql --pid-file=/var/run/mysql/mysqld.pid --socket=/var/run/mysql/mysql.sock --datadir=/var/lib/mysql       
           +-1095 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib/mysql/plugin --user=mysql --log-error=/var/lib/mysql/linux-70ce.site.err --pid-f...
                                                                                                                                                                                   
Mär 07 19:39:43 linux-70ce.site systemd[1]: Starting LSB: Start the MySQL database server...                                                                                       
Mär 07 19:39:48 linux-70ce.site mysql[694]: Starting service MySQL ..done
Mär 07 19:39:48 linux-70ce.site systemd[1]: Started LSB: Start the MySQL database server.
linux-70ce:/home/martin #

hmm - noch läft das nicht. Was meint ihr denn - ich denk dass da noch ein Fehler drinne ist!

Werde nochmals nachsehen.

vg lin ;)
- lin

Notebooks:
Akoya - P 6512 15" OpenSuse Leap: AMD Athlon X2 P320, 2,10 GHz, 4 GB
HP Notebook hp 14 r 103ng - Versuch OpenSuse Leap 42.1
Samsunng q 210, 12,1" OpenSuse 13.2: Intel® Core™ 2 Duo Proz. P8400 2,26 GHz 1066 MHz FSB 3 MB

luwa
Member
Member
Beiträge: 151
Registriert: 6. Mär 2009, 18:01

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von luwa » 31. Mär 2014, 02:26

Hey lin,

was mich von der Rolle bringt ist das der lampp nicht läuft. Das Teil sollte so gebaut sein das es läuft. Lampp unter Linux hab ich noch nicht gemacht, weil, blöder Besserwisser :zensur: , es einfach ist unter Linux den Apache zum rödeln zu bringen. Unter Windows zum Probieren hab ich das Dingen schon laufen gehabt. Auch mit 2 mal runterladen und installieren, anyway. Dein log sagt das in Zeile 102 und 179 der http.conf ein Syntax Error ist. Schieb das Ding mal rüber. Bin kein Crack habe aber schon den einen.... naja Webserver hochgefahren. Ich schau mal rein, also die http.conf. :???:
Was ich gern wüsste. Warum Lampp? Unter all den Membern hier bin ich wahrscheinlich der DAU. Ich habe unter Linux den Apache und den MySql hochgebaut, ein eGroupware raufgeschoben und erst dann unter Windows den Lampp als Trial, zum Probieren, angefahren. Ich stelle Dir gern meine vhosts.conf zur Verfügung, zwei Webseiten, unter Port 80 (Urlaubsfotos) und 443 (eGroupware). Ist halt keine Lampp.config sondern der Apache im Linux.
Nö, ist schon klar Du willst Deine html Kenntnisse ausprobieren im Lampp :schockiert: . Aber wenn Du keinen Web-Server (also Deine Maschine) im Netz hast dann lass uns darüber reden wie Du den Apache als Dienst in Deiner Maschine hochfährst.

Gruß aus dem Norden

lin
Hacker
Hacker
Beiträge: 623
Registriert: 24. Mai 2010, 19:16

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von lin » 31. Mär 2014, 20:55

hi und guten Abend

Hab das nach dieser Anleitung gemacht.

http://mntechblog.de/webserver-lamp-unt ... tallieren/

das passt halt nicht mehr zur version 13.1 - werde nochmals alles pruefen.

update: hab jetzt mal das hier noch gemacht:

Code: Alles auswählen

inux-70ce:/home/martin #
linux-70ce:/home/martin # https://forums.opensuse.org/showthread.php/496144-configuring-Apache-in-Opensuse-13-1-some-thing-fails/page2
bash: https://forums.opensuse.org/showthread.php/496144-configuring-Apache-in-Opensuse-13-1-some-thing-fails/page2: Datei oder Verzeichnis nicht gefunden
linux-70ce:/home/martin # zypper in -f apache2
Daten des Repositories laden ...
Installierte Pakete lesen ...
Installation von 'apache2-2.4.6-6.15.1.i586' aus Repository 'openSUSE 13.1 OSS Update' wird erzwungen.
Paketabhängigkeiten auflösen ...

The following package is going to be reinstalled:
  apache2

1 zu installierendes Paket.
Gesamtgröße des Downloads: 986,1 KiB. Kein zusätzlicher Speicherplatz wird nach dieser Operation belegt oder freigegeben.
Fortfahren? [j/n/? zeigt alle Optionen] (j): j
Paket apache2-2.4.6-6.15.1.i586 wird abgerufen                                                                                                 (1/1), 986,1 KiB (  3,3 MiB entpackt)
Abruf: apache2-2.4.6-6.15.1.i586.rpm .........................................................................................................................[fertig (610,2 KiB/s)]
(1/1) Installation von: apache2-2.4.6-6.15.1 ...............................................................................................................................[fertig]
Zusätzliche rpm-Ausgabe:
/usr/sbin/suexec2: cannot verify root:root 0755 - not listed in /etc/permissions
Updating /etc/sysconfig/apache2...
looking  for old 2.0 modules to be renamed...
Done.


aber ich hab noch keinen localhost.
- lin

Notebooks:
Akoya - P 6512 15" OpenSuse Leap: AMD Athlon X2 P320, 2,10 GHz, 4 GB
HP Notebook hp 14 r 103ng - Versuch OpenSuse Leap 42.1
Samsunng q 210, 12,1" OpenSuse 13.2: Intel® Core™ 2 Duo Proz. P8400 2,26 GHz 1066 MHz FSB 3 MB

Benutzeravatar
StephanS
Member
Member
Beiträge: 79
Registriert: 24. Jan 2005, 22:04

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von StephanS » 9. Apr 2014, 07:45

Du hast die nötigen Pakete erfolgreich installiert und der mysqld läuft. Nur der httpd startet nicht. Die Fehlermeldung hast du schon gepostet:
Syntax error on line 179 of /etc/apache2/httpd.conf: Syntax error on line 102 of /etc/apache2/de... required)
Gibt es dort noch andere

Code: Alles auswählen

httpd.conf*
-Dateien (z.B. httpd.conf.rpmsave)? Kannst du mal den Inhalt von /etc/apache2/httpd.conf, zumindest so um Zeile 102-179 herum hier posten?

lin
Hacker
Hacker
Beiträge: 623
Registriert: 24. Mai 2010, 19:16

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von lin » 9. Apr 2014, 22:00

hi - vielen dank fürs posten.

Code: Alles auswählen

### Global Environment ######################################################
#
# The directives in this section affect the overall operation of Apache,
# such as the number of concurrent requests.

# run under this user/group id
Include /etc/apache2/uid.conf

# - how many server processes to start (server pool regulation)
# - usage of KeepAlive
Include /etc/apache2/server-tuning.conf

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
ErrorLog /var/log/apache2/error_log

# generated from APACHE_MODULES in /etc/sysconfig/apache2
Include /etc/apache2/sysconfig.d/loadmodule.conf

# IP addresses / ports to listen on
Include /etc/apache2/listen.conf

# predefined logging formats
Include /etc/apache2/mod_log_config.conf

# generated from global settings in /etc/sysconfig/apache2
Include /etc/apache2/sysconfig.d/global.conf

# optional mod_status, mod_info
Include /etc/apache2/mod_status.conf
Include /etc/apache2/mod_info.conf

# optional cookie-based user tracking
# read the documentation before using it!!
Include /etc/apache2/mod_usertrack.conf

# configuration of server-generated directory listings
Include /etc/apache2/mod_autoindex-defaults.conf

# associate MIME types with filename extensions
TypesConfig /etc/apache2/mime.types
Include /etc/apache2/mod_mime-defaults.conf

# set up (customizable) error responses
Include /etc/apache2/errors.conf

# global (server-wide) SSL configuration, that is not specific to 
# any virtual host
Include /etc/apache2/ssl-global.conf

# forbid access to the entire filesystem by default
<Directory />
    Options None
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>

# use .htaccess files for overriding,
AccessFileName .htaccess
# and never show them
<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
</Files>

# List of resources to look for when the client requests a directory
DirectoryIndex index.html index.html.var

### 'Main' server configuration #############################################
#
# The directives in this section set up the values used by the 'main'
# server, which responds to any requests that aren't handled by a
# <VirtualHost> definition.  These values also provide defaults for
# any <VirtualHost> containers you may define later in the file.
#
# All of these directives may appear inside <VirtualHost> containers,
# in which case these default settings will be overridden for the
# virtual host being defined.
#
Include /etc/apache2/default-server.conf


# Another way to include your own files
#
# The file below is generated from /etc/sysconfig/apache2,
# include arbitrary files as named in APACHE_CONF_INCLUDE_FILES and
# APACHE_CONF_INCLUDE_DIRS
Include /etc/apache2/sysconfig.d/include.conf
das ist der ausschnitt.....
- lin

Notebooks:
Akoya - P 6512 15" OpenSuse Leap: AMD Athlon X2 P320, 2,10 GHz, 4 GB
HP Notebook hp 14 r 103ng - Versuch OpenSuse Leap 42.1
Samsunng q 210, 12,1" OpenSuse 13.2: Intel® Core™ 2 Duo Proz. P8400 2,26 GHz 1066 MHz FSB 3 MB

Benutzeravatar
StephanS
Member
Member
Beiträge: 79
Registriert: 24. Jan 2005, 22:04

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von StephanS » 10. Apr 2014, 07:10

Die Fehlemeldung bezieht sich wahrscheinlich auf Zeile 179

Code: Alles auswählen

Include /etc/apache2/default-server.conf
und dann auf Zeile 102 von /etc/apache2/default-server.conf, die bei mir

Code: Alles auswählen

IncludeOptional /etc/apache2/conf.d/*.conf
heißt. Frage: Sieht die Zeile 102 von default-server.conf bei dir genauso aus? Was gibt

Code: Alles auswählen

ls -l /etc/apache2/conf.d/*.conf
Kannst du mal die vollständige Fehlermeldung mit

Code: Alles auswählen

systemctl status -l apache2.service
anzeigen lassen?

lin
Hacker
Hacker
Beiträge: 623
Registriert: 24. Mai 2010, 19:16

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von lin » 10. Apr 2014, 12:54

hi - bin grad nicht am notebook aber werde die ausgaben heute abend herstellen u. dann posten.

vielen vielen Dank.

by the way:

wenn ich /etc/apache2/default-server.conf in einem text editor oeffne und die zeile 102 zu "IncludeOptional" wechseln will
dann gehts das nicht einfach da die RECHTE hier root rechte sind.

Muesste das irgendwie anstellen. -jhmm werd mal später ausprobieren ob ich das hinkriege.
Die ausgaben nach denen du fragst poste ich spätestens heute abend.

lg
- lin

Notebooks:
Akoya - P 6512 15" OpenSuse Leap: AMD Athlon X2 P320, 2,10 GHz, 4 GB
HP Notebook hp 14 r 103ng - Versuch OpenSuse Leap 42.1
Samsunng q 210, 12,1" OpenSuse 13.2: Intel® Core™ 2 Duo Proz. P8400 2,26 GHz 1066 MHz FSB 3 MB

Benutzeravatar
StephanS
Member
Member
Beiträge: 79
Registriert: 24. Jan 2005, 22:04

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von StephanS » 12. Apr 2014, 10:25

Unabhängig vom lamp-Problem brauchst du eine Möglichkeit, einen Editor mit root-Rechten auszuführen. Nicht alles läst sich mit Yast einrichten.
  • Erste Möglichkeit: Menü > Systemwerkzeuge > Konsole. Darin "su -" aufrufen und dann einen textbasierten Editor, z.B. "mcedit"
    Zweite Möglichkeit: Menü > Ausführen und "xdg-su -c kwrite" eintippen. Unter Extras > Hervorhebung gibt es dort auch Syntax-Highlighting für Apache-Konfigurationsdateien.
Um Dateiinhalte mit Copy&Paste hier in einen Forumsbeitrag einzufügen, brauchst du keinen Editor. Da reicht auch ein "sudo less /etc/apache2/default-server.conf". Markieren mit gedrückter linker Maustaste und dann einfügen in Firefox mit der mittleren Maustaste.

lin
Hacker
Hacker
Beiträge: 623
Registriert: 24. Mai 2010, 19:16

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von lin » 12. Apr 2014, 14:51

hallo und guten tag

vorweg vielen lieben Dank für die tipps. WERDE am WE. mal die von dir besprochenen Moeglichkeiten in der Apache-Config zu editieren testen. Das ist sicher eine gute moeglichkeit mal hier grundlegend weiterzukommen.

hier die antworten zu den Abfragen:

Code: Alles auswählen

linux-70ce:/home/martin # systemctl status -l apache2.service
apache2.service - The Apache Webserver
   Loaded: loaded (/usr/lib/systemd/system/apache2.service; enabled)
   Active: failed (Result: exit-code) since Sa 2014-04-12 14:21:28 CEST; 24min ago
 Main PID: 771 (code=exited, status=1/FAILURE)
   CGroup: /system.slice/apache2.service


Apr 12 14:21:28 linux-70ce.site start_apache2[771]: httpd2-prefork: Syntax error on line 179 of /etc/apache2/httpd.conf: Syntax error on line 102 of /etc/apache2/default-server.conf: No matches for the wildcard 'apache2-manual?conf' in '/etc/apache2/conf.d', failing (use IncludeOptional if required)
Apr 12 14:21:28 linux-70ce.site systemd[1]: apache2.service: main process exited, code=exited, status=1/FAILURE
Apr 12 14:21:28 linux-70ce.site start_apache2[1269]: httpd2-prefork: Syntax error on line 179 of /etc/apache2/httpd.conf: Syntax error on line 102 of /etc/apache2/default-server.conf: No matches for the wildcard 'apache2-manual?conf' in '/etc/apache2/conf.d', failing (use IncludeOptional if required)
Apr 12 14:21:28 linux-70ce.site systemd[1]: apache2.service: control process exited, code=exited status=1
Apr 12 14:21:28 linux-70ce.site systemd[1]: Failed to start The Apache Webserver.
Apr 12 14:21:28 linux-70ce.site systemd[1]: Unit apache2.service entered failed state.
linux-70ce:/home/martin # systemctl status -l apache2.service
apache2.service - The Apache Webserver
   Loaded: loaded (/usr/lib/systemd/system/apache2.service; enabled)
   Active: failed (Result: exit-code) since Sa 2014-04-12 14:21:28 CEST; 24min ago
 Main PID: 771 (code=exited, status=1/FAILURE)
   CGroup: /system.slice/apache2.service


Apr 12 14:21:28 linux-70ce.site start_apache2[771]: httpd2-prefork: Syntax error on line 179 of /etc/apache2/httpd.conf: Syntax error on line 102 of /etc/apache2/default-server.conf: No matches for the wildcard 'apache2-manual?conf' in '/etc/apache2/conf.d', failing (use IncludeOptional if required)
Apr 12 14:21:28 linux-70ce.site systemd[1]: apache2.service: main process exited, code=exited, status=1/FAILURE
Apr 12 14:21:28 linux-70ce.site start_apache2[1269]: httpd2-prefork: Syntax error on line 179 of /etc/apache2/httpd.conf: Syntax error on line 102 of /etc/apache2/default-server.conf: No matches for the wildcard 'apache2-manual?conf' in '/etc/apache2/conf.d', failing (use IncludeOptional if required)
Apr 12 14:21:28 linux-70ce.site systemd[1]: apache2.service: control process exited, code=exited status=1
Apr 12 14:21:28 linux-70ce.site systemd[1]: Failed to start The Apache Webserver.
Apr 12 14:21:28 linux-70ce.site systemd[1]: Unit apache2.service entered failed state.
linux-70ce:/home/martin # ls -l /etc/apache2/conf.d/*.conf
-rw-r--r-- 1 root root 222 21. Jan 10:59 /etc/apache2/conf.d/gitweb.conf
-rw-r--r-- 1 root root 646  3. Mär 12:28 /etc/apache2/conf.d/manual.conf
-rw-r--r-- 1 root root 692 28. Sep 2013  /etc/apache2/conf.d/mod_perl.conf
-rw-r--r-- 1 root root 354 17. Dez 15:13 /etc/apache2/conf.d/php5.conf
-rw-r--r-- 1 root root 975 28. Feb 10:33 /etc/apache2/conf.d/phpMyAdmin.conf
linux-70ce:/home/martin # IncludeOptional /etc/apache2/conf.d/*.conf

denke dass uns das auch wieder weiterhilft

dir vielen dank schon jetzt.

werde mich am WE wieder melden....
- lin

Notebooks:
Akoya - P 6512 15" OpenSuse Leap: AMD Athlon X2 P320, 2,10 GHz, 4 GB
HP Notebook hp 14 r 103ng - Versuch OpenSuse Leap 42.1
Samsunng q 210, 12,1" OpenSuse 13.2: Intel® Core™ 2 Duo Proz. P8400 2,26 GHz 1066 MHz FSB 3 MB

Benutzeravatar
StephanS
Member
Member
Beiträge: 79
Registriert: 24. Jan 2005, 22:04

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von StephanS » 13. Apr 2014, 11:45

Die Meldung
No matches for the wildcard 'apache2-manual?conf' in '/etc/apache2/conf.d', failing (use IncludeOptional if required)
deutet darauf hin, dass bei dir in /etc/apache2/default-server.conf evtl.
Include /etc/apache2/conf.d/apache2-manual?conf
statt
IncludeOptional /etc/apache2/conf.d/apache2-manual?conf
steht. Das wundert mich ein bisschen, weil ich auch apache2-2.4.6-6.15.1 (allerdings in 64 Bit) habe und hier steht es mit IncludeOptional.

Egal, wir müssen die Apache-Konfiguration hinbekommen. Die Zeile mit dem /etc/apache2/conf.d/apache2-manual?conf kannst du eigentlich komplett löschen. Das wurde ersetzt durch /etc/apache2/conf.d/manual.conf und ist somit in der anderen IncludeOptional-Zeile bereits enthalten. Bei mir sieht das Ende von /etc/apache2/default-server.conf so aus und das funktioniert:
# Include all *.conf files from /etc/apache2/conf.d/.
#
# This is mostly meant as a place for other RPM packages to drop in their
# configuration snippet.
#
# You can comment this out here if you want those bits include only in a
# certain virtual host, but not here.
#
IncludeOptional /etc/apache2/conf.d/*.conf

# The manual... if it is installed ('?' means it won't complain)
IncludeOptional /etc/apache2/conf.d/apache2-manual?conf
Am einfachsten löschst du die Zeile mit dem apache2-manual?conf. Danach funktioniert es entweder gleich (nach systemctl start apache2.service) oder du bekommst eine neue Fehlermeldung.

lin
Hacker
Hacker
Beiträge: 623
Registriert: 24. Mai 2010, 19:16

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von lin » 13. Apr 2014, 20:17

hi - werd das am wochenanfang alles nochmals nachvollziehen.

meld mich wieder.
vielen Dank nochmals ;)
vg lin
- lin

Notebooks:
Akoya - P 6512 15" OpenSuse Leap: AMD Athlon X2 P320, 2,10 GHz, 4 GB
HP Notebook hp 14 r 103ng - Versuch OpenSuse Leap 42.1
Samsunng q 210, 12,1" OpenSuse 13.2: Intel® Core™ 2 Duo Proz. P8400 2,26 GHz 1066 MHz FSB 3 MB

lin
Hacker
Hacker
Beiträge: 623
Registriert: 24. Mai 2010, 19:16

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von lin » 18. Apr 2014, 19:21

hallo


ich habe jetzt die default-server.conf

geaendert und zwar in den letzen Zeilen geht das so::

Code: Alles auswählen

 
Include /etc/apache2/conf.d/apache2-manual?conf
IncludeOptional

das ganze sieht man hier: http://pastebin.com/BrNaueL3

Aber nimmer noch nicht krieg ich das hin mit dem localhost. Da kommt immer noch nichts.

obwohl die runleveldienste - apache u. mysql auf on stehen





hier noch ein wichtiger artikel - zeigt imho die selben probleme:

http://byggvir.de/2014/01/10/opensuse-1 ... pache-2-4/


OpenSUSE 13.1 und Apache 2.4
Der Apache2 Version 2.4 bringt erhebliche Änderungen gegenüber der Version 2.2 mit. Den Versuch eines Updates des Apache2 auf die Version 2.4 auf einem openSUSE 12.2 System habe ich wegen zahlreicher Fehlermeldungen abgebrochen. Aus schlechten Erfahrung klug geworden, habe ich mir eine neues System von Grund auf mit openSUSE 13.1 in einer virtuellen Maschine aufgesetzt. Einen weiteren Abschuss des Servers wollte ich vor einen Upgrade nicht riskieren.

Die Konfiguration des Apache2 mit yast2 führt allerdings auch nicht zu einem lauffähigen System. Der Apache weigert sich mit mehreren Fehlermeldungen zu starten. Unter openSUSE 13.1 wird der Apache 2.4 installiert, obwohl in den Paketnamen die Version 2.2 angegeben ist. Nach einigen Versuchen konnte ich den Fehler in der Datei /etc/apache2/conf.d/mod_evasive.conf lokalisieren. Der Apache2 meldet, dass es das Modul /usr/lib24/apache2/mod_evasive20.so nicht gibt. Eine nachträgliche Installation / Update hilft nicht, denn die Datei heißt jetzt mod_evasive24.so.

Der Fehler kann nun durch Ändern der ersten Zeile in mod_evasive.conf behoben werden. Entweder wird auf das Module verzichtet und die Zeile auskommentiert / gelöscht oder der Dateinamen geändert. Eine Änderung des Modulnamen auf mod_evasive24.c führt allerdings wieder zu Fehlern.
LoadModule evasive20_module /usr/lib64/apache2/mod_evasive24.so
Mit einigen Hinweisen auf wirkungslose, obsolete Parameter startet der Apache2 jetzt.
Zuletzt geändert von lin am 20. Apr 2014, 12:35, insgesamt 1-mal geändert.
- lin

Notebooks:
Akoya - P 6512 15" OpenSuse Leap: AMD Athlon X2 P320, 2,10 GHz, 4 GB
HP Notebook hp 14 r 103ng - Versuch OpenSuse Leap 42.1
Samsunng q 210, 12,1" OpenSuse 13.2: Intel® Core™ 2 Duo Proz. P8400 2,26 GHz 1066 MHz FSB 3 MB

Benutzeravatar
StephanS
Member
Member
Beiträge: 79
Registriert: 24. Jan 2005, 22:04

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von StephanS » 18. Apr 2014, 20:33

Die ganze letzte Zeile muss weg. Dann

Code: Alles auswählen

systemctl start apache2.service
systemctl status -l apache2.service
und schauen, was als Ausgabe kommt.

Benutzeravatar
StephanS
Member
Member
Beiträge: 79
Registriert: 24. Jan 2005, 22:04

Re: lamp aufsetzen: apache lässt sich nicht konfigurieren.

Beitrag von StephanS » 20. Apr 2014, 13:24

Der von dir genannte Artikel trifft hier nicht zu, weil du die Datei /etc/apache2/conf.d/mod_evasive.conf gar nicht hast (dein Post vom 12.04.2014, 13:51). Was ich auch nicht nachvollziehen kann, ist die Aussage zur Version 2.2 im Apache-Paketnamen: Ich habe in Opensuse 13.1 das Paket apache2-2.4.6-6.19.2.x86_64, also Name "apache2", Version "2.4.6", Release "6.19.2", Architektur "x86_64". Hat der Autor vielleicht das "2-2" als Version interpretiert?

Der Punkt ist, dass der apache2-Webserverdienst wegen irgendeines Konfigurationsproblems nicht startet. Und wenn er nicht läuft, kann er auch nicht auf deine Anfrage http://localhost/ antworten. Du musst die Konfiguration kontrollieren. In dem Artikel war es die Datei mod_evasive.conf. Bei dir ist es etwas anderes. Im Moment sind wir noch bei den Include bzw. IncludeOptional-Anweisungen in der Konfigurationsdatei default-server.conf. Schau dir mal offizielle die Dokumentation auf http://httpd.apache.org/docs/current/de ... ml#include und http://httpd.apache.org/docs/current/de ... deoptional an. Höchstwahrscheinlich müssen wir aber in eine der mit Include eingebundenen Dateien schauen, weil es z.B. bei mir mit der normalen default-server.conf keine Probleme gibt.

Antworten