Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Keine Verbindung mit Domänecontroller

Alles rund um die Server (Web-, Mail-, Datenbank-, Datenaustausch-, etc.) die man unter Linux betreiben kann

Moderator: Moderatoren

Antworten
umbz2323
Newbie
Newbie
Beiträge: 17
Registriert: 14. Jun 2012, 10:55

Keine Verbindung mit Domänecontroller

Beitrag von umbz2323 » 25. Jul 2012, 10:43

Hallo,

Hab vor kurzem ein update von SLES 9 SP4 auf SLES 11 SP2 gemacht. Das ganze war leider nicht so erfolgreich wie ich es mir gewünscht hätte.

Seit diesem update kann sich kein XP Client mehr an der Domäne anmelden.

Bekomme dann immer folgende Meldung:

Code: Alles auswählen

Es konnte keine Verbindung mit einem Domönecontroller für die Domäne "sgo-vw" hergestellt werden. Stellen Sie sicher, dass der Domänenname richtig eingegeben wurde .
Meine smg.conf

Code: Alles auswählen

[global]
   #add machine script = /sbin/yast /usr/share/YaST2/data/add_machine.ycp %m$
add machine script=
bind interfaces only=yes
cups options=raw
domain logons=yes
domain master=yes
#lanman auth=yes
#client lanman auth=yes
encrypt passwords=yes
idmap backend=ldapsam:ldap://localhost
interfaces=127.0.0.1, 192.168.0.2
ldap admin dn=cn=Administrator,dc=sgo-verwaltung,dc=org
ldap group suffix=ou=group
ldap idmap suffix=ou=Idmap
ldap machine suffix=ou=Computers
ldap passwd sync=yes
ldap suffix=dc=sgo-verwaltung,dc=org
ldap user suffix=ou=people
local master=yes
   #logon drive = Z:
logon path=\\%L\profiles\%U\%a
logon script=%U.bat
map to guest=Bad User
netbios name=pdc-server
os level=255
passdb backend=ldapsam:ldap://localhost
preferred master=yes
printcap cache time=750
printcap name=cups
printing=cups
security=user
server string=
socket options=SO_KEEPALIVE
smb ports=139
time server=yes
username map=/etc/samba/smbusers
wins support=yes
workgroup=sgo-vw
unix extensions=no
wide links=yes

[netlogon]
comment=Network Logon Service
path=/var/lib/samba/netlogon/%a
browseable=no
guest ok=yes
write list=root
writable=no
share modes=no

[homes]
browseable=no
comment=Home Directories
guest ok=no
inherit permissions=Yes
printable=no
read only=No
valid users=%S
veto files=/+*/.*/Desktop/

[pdf]
browseable=yes
comment=PDF creator
create mask=0600
guest ok=no
path=/var/tmp
print command=/usr/bin/smbprngenpdf -J '%J' -c %c -s %s -u '%u' -z %z
printable=yes

[profiles]
root preexec=/usr/sbin/make_sso.pl %u %I %a
browseable=no
comment=Network Profiles Service
create mask=0600
directory mask=0700
guest ok=no
path=/home/profile
printable=no
read only=No
store dos attributes=Yes

[groups]
browseable=yes
comment=All groups
guest ok=yes
inherit permissions=Yes
path=/home/groups
printable=no
read only=No

[all]
comment=Folder for all
path=/home/all
inherit permissions=Yes
browseable=yes
guest ok=yes
writable=yes

[pc]
root preexec=/usr/sbin/oss_prepair_pc_share.sh %m
comment=Folder for the PCs
path=/home/workstations/%m
inherit permissions=Yes
browseable=yes
guest ok=yes
writable=yes

[allteachers]
comment=Folder for all teacher
path=/home/groups/TEACHERS
browseable=yes
inherit permissions=Yes
valid users=@TEACHERS
force group=TEACHERS
guest ok=no
writable=yes

[alladmins]
comment=Folder for all teacher
path=/home/groups/ADMINISTRATION
browseable=yes
inherit permissions=Yes
valid users=@ADMINISTRATION
force group=ADMINISTRATION
guest ok=no
writable=yes

[software]
comment=Folder for software
path=/home/software
inherit permissions=Yes
browseable=yes
guest ok=yes
writable=yes

[archiv]
browseable=yes
comment=Folder for Arhived Users
valid users=@TEACHERS
guest ok=no
path=/home/archiv
writable=yes

[users]
browseable=yes
comment=All users
guest ok=no
inherit permissions=Yes
path=/home
printable=no
read only=No
valid users=@sysadmins, @TEACHERS
veto files=/aquota.user/

[print$]
browseable=yes
comment=Printer Drivers
create mask=0664
directory mask=0775
force group=ntadmin
guest ok=no
path=/var/lib/samba/drivers
printable=no
write list=@ntadmin root

[printers]
browseable=yes
comment=All Printers
create mask=0600
path=/var/tmp
printable=yes

[itool]
comment=Imaging Tool
path=/srv/itool
inherit permissions=Yes
valid users=@TEACHERS, @sysadmins
browseable=no
guest ok=no
writable=yes
Dachte vllt das es an der SSID von der Domäne liegt ist aber noch die alte.

Wenn ich mich dann lokal an den clients anmelde kann ich auch kein Netzlauufwerk verbinden. Der Fragt immer nach Benutzer und Password. Aber egal was ich eingebe es wird davon nichts akzeptiert. Bin mir gerade aber nciht sicher ob das mit Samba zusammenhängne kann.

mfg

Werbung:
spoensche
Moderator
Moderator
Beiträge: 7396
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Keine Verbindung mit Domänecontroller

Beitrag von spoensche » 25. Jul 2012, 20:04

Hast du einen LDAP auf dem Samba laufen? Wenn nicht, dann musst du die Zeilen in der Konfiguration deaktivieren. Sind die Rechner auch alle in der Domäne? Ist der Samba der einzige Domänencontroller im Netz? Was sagen die Logfiles?

umbz2323
Newbie
Newbie
Beiträge: 17
Registriert: 14. Jun 2012, 10:55

Re: Keine Verbindung mit Domänecontroller

Beitrag von umbz2323 » 1. Aug 2012, 07:58

Also LDAP läuft auf dem Samba. Vor dem Update waren alle in der Domäne aber nun funzt diese leider nicht mehr. Ja Samba ist der einzigste Domänecontroller im Netz.

Welche Logfiles meinst du genau?

mfg

spoensche
Moderator
Moderator
Beiträge: 7396
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Keine Verbindung mit Domänecontroller

Beitrag von spoensche » 1. Aug 2012, 18:49

Die Logfiles vom Samba

umbz2323
Newbie
Newbie
Beiträge: 17
Registriert: 14. Jun 2012, 10:55

Re: Keine Verbindung mit Domänecontroller

Beitrag von umbz2323 » 7. Aug 2012, 10:01

Hallo,

hier die Logfiles vom Samba

Code: Alles auswählen

[2012/07/20 10:51:20.627067,  0] lib/smbldap.c:799(smb_ldap_start_tls)
  Failed to issue the StartTLS instruction: Connect error
[2012/07/20 10:51:21.633547,  0] lib/smbldap.c:799(smb_ldap_start_tls)
  Failed to issue the StartTLS instruction: Connect error
[2012/07/20 10:51:22.634710,  0] rpc_server/netlogon/srv_netlog_nt.c:785(get_md4pw)
  get_md4pw: Workstation V32-PC01$: account does not have a password
[2012/07/20 10:51:22.634878,  0] rpc_server/netlogon/srv_netlog_nt.c:954(_netr_ServerAuthenticate3)
  _netr_ServerAuthenticate3: failed to get machine password for account V32-PC01$: NT_STATUS_LOGON_FAILURE
[2012/07/20 10:51:22.644775,  0] lib/smbldap.c:799(smb_ldap_start_tls)
  Failed to issue the StartTLS instruction: Connect error
[2012/07/20 10:51:23.651712,  0] lib/smbldap.c:799(smb_ldap_start_tls)
  Failed to issue the StartTLS instruction: Connect error
[2012/07/20 10:51:24.652830,  0] rpc_server/netlogon/srv_netlog_nt.c:785(get_md4pw)
  get_md4pw: Workstation V32-PC01$: account does not have a password
[2012/07/20 10:51:24.653004,  0] rpc_server/netlogon/srv_netlog_nt.c:954(_netr_ServerAuthenticate3)
  _netr_ServerAuthenticate3: failed to get machine password for account V32-PC01$: NT_STATUS_LOGON_FAILURE
[2012/07/20 10:52:49.355340,  0] lib/smbldap.c:799(smb_ldap_start_tls)
  Failed to issue the StartTLS instruction: Connect error
[2012/07/20 10:52:50.362214,  0] lib/smbldap.c:799(smb_ldap_start_tls)
  Failed to issue the StartTLS instruction: Connect error
Sieht für mich so aus als würden Samba und Ldap nicht mehr miteinander kommunizieren. Wobei rcldap status ergibt aber running.

mfg

spoensche
Moderator
Moderator
Beiträge: 7396
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Keine Verbindung mit Domänecontroller

Beitrag von spoensche » 7. Aug 2012, 18:46

[quote=umbz2323]

Code: Alles auswählen

Failed to issue the StartTLS instruction: Connect error
[/quote]

Poste mal bitte die Logs vom LDAP.

Das fehlende Passwort solltest du schnellstmögl. setzen.

stka
Moderator
Moderator
Beiträge: 3287
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Re: Keine Verbindung mit Domänecontroller

Beitrag von stka » 7. Aug 2012, 20:00

Welche Samba-Version war auf dem alten Server und welche ist auf dem neuen Server? Dein Problem ist unter anderem, dass deine Hosts keine Verbindung mehr herstellen können, da das Passwort der Maschine abgelaufen scheint:
[2012/07/20 10:51:22.634710, 0] rpc_server/netlogon/srv_netlog_nt.c:785(get_md4pw)
get_md4pw: Workstation V32-PC01$: account does not have a password
Wichtig ist aber erst mal die Version von beiden Samba und zwar genau bis z.B 3.4.6 also alle drei Stellen.
Du hörst nicht auf zu laufen weil du alt wirst. Du wirst alt weil du aufhörst zu laufen.
Das neue Buch http://www.kania-online.de/fachbuecher

Antworten