Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Benutzer soll in Verzeichnis verbleiben

Alles rund um die Server (Web-, Mail-, Datenbank-, Datenaustausch-, etc.) die man unter Linux betreiben kann

Moderator: Moderatoren

Antworten
gTux
Member
Member
Beiträge: 158
Registriert: 22. Jan 2009, 14:31

Benutzer soll in Verzeichnis verbleiben

Beitrag von gTux » 24. Apr 2012, 10:19

Servus!

Ich habe vfstpd installiert und möchte verhindern dass der ftp Benutzer "myftp1" in das übergeordnete Verzeichnis wechselt. Ihn soll das Verzeichnis /srv/www/htdocs/ zugewiesen werden und er soll darin verbleiben ohne die Möglichkeit in das übergeordnete Verzeichnis zu gehen.

Werbung:
admine
Administrator
Administrator
Beiträge: 8768
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: Benutzer soll in Verzeichnis verbleiben

Beitrag von admine » 24. Apr 2012, 10:44

Schau dir das an:
http://www.danzei.de/archives/24

und noch weitere via Google ;)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

gTux
Member
Member
Beiträge: 158
Registriert: 22. Jan 2009, 14:31

Re: Benutzer soll in Verzeichnis verbleiben

Beitrag von gTux » 25. Apr 2012, 03:00

Servus, das ist leider nicht so einfach wie du denkst.

Ich habe den Benuzter in der /etc/passwd stehen:

Code: Alles auswählen

myftp1:x:1001:1000::/srv/www/htdocs:/bin/false
Meine vsftpd.conf beinhaltet die Zeilen:

Code: Alles auswählen

chroot_local_user=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list
Trotzdem komme ich aus /srv/www/htdocs nach oben raus!

Edit
Habe soeben die Leserechte am Verzeichnis "htdocs" geändert

Code: Alles auswählen

chown myftp1:ftp-users /srv/www/htdocs
und dann in der /etc/vsftpd.chroot_list den Namen "myftp1" raugenommen - da hatte ich was verdreht. Doch jetzt lande ich direkt beim Wurzelpfad "/" mit den FTP client.

Code: Alles auswählen

tail -f /var/log/messages
Apr 25 03:08:48 b203 kernel: [527738.471932] lo: Disabled Privacy Extensions
Apr 25 03:08:49 b203 vsftpd[1]: [myftp1] OK LOGIN: Client "xxx.xxx.xxx.32"
Apr 25 03:08:49 b203 kernel: [527738.740820] lo: Disabled Privacy Extensions
Apr 25 03:08:49 b203 vsftpd[1]: [myftp1] FTP response: Client "xxx.xxx.xxx.32", "230 Login successful."
Apr 25 03:08:49 b203 vsftpd[1]: [myftp1] FTP command: Client "xxx.xxx.xxx.32", "OPTS UTF8 ON"
Apr 25 03:08:49 b203 vsftpd[1]: [myftp1] FTP response: Client "xxx.xxx.xxx.32", "200 Always in UTF8 mode."
Apr 25 03:08:49 b203 vsftpd[1]: [myftp1] FTP command: Client "xxx.xxx.xxx.32", "PWD"
Apr 25 03:08:49 b203 vsftpd[1]: [myftp1] FTP response: Client "xxx.xxx.xxx.32", "257 "/""
Da bin ich jetzt ganz verwirrt - eigentlich sollte jeder der in der Datei "/etc/vsftpd.chroot_list" gespeichert ist, uneingeschränkt aus seinem chroot rauskommen können - das hat aber keinen Einfluß. Ob in der Datei eingetragen oder nicht, der User kommt raus bzw. (wenn nicht in der vsftpd.chroot_list eingetragen) landet gleich beim "/".

bolder
Member
Member
Beiträge: 120
Registriert: 20. Mär 2006, 09:08
Wohnort: Mainz

Re: Benutzer soll in Verzeichnis verbleiben

Beitrag von bolder » 25. Apr 2012, 08:12

Der Eintrag in die /etc/passwd sollte so aussehen:

Code: Alles auswählen

myftp1:x:1001:1000::/srv/www/htdocs/./:/bin/false

gTux
Member
Member
Beiträge: 158
Registriert: 22. Jan 2009, 14:31

Re: Benutzer soll in Verzeichnis verbleiben

Beitrag von gTux » 26. Apr 2012, 23:01

Das war es zwar nicht, aber ich habe trotzdem das ganze gelöst.

In der vsftpd.conf die Einträge einfach mit einer "#" ausgeschaltet

Code: Alles auswählen

chroot_list_enable=YES
chroot_list_file=/etc/vsftpd.chroot_list
Und schon bleibt der user brav im Knast.

Danke für die Hilfeversuche

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast