Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] smb.conf Kein Zugriff auf Verzeichnisse per ln -s

Alles rund um die Server (Web-, Mail-, Datenbank-, Datenaustausch-, etc.) die man unter Linux betreiben kann

Moderator: Moderatoren

Antworten
sphings
Member
Member
Beiträge: 73
Registriert: 3. Jun 2004, 13:27

[gelöst] smb.conf Kein Zugriff auf Verzeichnisse per ln -s

Beitrag von sphings » 3. Apr 2012, 16:30

Hallo,

ich habe ein Problem.
Ich habe per samba ein Verzeichnis freigegeben.
/home/auction/bilderarchiv
darin befinden sich per ln -s angelegte Symbolische Links auf

Code: Alles auswählen

auction@intranet:~/pixmerge/bilderarchiv> ll
insgesamt 0
lrwxrwxrwx 1 auction users 51  3. Apr 16:17 2008 -> /home/auction/pixmerge/festplatten/intern/sdb1/2008
lrwxrwxrwx 1 auction users 51  3. Apr 16:17 2009 -> /home/auction/pixmerge/festplatten/intern/sdb1/2009
lrwxrwxrwx 1 auction users 51  3. Apr 16:17 2010 -> /home/auction/pixmerge/festplatten/intern/sdb1/2010
lrwxrwxrwx 1 auction users 51  3. Apr 16:17 2011 -> /home/auction/pixmerge/festplatten/intern/sdb1/2011
lrwxrwxrwx 1 auction users 51  3. Apr 16:17 2012 -> /home/auction/pixmerge/festplatten/intern/sdc1/2012
ein Zugriff aus dem Windows Netzwerk ist nicht möglich.
Hat jemand eine Idee warum?

meine smb.conf:

Code: Alles auswählen

[global]
        workgroup = Arbeitsgruppe
        printcap name = cups
        cups options = raw
        include = /etc/samba/dhcp.conf
        map to guest = Bad User
        guests account = nobody
        read only = no
        unix password sync = yes
        password program = /usr/bin/passwd %u
        passdb backend = smbpasswd
        wins support = No
        netbios name = suse
        usershare max shares = 100
        ldap suffix =
        wins server =
...
[bilderarchiv]
        path = /home/auction/pixmerge/bilderarchiv
        case sensitive = no
        guest ok = yes
        force user = auction
        read only = No
        #hide files = /.*/
in /home/festplatten/intern/sdb1 sind folgende verzeichnisse vorhanden:

Code: Alles auswählen

auction@intranet:~/pixmerge/festplatten/intern/sdb1> ll
insgesamt 32
drwxrwxrwx 5 auction users  4096  3. Apr 16:12 2008
drwxrwxrwx 5 auction users  4096  3. Apr 15:18 2009
drwxrwxrwx 5 auction users  4096  3. Apr 15:18 2010
drwxrwxrwx 5 auction users  4096  3. Apr 15:18 2011
in /home/festplatten/intern/sdc1 sind folgende verzeichnisse vorhanden:

Code: Alles auswählen

auction@intranet:~/pixmerge/festplatten/intern/sdc1> ll
insgesamt 20
drwxrwxrwx 5 auction users  4096  3. Apr 15:16 2012
Da das Bilderarchiv inzwischen weit über 5 TB groß ist und weiter wächst lässt sich das leider nicht mehr auf einer Festplatte verwalten ...

Gruß

sphings
Zuletzt geändert von sphings am 4. Apr 2012, 13:41, insgesamt 1-mal geändert.

Werbung:
stka
Moderator
Moderator
Beiträge: 3284
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Re: smb.conf Kein Zugriff auf Verzeichnisse per ln -s möglic

Beitrag von stka » 3. Apr 2012, 16:34

Setze mal die beiden Parameter:
follow symlinks = yes
wide links = yes
Du hörst nicht auf zu laufen weil du alt wirst. Du wirst alt weil du aufhörst zu laufen.
Das neue Buch http://www.kania-online.de/fachbuecher

sphings
Member
Member
Beiträge: 73
Registriert: 3. Jun 2004, 13:27

Re: smb.conf Kein Zugriff auf Verzeichnisse per ln -s möglic

Beitrag von sphings » 4. Apr 2012, 13:35

hallo,

danke ich habe es unter [global] eingefügt.
habe samba neugestartet und trotzdem bleibt der Zugriff auf die Verzeichnisse verweigert.

hier mal die ganze smb.conf:

Code: Alles auswählen

cat /etc/samba/smb.conf
[global]
        workgroup = Arbeitsgruppe
        printcap name = cups
        cups options = raw
        include = /etc/samba/dhcp.conf
        map to guest = Bad User
        guests account = nobody
        read only = no
        unix password sync = yes
        password program = /usr/bin/passwd %u
        passdb backend = smbpasswd
        wins support = No
        netbios name = intranet 
        usershare max shares = 100
        ldap suffix = 
        wins server =
        follow symlinks = yes
        wide links = yes
[homes]
        comment = Home Directories
        valid users = %S, %D%w%S
        browseable = No
        read only = No
        inherit acls = Yes
[profiles]
        comment = Network Profiles Service
        path = %H
        read only = No
        store dos attributes = Yes
        create mask = 0600
        directory mask = 0700
[users]
        comment = All users
        path = /home
        read only = No
        inherit acls = Yes
        veto files = /aquota.user/groups/shares/
[groups]
        comment = All groups
        path = /home/groups
        read only = No
        inherit acls = Yes
[printers]
        comment = All Printers
        path = /var/tmp
        printable = Yes
        create mask = 0600
        browseable = No
[print$]
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin root
        force group = ntadmin
        create mask = 0664
        directory mask = 0775
[freigabe]
        path = /home/freigabe/
        read only = No
        case sensitive = no
        guest ok = yes
        force user = auction
[scanner]
        path = /home/auction/pixmerge/scanner
        case sensitive = no
        guest ok = yes
        force user = auction
        read only = No
        #hide files = /.*/
[scanner-bearbeiten]
        path = /home/auction/pixmerge/scanner.bearbeiten
        case sensitive = no
        guest ok = yes
        force user = auction
        read only = No
        #hide files = /.*/ 
[digicam]
        path = /home/auction/pixmerge/digicam
        case sensitive = no
        guest ok = yes
        force user = auction
        read only = No
        #hide files = /.*/ 
[digicam-bearbeiten]
        path = /home/auction/pixmerge/digicam.bearbeiten
        case sensitive = no
        guest ok = yes
        force user = auction
        read only = No
        #hide files = /.*/ 
[upload]
        path = /home/auction/pixmerge/upload
        case sensitive = no
        guest ok = yes
        force user = auction
        read only = No
        #hide files = /.*/ 
[bilderarchiv]
        path = /home/auction/pixmerge/bilderarchiv
        case sensitive = no
        guest ok = yes
        force user = auction
        read only = No
        #hide files = /.*/ 
__________________________________________-
EDIT

Habs gelöst.

Code: Alles auswählen

unix extensions = no
fehlte unter [global]

Danke nochmal!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast