Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[erledigt] openSUSE TFTP-Server

Alles rund um die Server (Web-, Mail-, Datenbank-, Datenaustausch-, etc.) die man unter Linux betreiben kann

Moderator: Moderatoren

Antworten
admine
Administrator
Administrator
Beiträge: 8768
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

[erledigt] openSUSE TFTP-Server

Beitrag von admine » 3. Feb 2012, 12:01

Hallo Leute,

ich brauche den TFTP-Server in openSUSE 12.1
Dachte, geht ja eigentlich recht schnell.
YaST - Netzwerkdienst - xinetd - tftp anschalten + konfigurieren
Gesagt getan und tftpd läuft auch:

Code: Alles auswählen

ps -ef | grep tftp
<user> 22681 22285  0 11:50 ?        00:00:00 in.tftpd -s /daten/tftpboot

Code: Alles auswählen

/sbin/chkconfig -l
...
xinetd based services:
       ...
        tftp:               on
        ...
Trotzdem bekomm ich vom Switch:

Code: Alles auswählen

%Error opening tftp://<ip der opensuse>/lvswl6507_028-confg_20120203 (Timed out)
Was ist da seit der 12.1 anders? :schockiert:
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Werbung:
Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2480
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Re: openSUSE TFTP-Server

Beitrag von TomcatMJ » 3. Feb 2012, 19:09

Hi!
Dran gedacht den Port dazu auch in der SuSEFirewall2 freizugeben?

Bis denne,
Tom

admine
Administrator
Administrator
Beiträge: 8768
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: openSUSE TFTP-Server

Beitrag von admine » 3. Feb 2012, 20:54

TomcatMJ hat geschrieben: Dran gedacht den Port dazu auch in der SuSEFirewall2 freizugeben?
Ich bin mir da jetzt nicht 100%ig sicher, aber zu 97% sag ich, ist die FW gar nicht aktiv.
Schaun kann ich da aber erst übernächste Woche... eher bin ich nicht wieder an diesem openSUSE :-)
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2480
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Re: openSUSE TFTP-Server

Beitrag von TomcatMJ » 3. Feb 2012, 21:25

Naja,dann dauerts halt ein wenig ;)....hier läuft der 12.1er opensuse tftp-server jedenfalls sauber wie er soll,daher dürfte es wohl eher nicht am tftp-server liegen...vielleicht einfach bei der Gelegenheit auch mal die Dateirechte der angeforderten Datei prüfen wenn du dann demnächst wieder an dem Rechner bist ;)

admine
Administrator
Administrator
Beiträge: 8768
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: openSUSE TFTP-Server

Beitrag von admine » 3. Feb 2012, 21:34

TomcatMJ hat geschrieben:.vielleicht einfach bei der Gelegenheit auch mal die Dateirechte der angeforderten Datei prüfen
Da wird nix angefordert ... das File soll im TFTP-Datenverzeichnis abgelegt werden.
Da fällt mir noch ein ... unter welchem User läuft bei dir der TFTP?
Ich hab da meinen User genommen und das Datenverzeichnis gehört ihm auch. Damit sollten IMHO die Rechte ok sein :???:
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2480
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Re: openSUSE TFTP-Server

Beitrag von TomcatMJ » 4. Feb 2012, 02:02

Da er bei mir nur im lokalen netz auf einer von 5 schnitsellen lauscht läuft er bei mir unter dem Default-User, also root...nuja, ist hier eh nur für den MosNis am Werk,also könnte ich durchaus morgen mal testen ob da ein anders Verhalten aufkommt wenn ich ihm nen anderen User einstelle und die Verzeichnisse entsprechend per chown -R * mal neu zuordne ;)...Das probier ich nacher dann mal aus. Rückmeldung dazu poste ich dann gegen Abend;)

admine
Administrator
Administrator
Beiträge: 8768
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: openSUSE TFTP-Server

Beitrag von admine » 16. Feb 2012, 12:32

So, jetzt muss es hier weiter gehen.
Firewall ist, wie schon erwähnt aus (bzw. gar nicht installiert ;) )

Der Server läuft unter meinem User-Account und der hat auch das Recht in das entsprechende Verzeichnis zu schreiben:

Code: Alles auswählen

ls -dl /daten/tftpboot/
drwxr-xr-x 2 <user> tftp 4096 Dec 17  2010 /daten/tftpboot/
Fehlermeldung am Switch, wenn ich versuche eine Konfig auf meinen Laptop zu speichern:

Code: Alles auswählen

%Error opening tftp://<ip der opensuse>/lvswl6507_028-confg_20120216 (Timed out)
Mein User ist auch in der Gruppe "tftp".

Starte ich den TFTP-Server unter dem User root, dann gibts diese Fehlermeldung:

Code: Alles auswählen

%Error opening tftp://<ip der opensuse>/lvswl6507_028-confg_20120216 (No such file or directory)
Ich muss ganz ehrlich sagen, ich nutze TFTP schon so lange und unter so vielen oS-Versionen ... das gabs noch nie.
Das hat immer einfach gefunzt und jetzt hab ich ehrlich gesagt keinen Plan mehr :???: :irre:

EDIT:

Jetzt hab ich noch etwas auf der F10er-Konsole gefunden:

Code: Alles auswählen

in.tftpd[3077]: cannot set groups for user nobody
Daraufhin hab ich ein wenig mit verschiedenen Optionen "gespielt" ... allerdings ohne Erfolg :(

Meine /etc/xinetd.d/tftp sieht jetzt so aus:

Code: Alles auswählen

# default: off
# description: tftp service is provided primarily for booting or when a \
#       router need an upgrade. Most sites run this only on machines acting as
#       "boot servers".
service tftp
{
        socket_type     = dgram
        protocol        = udp
        wait            = yes
        user            = <mein_user>
        group           = tftp
        server          = /usr/sbin/in.tftpd
        server_args     = -c -s /daten/tftpboot -u nobody
        disable         = no
        flags           = IPv4
}
Hat da evt. jemand eine Idee? :roll:
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2480
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Re: openSUSE TFTP-Server

Beitrag von TomcatMJ » 17. Feb 2012, 15:29

Dein User ist der unter dessen Kennung der tftp-Server läuft,aber bei den Serverparametern teilst du dem Server mit er solle als nobody laufen. Ist das wirklich so beabsichtigt? Vermutlich hakt es genau dort denk ich. Du solltest deinen User auch anstelle von nobody in der Datei /etc/xinetd.d/tftp setzen,

Code: Alles auswählen

        server_args     = -c -s /daten/tftpboot -u <dein_user>
dann dürfte sich das Problem eigentlich erledigt haben ;)

admine
Administrator
Administrator
Beiträge: 8768
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: openSUSE TFTP-Server

Beitrag von admine » 17. Feb 2012, 20:23

TomcatMJ hat geschrieben:Dein User ist der unter dessen Kennung der tftp-Server läuft,aber bei den Serverparametern teilst du dem Server mit er solle als nobody laufen. Ist das wirklich so beabsichtigt? Vermutlich hakt es genau dort denk ich. Du solltest deinen User auch anstelle von nobody in der Datei /etc/xinetd.d/tftp setzen,

Code: Alles auswählen

        server_args     = -c -s /daten/tftpboot -u <dein_user>
dann dürfte sich das Problem eigentlich erledigt haben ;)
OK, das teste ich dann am Montag und berichte.
Danke vorab.
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

admine
Administrator
Administrator
Beiträge: 8768
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: openSUSE TFTP-Server

Beitrag von admine » 20. Feb 2012, 14:17

TomcatMJ hat geschrieben:

Code: Alles auswählen

        server_args     = -c -s /daten/tftpboot -u <dein_user>
dann dürfte sich das Problem eigentlich erledigt haben ;)
Leider nicht :(

Code: Alles auswählen

cat /etc/xinetd.d/tftp
# default: off
# description: tftp service is provided primarily for booting or when a \
#       router need an upgrade. Most sites run this only on machines acting as
#       "boot servers".
service tftp
{
        socket_type     = dgram
        protocol        = udp
        wait            = yes
        user            = <mein_user>
        group           = users
        server          = /usr/sbin/in.tftpd
        server_args     = -c -s /daten/tftpboot -u <mein_user>
        flags           = IPv4
Meldung am Switch:

Code: Alles auswählen

%Error opening tftp://<ip_tftp_server>/lvswl6507_028-confg_2012 (Timed out)
und auf F10 diesmal:

Code: Alles auswählen

in.tftpd[3077]: cannot set groups for user <mein_user>
Das kann doch nicht wahr sein ...
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2480
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Re: openSUSE TFTP-Server

Beitrag von TomcatMJ » 20. Feb 2012, 14:41

Hm,mal testhalber die Dateisystemrechte auf /daten/tftpboot auf 777 gesetzt in dem sich ja deine Datei befinden sollte? Zumindest ist das Verzeichnis ja als Root deines tftp-Servers angegeben...

admine
Administrator
Administrator
Beiträge: 8768
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: openSUSE TFTP-Server

Beitrag von admine » 21. Feb 2012, 11:46

TomcatMJ hat geschrieben:Hm,mal testhalber die Dateisystemrechte auf /daten/tftpboot auf 777 gesetzt in dem sich ja deine Datei befinden sollte? Zumindest ist das Verzeichnis ja als Root deines tftp-Servers angegeben...
Keine Änderung ... leider.
Noch immer die Meldung cannot set groups for user <mein_user> auf F10 und am Switch gibts Timed out.
Ich hab keinen Plan mehr ... aber das kann doch nicht sein *grrr* :irre:
Und ich brauch das ... Mist!
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

admine
Administrator
Administrator
Beiträge: 8768
Registriert: 15. Feb 2004, 21:13
Kontaktdaten:

Re: openSUSE TFTP-Server

Beitrag von admine » 21. Feb 2012, 12:06

So, Problem für mich gelöst.

Hab atftp installiert, kurz konfiguriert und tut.
SOO muss es funktionieren!
..:: unser Linux-Club-Wiki ::..
-------------------------
..:: Deutsche Mugge ::..
-------------------------

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast