Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst]php5 funzt nicht

Alles rund um die Server (Web-, Mail-, Datenbank-, Datenaustausch-, etc.) die man unter Linux betreiben kann

Moderator: Moderatoren

Antworten
mampfi
Hacker
Hacker
Beiträge: 670
Registriert: 17. Mär 2004, 19:33
Wohnort: München

[gelöst]php5 funzt nicht

Beitrag von mampfi » 12. Aug 2009, 22:48

In der SuFu und im Google hierzu nichts gefunden.

Ich schreibs jetzt hier ins debian-Forum, da Installation

Ausgangssituation: Ein frisch installiertes debian 5, mysql installiert und funktioniert


Leider funzt das installierte PHP 5 nicht, ein Verzeichnis /srv/www/hdocs existiert nicht.

Hier installierte Programme (Konsolenausgabe):


ii libapache2-mod-php5 5.2.6.dfsg.1-1+lenny3 server-side, HTML-embedded scripting language (Apache 2 module
ii php5 5.2.6.dfsg.1-1+lenny3 server-side, HTML-embedded scripting language (metapackage)
ii php5-cli 5.2.6.dfsg.1-1+lenny3 command-line interpreter for the php5 scripting language
ii php5-common 5.2.6.dfsg.1-1+lenny3 Common files for packages built from the php5 source
ii php5-mysql 5.2.6.dfsg.1-1+lenny3 MySQL module for php5
ii php5-sqlite 5.2.6.dfsg.1-1+lenny3 SQLite module for php5
duron:/srv# dpkg -l | grep apache
ii apache2 2.2.9-10+lenny4 Apache HTTP Server metapackage
ii apache2-mpm-prefork 2.2.9-10+lenny4 Apache HTTP Server - traditional non-threaded model
ii apache2-utils 2.2.9-10+lenny4 utility programs for webservers
ii apache2.2-common 2.2.9-10+lenny4 Apache HTTP Server common files
ii libapache2-mod-php5 5.2.6.dfsg.1-1+lenny3 server-side, HTML-embedded scripting language (Apache 2 module
duron:/srv# dpkg -l | grep mysql
ii libdbd-mysql-perl 4.007-1 A Perl5 database interface to the MySQL database
ii libmysqlclient15off 5.0.51a-24+lenny1 MySQL database client library
ii mysql-admin 5.0r12-1 GUI tool for intuitive MySQL administration
ii mysql-client 5.0.51a-24+lenny1 MySQL database client (metapackage depending on the latest ver
ii mysql-client-5.0 5.0.51a-24+lenny1 MySQL database client binaries
ii mysql-common 5.0.51a-24+lenny1 MySQL database common files
ii mysql-gui-tools-common 5.0r12-1 Architecture independent files for MySQL GUI Tools
ii mysql-query-browser 5.0r12-1 Official GUI tool to query MySQL database
ii mysql-server 5.0.51a-24+lenny1 MySQL database server (metapackage depending on the latest ver
ii mysql-server-5.0 5.0.51a-24+lenny1 MySQL database server binaries
ii php5-mysql 5.2.6.dfsg.1-1+lenny3 MySQL module for php5
Zuletzt geändert von mampfi am 13. Aug 2009, 13:24, insgesamt 1-mal geändert.
Programmieren macht Spaß und ärgert gleichzeitig

Werbung:
Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4272
Registriert: 14. Jun 2004, 09:12

Re: php5 funzt nicht

Beitrag von Geier0815 » 13. Aug 2009, 09:01

Hää? Unter debian guckst Du /var/www/ aber das hat nur indirekt mit php zu tun sondern ist das Verzeichnis vom apache.
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

mampfi
Hacker
Hacker
Beiträge: 670
Registriert: 17. Mär 2004, 19:33
Wohnort: München

Re: php5 funzt nicht

Beitrag von mampfi » 13. Aug 2009, 11:19

Habs hier im debian-Forum gepostet, da Problem "nur" unter debian auftaucht.

Werd mal nachschauen
Programmieren macht Spaß und ärgert gleichzeitig

marce
Advanced Hacker
Advanced Hacker
Beiträge: 1037
Registriert: 19. Jun 2008, 13:16
Wohnort: Dettenhausen
Kontaktdaten:

Re: php5 funzt nicht

Beitrag von marce » 13. Aug 2009, 12:11

übrigens: "es geht nicht" ist keine ausreichend genau Fehlerbeschreibung...

mampfi
Hacker
Hacker
Beiträge: 670
Registriert: 17. Mär 2004, 19:33
Wohnort: München

Re: php5 funzt nicht

Beitrag von mampfi » 13. Aug 2009, 13:23

Also php-Skripte liefen nicht.

Problem gelöst, php rennt.

Statt /srv/www/htdocs wie unter SuSe ist es/var/www
Programmieren macht Spaß und ärgert gleichzeitig

Benutzeravatar
Geier0815
Administrator
Administrator
Beiträge: 4272
Registriert: 14. Jun 2004, 09:12

Re: [gelöst]php5 funzt nicht

Beitrag von Geier0815 » 13. Aug 2009, 16:18

Was hatte ich dir im ersten Post geschrieben? :D
Wenn Windows die Lösung ist...
kann ich dann bitte das Problem zurück haben?

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste