Samba: Rechtevergabe per force...mode-Anweisung ignoriert

Alles rund um die Server (Web-, Mail-, Datenbank-, Datenaustausch-, etc.) die man unter Linux betreiben kann

Moderator: Moderatoren

Antworten
Benutzeravatar
Hengstenberg
Newbie
Newbie
Beiträge: 46
Registriert: 2. Mai 2009, 15:07
Wohnort: Waiblingen

Samba: Rechtevergabe per force...mode-Anweisung ignoriert

Beitrag von Hengstenberg » 16. Feb 2017, 20:38

Hey,

ich habe einen Samba-Server mit der folgenden smb.conf aufgesetzt:

Code: Alles auswählen

[global]
	workgroup = HOMENET
	passdb backend = tdbsam
	map to guest = Bad User
	usershare allow guests = No
	add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
	domain logons = No
	domain master = No
	security = user
	username map = /etc/samba/smbusers
	wins support = No
	ldap admin dn = 
	wins server = 

[homes]
	comment = Persönliches Laufwerk
	path = /srv/data/private/%S
	browseable = No
	read only = No
	force create mode = 0640
	force directory mode = 0750
	valid users = %S, %D%w%S
	inherit acls = Yes

[Netzwerkspeicher]
	comment = Familien-Laufwerk
	path = /srv/data/public
	read only = No
	force create mode = 0664
	force directory mode = 0775
	force user = chief
	force group = users
	inherit acls = Yes
Was ich nun nicht verstehe ist, dass die beiden force-Anweisungen im [homes]-Block irgendwie "ignoriert" werden. Egal wie ich die Maske einstelle, es wird immer 0700 gesetzt. Nach einer Recherche im Internet habe ich keine eindeutige Erklärung gefunden:
  • Die einen meinen, man müsse noch force security-Anweisungen einfügen (die bei meinem 4er Samba ignoriert werden, weil offenbar nicht mehr unterstützt),
  • die anderen meinen, dass freigegebene Laufwerk müsse bei der fstab-Einbindung ins Server-Dateisystem mit der user_xattr-Option eingebunden werden.
  • Und das waren nur 2 mögliche "Meinungen".
  • Und dann gestaltet sich die "nicht änderbare" Maske bei anderen immer anders, als ich sie bei mir beobachte (z.B. die einen haben immer 0660, andere wieder 0644 oder 0744, usw.)
Gibt es hier jemand, der mir erklären kann, warum die Maske ignoriert wird? Gibt es ggf. übergeordnete Einstellungen, die diese force-Anweisungen unwirksam machen? Liegt es vielleicht am [homes]-Block selbst (den ich aber eigentlich ganz praktisch finde)?

Noch ein paar relevante Infos:
  • Samba-Version: 4.4.2-9.1-x86_64
  • Linux: openSUSE 42.2 mit Kernel 4.4.46-11.1
  • fehlt noch was?
Grüße, Hengstenberg
OS: Linux 4.4.79-19-default | openSUSE Leap 42.3 | KDE 5.8.7
Hardware:
  • Notebook (Lenovo X61) | Intel Core2Duo T8300 @ 2.40 GHz | 4 GB RAM | Intel 965 GM
  • Deskunder (Selbstbau) | Intel Core2Duo E6700 @ 2,66 GHz | 8 GB RAM| nVidia GeForce GTX 560 Ti

Werbung:
stka
Moderator
Moderator
Beiträge: 3268
Registriert: 1. Jun 2004, 13:56
Wohnort: 51°58'34.91"N 7°38'37.47"E
Kontaktdaten:

Re: Samba: Rechtevergabe per force...mode-Anweisung ignoriert

Beitrag von stka » 23. Feb 2017, 18:04

Schmeiß den ganzen "force"-Mist raus und schau die die einfachen ACLs und die default-ACLs im Dateisystem an und steuer die Rechte darüber. Dann noch "inherit acls = yes" "store dos attributes = yes" in die smb.conf und alles ist gut
Du hörst nicht auf zu laufen weil du alt wirst. Du wirst alt weil du aufhörst zu laufen.
Das neue Buch http://www.kania-online.de/fachbuecher

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast