Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

@Linupedia Admins - Fehler in Linupedia

Alles rund um unser eigenes Wiki, die Linupedia

Moderator: robi

Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2480
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von TomcatMJ » 6. Apr 2014, 14:42

Das Verschieben der Übersichtsseite des DVB-Wikibooks auf http://www.linupedia.org/opensuse/Dvb_w ... /Übersicht gab gerade denselben Anzeigefehler mit der Exception,aber funktioniert hats dennoch. Sieht nach einem Kodierungsproblem aus das aber nur die Anzeige betrifft,nicht die tatsächlichen Inhalte...wird wohl mal Zeit den Fehler irgendwoanders nachzubauen damit mans genauer analysieren kann wohers kommt,denn dazu braucht man die Logfiles des Webservers und Zugang zu den Dateien des Mediawikis um den Haken zu finden, ohne diesen beiden Voraussetzungen erfüllt zu haben funktioniert das Lokalisieren der Fehlerursache quasi gar nicht.

Edit:Aufgrund der nun richtigen Lage der Übersichtsseite im Wiki hab ich die Änderung der Navi-Box natürlich auch wieder rückgängig gemacht da der Grund für diese Änderung ja nun auch beseitigt wurde ;)

Werbung:
Benutzeravatar
Escho
Advanced Hacker
Advanced Hacker
Beiträge: 881
Registriert: 20. Jun 2006, 21:04
Wohnort: Mittelfranken
Kontaktdaten:

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von Escho » 6. Apr 2014, 14:51

TomcatMJ hat geschrieben:Das Verschieben der Übersichtsseite des DVB-Wikibooks auf http://www.linupedia.org/opensuse/Dvb_w ... /Übersicht gab gerade denselben Anzeigefehler mit der Exception,aber funktioniert hats dennoch.
Ja, funktioniert hat es immer, trotz der Fehleranzeige.

Danke übrigens für das Verschieben. Gefällt mir so besser als mit dem "kryptischen" Dateinamen ;)

Edgar

Benutzeravatar
Escho
Advanced Hacker
Advanced Hacker
Beiträge: 881
Registriert: 20. Jun 2006, 21:04
Wohnort: Mittelfranken
Kontaktdaten:

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von Escho » 6. Apr 2014, 15:44

Ich hab zwei Links zu mediawike.org gefunden wegen dieser fatal exception:

http://www.mediawiki.org/wiki/Thread:Ex ... tion_Error
http://www.mediawiki.org/wiki/Thread:Pr ... 19_to_1.20

Die sind zwar schon etwas älter, aber vielleicht hilft´s bei der Suche

Edgar

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1807
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von gehrke » 7. Apr 2014, 07:24

Vielleicht ein nützliches Detail beim Debuging:
Ich habe soeben 3 inhaltlich identische Commits (Löschanträge) auf 3 unterschiedlichen Seiten durchgeführt. Bei den ersten beiden bekam ich obige Fehlermeldung, aber bei der letzten nicht.

Seltsam, aber so steht es geschrieben...

Benutzeravatar
Escho
Advanced Hacker
Advanced Hacker
Beiträge: 881
Registriert: 20. Jun 2006, 21:04
Wohnort: Mittelfranken
Kontaktdaten:

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von Escho » 7. Apr 2014, 17:28

OK, dannn auch von mir noch´n Detail:

Diese 3 Löschanträge in ihrer Urform, also ohne den Vorlagenbaustein, konnte ich ganz ohne diese "fatal exclusion" hochladen, alle drei!

@gehrke: ich hab vorgestern noch einen Löschantrag gestellt in der gleichen Form, wie die drei anderen. Was meist du, soll ich da den Baustein ebenfalls noch einbauen? Sieht irgendwie bescheiden aus mit dem nicht richtig angezeigten "Löschbaustein"

Edgar

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1807
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von gehrke » 7. Apr 2014, 17:49

Escho hat geschrieben:@gehrke: ich hab vorgestern noch einen Löschantrag gestellt in der gleichen Form, wie die drei anderen. Was meist du, soll ich da den Baustein ebenfalls noch einbauen? Sieht irgendwie bescheiden aus mit dem nicht richtig angezeigten "Löschbaustein"
Ich würde das tun - allein schon, weil dann die Kategorie passend gesetzt ist, was den Admins die Arbeit erleichtern sollte.

Bescheiden sieht das natürlich aus, aber das tun ganz viele andere Seiten im Wiki derzeit auch (oder sind gänzlich unverständlich mangels Bilder). Da kommt es auf schlecht aussehende Seiten mit Löschantrag auch nicht mehr an... :-(

Benutzeravatar
Escho
Advanced Hacker
Advanced Hacker
Beiträge: 881
Registriert: 20. Jun 2006, 21:04
Wohnort: Mittelfranken
Kontaktdaten:

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von Escho » 7. Apr 2014, 20:26

gehrke hat geschrieben: Ich würde das tun - allein schon, weil dann die Kategorie passend gesetzt ist, was den Admins die Arbeit erleichtern sollte.

Bescheiden sieht das natürlich aus, aber das tun ganz viele andere Seiten im Wiki derzeit auch (oder sind gänzlich unverständlich mangels Bilder). Da kommt es auf schlecht aussehende Seiten mit Löschantrag auch nicht mehr an... :-(
done

Edgar

Benutzeravatar
Escho
Advanced Hacker
Advanced Hacker
Beiträge: 881
Registriert: 20. Jun 2006, 21:04
Wohnort: Mittelfranken
Kontaktdaten:

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von Escho » 7. Apr 2014, 23:59

Ich hab den Bug mit den nicht angezeigten eingebetteten Bildern, bei denen die Vorschaubilder intakt sind, umgangen. Da das Skalieren nur per Zufallsprinzip funktioniert, habe ich sie einfach als Thumbnail in den Artikel eingebettet. Wie ich das gemacht habe, kann man hier ansehen (letzte und vorletzte Version): http://www.linupedia.org/opensuse/Kommander/Screenshots

Edgar

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1807
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von gehrke » 8. Apr 2014, 06:47

Escho hat geschrieben:Ich hab den Bug mit den nicht angezeigten eingebetteten Bildern, bei denen die Vorschaubilder intakt sind, umgangen. Da das Skalieren nur per Zufallsprinzip funktioniert, habe ich sie einfach als Thumbnail in den Artikel eingebettet. Wie ich das gemacht habe, kann man hier ansehen (letzte und vorletzte Version)
Ich hatte definitiv noch nicht genug Kaffee heute morgen. :???: Den Effekt sehe ich, aber bislang habe ich noch nicht verstanden, wo der grundsätzliche Unterschied in der Einbettung besteht:

Code: Alles auswählen

[[Bild:Kommanderdialog_beispiel_1.png|thumb|none]]
[[Bild:Kmdr-Editor-DVB Script GUI.png|thumb|none]]
Was meinst Du mit 'Zufallsprinzip'? Oder liegt es an den Underscores???
TNX

Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2480
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von TomcatMJ » 8. Apr 2014, 08:38

Also ich krieg hier noch immer nichts zu sehen,aber dafür endlich mal ne Fehlermeldung mit der man auf die Suche gehen kann:
Fehler beim Erstellen des Vorschaubildes: Die Miniaturansicht konnte nicht am vorgesehenen Ort gespeichert werden
Das sieht mir nach falschen Rechten auf dem Zielverzeichnis für die Miniaturansichten aus, da müsste also moenk mal nach gucken welche Rechte (gegebenenfalls auch mal die umask checken) und welcher Owner bei dem Verzeichnis festgelegt sind in dem die Miniaturansichten abgelegt werden sollen. müsste entweder das allgemeine Bildverzeichnis vom Mediawiki samt Unterverzeichnissen oder das temporäre Verzeichnis dann wohl sein.

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5037
Registriert: 23. Sep 2008, 17:09

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von josef-wien » 8. Apr 2014, 12:08

gehrke hat geschrieben:wo der grundsätzliche Unterschied in der Einbettung besteht
In der zusätzlichen Angabe von
Escho hat geschrieben:|thumb|none
bzw. durch die Angabe von none an Stelle des Pixel-Werts.
TomcatMJ hat geschrieben:endlich mal ne Fehlermeldung
http://forum.linux-club.de/viewtopic.ph ... 28#p754348

Benutzeravatar
Escho
Advanced Hacker
Advanced Hacker
Beiträge: 881
Registriert: 20. Jun 2006, 21:04
Wohnort: Mittelfranken
Kontaktdaten:

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von Escho » 8. Apr 2014, 12:11

So, nochmal kurz zur Erklärung, bevor ich in den Keller gehe, Wand verputzen (2 Tage überstundenfrei müssen sinnvoll genutzt werden :)):

In der vorigen Form des Artikels hatte ich die Bilder direkt eingebettet ( [[Bild:Kommanderdialog_beispiel_1.png]] ). Das funktioniert nicht mehr, es kommt die von TomcatMJ erwähnte Fehlermeldung. Zeige ich das Bild nun als Thumnail (thumb), dann sehe dieses Thumb. Skaliere ich das Thumbnail auf eine angenehmere Größe, dann klappt es wieder nicht ( [[Bild:Kommanderdialog_beispiel_1.png|thumb|none]|500px] ).

So weit, so gut. Doch nun das Zufallsprinzip: Das erste Bild auf der Seite konnte ich auf 500px Breite skalieren, alle anderen nicht. Keine Ahnung warum.

Das mit dem Thumbnail funktioniert übrigens nur, wenn die Originaldatei in der Vorschau auf der Datei-Seite auch angzeigt wird. Erscheint dort schon die Fehlermeldung, dann klappt es nicht.

Ob´s was mit den Rechten zu tun hat, mag ich nicht beurteilen, da ich von diesem php-Zeugs nicht die geringste Ahnung habe.

None hat übrigens nichts mit dem Pixelwert zu zun, sondern ist nur dazu da, das Bild nicht vom Text umfließen zulassen

Edgar

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1807
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von gehrke » 8. Apr 2014, 12:12

TomcatMJ hat geschrieben:Also ich krieg hier noch immer nichts zu sehen,aber dafür endlich mal ne Fehlermeldung mit der man auf die Suche gehen kann:
Fehler beim Erstellen des Vorschaubildes: Die Miniaturansicht konnte nicht am vorgesehenen Ort gespeichert werden
Das sieht mir nach falschen Rechten auf dem Zielverzeichnis für die Miniaturansichten aus, da müsste also moenk mal nach gucken welche Rechte (gegebenenfalls auch mal die umask checken) und welcher Owner bei dem Verzeichnis festgelegt sind in dem die Miniaturansichten abgelegt werden sollen. müsste entweder das allgemeine Bildverzeichnis vom Mediawiki samt Unterverzeichnissen oder das temporäre Verzeichnis dann wohl sein.
Aber das ist doch schon lange bekannt, siehe Beitrag von P6CNAT 3. Feb 2014, 20:13:
P6CNAT hat geschrieben:Im Linupedia erscheint statt einer Grafik die Meldung:
Fehler beim Erstellen des Vorschaubildes: Die Miniaturansicht konnte nicht am vorgesehenen Ort gespeichert werden
Darauf hat 'moenk' ja schon damals geantwortet, daher gehe ich davon aus, dass das geprüft wurde...

Edit:
moenk hat geschrieben:Die Probleme hängen an der neuen Version von MediaWiki - da war ein Update auf 1.22.2 dabei. Dass einige Bilder noch zu sehen sind, liegt daran dass sie schon skaliert wurden. Nur grad wills nicht mehr, weiß aber nicht warum. An den Rechten liegts nicht.
Zuletzt geändert von gehrke am 8. Apr 2014, 12:18, insgesamt 1-mal geändert.

Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2480
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von TomcatMJ » 8. Apr 2014, 12:13

Oops?Die war mir wohl vor lauter Fatal Exceptions im Thread durch die Lappen gegangen..hm.wenn das aber schon gecheckt wurde mit den Dateisystemeinstellungen dann wärs wohl eher ein Punkt nach dem man die Apachelogs durchsuchen könnte um genauer zu sehen was da in dem Moment in dem das auftritt als Fehlerquelle zuschlägt...

Benutzeravatar
Escho
Advanced Hacker
Advanced Hacker
Beiträge: 881
Registriert: 20. Jun 2006, 21:04
Wohnort: Mittelfranken
Kontaktdaten:

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von Escho » 8. Apr 2014, 23:06

Das da hab ich in Google zu den fehlenden Vorschaubildern gefunden:

http://www.goingelectric.de/forum/going ... 37-30.html
http://www.wiki-forum.de/bilder-werden- ... 308392.htm

Bitte tut was. So wie es jetzt ist, macht es keinen Spass :nosmile:

Edgar

Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2480
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von TomcatMJ » 8. Apr 2014, 23:34

Der zweite Link sollte eigentlich ne Lösung darstellen die hier dann auch greifen müsste...da muss moenk ran da er als einziger Admin (und eben auch Betreiber des Ganzen) die Zugriffsrechte auf die Dateien des Servers hat ;)
Ich schicke ihm mal eben ne PN dazu mit Hinweis auf den Beitrag mit den Lösungen!

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1807
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von gehrke » 18. Apr 2014, 07:01

TomcatMJ hat geschrieben:Der zweite Link sollte eigentlich ne Lösung darstellen die hier dann auch greifen müsste...da muss moenk ran da er als einziger Admin (und eben auch Betreiber des Ganzen) die Zugriffsrechte auf die Dateien des Servers hat ;)
Ich schicke ihm mal eben ne PN dazu mit Hinweis auf den Beitrag mit den Lösungen!
Für mich als Außenstehender sieht es so aus, als ob sich in den nunmehr 10 Tagen seitdem genau gar nichts geändert hat.

Benutzeravatar
TomcatMJ
Guru
Guru
Beiträge: 2480
Registriert: 1. Apr 2004, 00:29
Wohnort: Köln
Kontaktdaten:

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von TomcatMJ » 18. Apr 2014, 10:45

gehrke hat geschrieben: Für mich als Außenstehender sieht es so aus, als ob sich in den nunmehr 10 Tagen seitdem genau gar nichts geändert hat.
Das muss ich leider auch so sehen,denn bisher gabs nichtmal eine Reaktion auf die PN :-/....

Benutzeravatar
gehrke
Moderator
Moderator
Beiträge: 1807
Registriert: 10. Nov 2012, 11:00
Wohnort: Münsterland

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von gehrke » 18. Apr 2014, 11:22

TomcatMJ hat geschrieben:Das muss ich leider auch so sehen,denn bisher gabs nichtmal eine Reaktion auf die PN :-/....
Auf meine leider auch nicht.

Benutzeravatar
Escho
Advanced Hacker
Advanced Hacker
Beiträge: 881
Registriert: 20. Jun 2006, 21:04
Wohnort: Mittelfranken
Kontaktdaten:

Re: @Linupedia Admins - Fehler in Linupedia

Beitrag von Escho » 18. Apr 2014, 18:52

Scheint anderweitig schwer beschäftigt zu sein, unser Administrator. Vielleicht macht es ja Sinn, wenn ihr ihn im geocaching-Forum kontaktiert?

Edgar

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast