Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

FC4 - Windows XP (Dualboot)

Moderator: Moderatoren

Antworten
DasX
Newbie
Newbie
Beiträge: 9
Registriert: 29. Mär 2005, 15:35

FC4 - Windows XP (Dualboot)

Beitrag von DasX » 29. Jul 2005, 01:03

Bei Fedora Core 3 gab es ein Problem wenn man es parallel zu einer Windows-Installation aufspielen wollte.

Das FC3 Setup musste dann mit linux hdx=.... gestartet werden.

Ist dieses Problem in Fedora Core 4 behoben ?

Werbung:
Greunke
Member
Member
Beiträge: 159
Registriert: 31. Mai 2004, 15:24
Wohnort: Troisdorf

Beitrag von Greunke » 29. Jul 2005, 08:33

Wie meinst du das jetzt genau mit "parallel"? Zwei Installationen auf eine Platte oder je ein Betriebssystem auf einer Festplatte?

Also der FC3-Setup sollte normalerweise direkt beim Lesen der DVD gestartet werden. Vielleicht musst du ggf. die Reihenfolge der Geräte im Bios umstellen, sodass das CD-/DVD-ROM-Laufwerk vor den Festplatten benutzt wird.

Ansonsten muss bei der Installation darauf geachtet werden, dass der Bootloader in den Masterbootsektor der Festplatte geschrieben wird, welche zuerst gebootet wird.
In diesem Sinne: Learning by Doing
Christian

Bild
Fedora 11 auf Amilo M1437G
Mein OpenPGP-Key

DasX
Newbie
Newbie
Beiträge: 9
Registriert: 29. Mär 2005, 15:35

Beitrag von DasX » 29. Jul 2005, 10:59

Parallel heißt Windows ist installiert und FC4 soll auf den hinteren Partitionen (der gleichen Platte) installiert werden. Als Bootmanager dient dabei Grub von FC4.

Bei FC3 und frühen Versionen von Debian 3.1 gab es Probleme nach der Einführung des 2.6er Kernels. Windows war nach deren Installation nicht mehr zu booten.
In FC3 ließ sich das Problem mit Angabe spezieller Parameter lösen.

Debian hat es in den aktuellen Sarge-Installern gefixt.

Ist das bei FC4 auch gefixt? Oder muss ich wieder erst die rescue-Console aufmachen um mir die Einträge für Sektoren, Zylinder und Köpfe der Platte zu holen um dies dann als Bootparameter anzugeben ?

Benutzeravatar
jannpoohbear
Newbie
Newbie
Beiträge: 26
Registriert: 4. Apr 2004, 13:21

Beitrag von jannpoohbear » 29. Jul 2005, 20:25

Hallo!
GRUB muß in den MasterBootRecord (MBR) der ersten Platte geschrieben werden. Grub erkennt die Windows-Installation und Du kannst XP booten. Das funktionierte bei mir mit Suse 8.2, Suse 9.0, FedoraCore 2 und FedoraCore 3 und funktioniert immernoch bei FedoraCore 4, RedHat 9 und Suse 9.2. Wenn Du damit ein Problem hast kann es also nicht an Linux liegen. Da Tippe ich eher (Entschuldigung) auf einen Bedienerfehler.
AMD Duron 1000 / 512 MB
RedHat 9
Fedora Core 4
Suse 9.2
Windows XP
Nvidia nForce2 400
Nvidia GeForce 440-SE

Es heißt "WINDOWS" , verdammt !!!

Benutzeravatar
Fytzi
Hacker
Hacker
Beiträge: 305
Registriert: 1. Aug 2004, 17:14
Kontaktdaten:

Beitrag von Fytzi » 29. Jul 2005, 21:25

Ich kann meinem Vorredner nur zustimmen. Ich hatte mit Fedora/Mandrake/Suse ... noch nie solche Probleme. Habe aber davon gehört. Sollte aber bei Fedora Core 4 bzw. Suse 9.3 nicht mehr passieren.

Antworten