[gelöst] Arch-Linux bootet nicht mehr

Moderator: Moderatoren

Antworten
Benutzeravatar
Herz-von-Hessen
Guru
Guru
Beiträge: 1550
Registriert: 23. Jun 2009, 21:29
Wohnort: Zuhause
Kontaktdaten:

[gelöst] Arch-Linux bootet nicht mehr

Beitrag von Herz-von-Hessen » 23. Jan 2017, 21:55

Hallo

Seit meinem Umbau (neuer/anderer Akku) bootet mein Laptop (Thinkpad T41p) nicht mehr richtig sondern gibt folgende Meldung aus:

Code: Alles auswählen

Warning: /lib/modules/4.8.13-1-ARCH/modules.devname not found - ignoring
starting version 231
ERROR: resume: hibernation device '/dev/sda1' not found
ERROR: Unable to find root device 'UUID=fe80efc8-f804-412c-a264-40eabb1b9677' .
You are being dropped to a recovery shell
    Type 'exit' to try and continue booting
sh: can't acess tty: job control turned off
[rootfs ]#
Wenn ich mit einer Live-Version boote kann ich ohne Probleme auf die Festplatte (eine 30gb kleine SSD) zugreifen.
Ich möchte ungern neu installieren müssen, wo mein Setup so perfekt lief.
Es muss doch da irgendwo eine Hibernate-Datei (oder sonstiges Lock-File) sein die ich löschen muss um wieder booten zu können.

Lieben Gruß aus Zuhaus
Zuletzt geändert von Herz-von-Hessen am 16. Jun 2017, 19:17, insgesamt 1-mal geändert.
Asus P8H77V/ Intel Core i5, 3.10GHz | 8.0gb RAM | NVIDIA GeForce GTX 650 Ti Boost 2GB | Arch-Linux| arch-desktop 4.7.6-1-ARCH | Plasma: 5.8.0.1| HP Officejet Pro 8620

Werbung:
abgdf
Guru
Guru
Beiträge: 2975
Registriert: 13. Apr 2004, 21:15

Re: Arch-Linux bootet nicht mehr

Beitrag von abgdf » 23. Jan 2017, 22:24

Sprich Freund und tritt ein.
Heißt hier:
Type 'exit' to try and continue booting
Wenn das geht. ;)

spoensche
Moderator
Moderator
Beiträge: 7239
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Arch-Linux bootet nicht mehr

Beitrag von spoensche » 24. Jan 2017, 20:44

Die Rootpartition wird nicht mehr gefunden.
Überprüfe mal in der Recovery Shell, ob UUID deiner Rootpartition unter /dev/disk/by-uuid existiert. Das kannst du mit einem simplen

Code: Alles auswählen

ls -l /dev/disk/by-uuid
durchführen.

Benutzeravatar
Herz-von-Hessen
Guru
Guru
Beiträge: 1550
Registriert: 23. Jun 2009, 21:29
Wohnort: Zuhause
Kontaktdaten:

Re: Arch-Linux bootet nicht mehr

Beitrag von Herz-von-Hessen » 26. Jan 2017, 21:12

Hallo abgdf,
abgdf hat geschrieben:Wenn das geht.
Nein das geht leider nicht, denn die Tastatur des Laptop nimmt keinerlei Eingaben, nicht einmal ein Strg+Alt+Entf an :-(


Hallo spoensche,
spoensche hat geschrieben:Die Rootpartition wird nicht mehr gefunden.
Das kann ich auch lesen :/
spoensche hat geschrieben:Überprüfe mal in der Recovery Shell, ob UUID deiner Rootpartition unter /dev/disk/by-uuid existiert.
Ja die UUID ist exakt die, die auch in der /etc/fstab angegeben ist. Danach habe ich natürlich als allererstes gesehen.
Ich vermute das es eine lock- oder hibernate-Datei gibt die hier zu laden versucht wird und diese nicht da ist (weil der Strom schneller weg war als das schreiben der hibernate Datei) Nur bin ich da nicht sicher und habe auch keine Hinweise gefunden wie diese heißen könnte oder wo sie sich befindet.

Lieben Gruß aus Hessen
Asus P8H77V/ Intel Core i5, 3.10GHz | 8.0gb RAM | NVIDIA GeForce GTX 650 Ti Boost 2GB | Arch-Linux| arch-desktop 4.7.6-1-ARCH | Plasma: 5.8.0.1| HP Officejet Pro 8620

abgdf
Guru
Guru
Beiträge: 2975
Registriert: 13. Apr 2004, 21:15

Re: Arch-Linux bootet nicht mehr

Beitrag von abgdf » 26. Jan 2017, 22:17

Hmm, Tastatur geht wohl nicht, da:
Herz-von-Hessen hat geschrieben:

Code: Alles auswählen

sh: can't acess tty: job control turned off
Ehrlich gesagt, weiß ich nicht, was da los ist.

Ansätze:
https://bbs.archlinux.org/viewtopic.php?id=77815 (2009!)

Code: Alles auswählen

ln -s /dev/sda1 /dev/archiso
https://www.youtube.com/watch?v=NbjjWyxmsAU

Code: Alles auswählen

fsck /dev/sda1
https://debianforum.de/forum/viewtopic. ... 2&t=148057

Code: Alles auswählen

insmod lvm
(auf Grub-shell)

spoensche
Moderator
Moderator
Beiträge: 7239
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Arch-Linux bootet nicht mehr

Beitrag von spoensche » 27. Jan 2017, 23:34

Ich gehe jetzt mal davon aus, dass /dev/sda2 deine / Partition ist und /dev/sda1 deine Swap Partition.

Boote mal das Arch Installations ISO. Wenn du dort eine Schell hast, dann machst du mal folgendes:

1.

Code: Alles auswählen

 mount /dev/sda2 /mnt
2.

Code: Alles auswählen

chroot /mnt
3.

Code: Alles auswählen

mkinitcpio -p linux
4. 5.

Code: Alles auswählen

umount /mnt && reboot
Bootet dein System jetzt normal?

Benutzeravatar
Herz-von-Hessen
Guru
Guru
Beiträge: 1550
Registriert: 23. Jun 2009, 21:29
Wohnort: Zuhause
Kontaktdaten:

Re: Arch-Linux bootet nicht mehr

Beitrag von Herz-von-Hessen » 3. Mär 2017, 19:35

Hallo spoensche,
spoensche hat geschrieben:
27. Jan 2017, 23:34
Boote mal das Arch Installations ISO. Wenn du dort eine Schell hast, dann machst du mal folgendes:
Ich habe nun tatsächlich die Installations-CD eingelegt und in das System chrootet, dann habe ich erst einmal alle Dateien vom pacman-Cache gelöscht (Partition war zu 99% voll)
Dann habe ich ein Update (pacman -Syv & pacman -Suv) getätigt, die chtoot-Umgebung verlassen und siehe da, der Neustart ist geglückt.

Eine Erklärung was eigentlich passiert ist habe ich aber nicht gefunden :-(

Lieben Gruß aus Zuhaus
Asus P8H77V/ Intel Core i5, 3.10GHz | 8.0gb RAM | NVIDIA GeForce GTX 650 Ti Boost 2GB | Arch-Linux| arch-desktop 4.7.6-1-ARCH | Plasma: 5.8.0.1| HP Officejet Pro 8620

spoensche
Moderator
Moderator
Beiträge: 7239
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: Arch-Linux bootet nicht mehr

Beitrag von spoensche » 10. Mär 2017, 20:28

Also wenn deine / Partition zu 99% voll war, dann ist es klar das da nix mehr bootet. Wenn / nahe voll belegt ist, dann können Systemdienste nicht mehr starten, weil sie die benötigten Dateien nicht mehr in ihrem Homeverzeichnis /var/lib/dienst speichern können. Dies betrifft vor allem die eierlegende Wollmichsau systemd und ohne den geht eben nix.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast