Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

Die Suche ergab 41 Treffer

von kruppa
19. Okt 2020, 22:11
Forum: Internet und Netzwerk
Thema: Langsame Netzwerkverbindung
Antworten: 9
Zugriffe: 6766

Re: Langsame Netzwerkverbindung

Der Download war da ziemlich gut, bei speedtest.net aber immer noch wie bisher.

http://www.dslreports.com/speedtest/65994222
von kruppa
12. Okt 2020, 23:33
Forum: Internet und Netzwerk
Thema: Langsame Netzwerkverbindung
Antworten: 9
Zugriffe: 6766

Re: Langsame Netzwerkverbindung

Da bekomme ich leider nur einen Fehler:

Code: Alles auswählen

ethtool -g eno1
Ring parameters for eno1:
Cannot get device ring settings: Operation not supported
von kruppa
11. Okt 2020, 23:02
Forum: Internet und Netzwerk
Thema: Langsame Netzwerkverbindung
Antworten: 9
Zugriffe: 6766

Re: Langsame Netzwerkverbindung

Das Abschalten von IPv6 scheint nichts gebracht zu haben. ethtool -k eno1 liefert: Features for eno1: rx-checksumming: on tx-checksumming: off tx-checksum-ipv4: off tx-checksum-ip-generic: off [fixed] tx-checksum-ipv6: off tx-checksum-fcoe-crc: off [fixed] tx-checksum-sctp: off [fixed] scatter-gathe...
von kruppa
11. Okt 2020, 15:23
Forum: Internet und Netzwerk
Thema: Langsame Netzwerkverbindung
Antworten: 9
Zugriffe: 6766

Re: Langsame Netzwerkverbindung

Ich habe eine Fritz!Box Cable 6591, die ist mit einem Switch verbunden und dort hängt der Fileserver dran. Ein Windows Notebook am selben Kabel hat bei speedtest.net über 900Mbit/s erreicht.
von kruppa
10. Okt 2020, 19:36
Forum: Internet und Netzwerk
Thema: Langsame Netzwerkverbindung
Antworten: 9
Zugriffe: 6766

Langsame Netzwerkverbindung

Hi, auf meinem Fileserver funktioniert die Netzwerkverbindung nicht so schnell wie ich es erwarten würde. Ich habe einen 1000 Mbit/s Anschuss. Aufgefallen ist mir das bei folgendem Speedtest: speedtest-cli Retrieving speedtest.net configuration... Testing from Vodafone DSL (x.x.x.x)... Retrieving sp...
von kruppa
15. Sep 2017, 01:55
Forum: Internet und Netzwerk
Thema: mehrere gleichzeitig ausgehende IPs
Antworten: 22
Zugriffe: 4751

Re: mehrere gleichzeitig ausgehende IPs

Danke, das mit dem Bridge hört sich gut an. Werde mir das noch genauer ansehen, obwohl ich jetzt mit meinem Script auch eine Lösung gefunden habe. Wahrscheinlich sehr umständlich. Die Option -j SNAT --to-source $ip bei iptables hat den Erfolg gebracht. for ((i=0; i<${#ips[@]}; i++)) do ip=${ips[$i]}...
von kruppa
12. Sep 2017, 17:50
Forum: Internet und Netzwerk
Thema: mehrere gleichzeitig ausgehende IPs
Antworten: 22
Zugriffe: 4751

Re: mehrere gleichzeitig ausgehende IPs

scheinbar zu schwer für mich, welche IP soll ich denn veth0 und welche vpeer0 zuweisen?
von kruppa
12. Sep 2017, 14:51
Forum: Internet und Netzwerk
Thema: mehrere gleichzeitig ausgehende IPs
Antworten: 22
Zugriffe: 4751

Re: mehrere gleichzeitig ausgehende IPs

Ich habe jetzt einen funktionierenden Namespace hinbekommen. Allerdings nur über die IP von eth0. Wie bekomme ich es denn über die IP von eth0:0, eth0:1, usw. hin. ip netns del kab ip netns add kab ip link add veth0 type veth peer name vpeer0 ip link set vpeer0 netns kab ip addr add 10.0.0.1/24 dev ...
von kruppa
11. Sep 2017, 20:13
Forum: Internet und Netzwerk
Thema: mehrere gleichzeitig ausgehende IPs
Antworten: 22
Zugriffe: 4751

Re: mehrere gleichzeitig ausgehende IPs

An der Stelle hab ich ja noch gar keine IP verwendet nur das Device eth0 und ich habe kein anderes. Nur die virtuellen eth0:0 eth0:1 ...

Aber das ist ja nur ein Problem, das eigentliche war ja der Fehler: RTNETLINK answers: Network is unreachable
von kruppa
11. Sep 2017, 16:34
Forum: Internet und Netzwerk
Thema: mehrere gleichzeitig ausgehende IPs
Antworten: 22
Zugriffe: 4751

Re: mehrere gleichzeitig ausgehende IPs

Leider funktioniert es noch nicht. Ich musste den Code ein wenig anpassen, wegen eth1 und der netmask. Habe nun folgendes und bekomme einen Fehler ip netns add my_php_app ip link set dev eth0 netns my_php_app ip netns exec my_php_app ifconfig eth0 *.*.19.90 netmask 255.255.255.255 up ip netns exec m...
von kruppa
7. Sep 2017, 14:26
Forum: Internet und Netzwerk
Thema: mehrere gleichzeitig ausgehende IPs
Antworten: 22
Zugriffe: 4751

Re: mehrere gleichzeitig ausgehende IPs

Ich habe jetzt die Idee die Pakete mit cgroup zu markieren und dann mit iptables entsprechend der IP zuzuweisen. Leider scheint bei folgendem Code irgendein Fehler zu sein: cd /sys/fs/cgroup/net_cls/ mkdir new_route cd new_route echo 0x00110011 > net_cls.classid iptables -t mangle -A OUTPUT -m cgrou...
von kruppa
6. Sep 2017, 10:28
Forum: Internet und Netzwerk
Thema: mehrere gleichzeitig ausgehende IPs
Antworten: 22
Zugriffe: 4751

Re: mehrere gleichzeitig ausgehende IPs

jetzt wäre es schön zu wissen ob man PHP dazu bringen kann die IP zu wählen.
von kruppa
5. Sep 2017, 23:37
Forum: Internet und Netzwerk
Thema: mehrere gleichzeitig ausgehende IPs
Antworten: 22
Zugriffe: 4751

Re: mehrere gleichzeitig ausgehende IPs

Wie weise ich denn einer cgroup ein Device zu? Es sind ja nur Alias-Devices. Ich habe mal folgendes gemacht und bekomme einen Fehler: echo "eth0:0 5" > net_prio.ifpriomap -bash: echo: write error: No such device Lese ich net_prio.ifpriomap aus kommt nur: cat net_prio.ifpriomap lo 0 eth0 0 Was kann i...
von kruppa
1. Sep 2017, 17:51
Forum: Internet und Netzwerk
Thema: mehrere gleichzeitig ausgehende IPs
Antworten: 22
Zugriffe: 4751

Re: mehrere gleichzeitig ausgehende IPs

Der Tipp mit den cgroups hört sich sehr vielversprechen an. Danke. Ich werde es mal probieren
von kruppa
31. Aug 2017, 22:12
Forum: Internet und Netzwerk
Thema: mehrere gleichzeitig ausgehende IPs
Antworten: 22
Zugriffe: 4751

Re: mehrere gleichzeitig ausgehende IPs

Die IPs gehören nicht zur selben Class. Routing habe ich z.B. mit

Code: Alles auswählen

ip route add default dev eth0 via *.*.96.1 src  *.*.19.45
ändern können.
von kruppa
31. Aug 2017, 21:35
Forum: Internet und Netzwerk
Thema: mehrere gleichzeitig ausgehende IPs
Antworten: 22
Zugriffe: 4751

Re: mehrere gleichzeitig ausgehende IPs

ich poste einfach mal die gekürzte Ausgabe von ifconfig: eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 inet *.*.*.4 netmask 255.255.255.255 broadcast *.*.*.4 eth0:0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 inet *.*.*.75 netmask 255.255.255.255 broadcast *.*.*.75 eth0:1: flags...
von kruppa
31. Aug 2017, 20:15
Forum: Internet und Netzwerk
Thema: mehrere gleichzeitig ausgehende IPs
Antworten: 22
Zugriffe: 4751

mehrere gleichzeitig ausgehende IPs

Hallo, ich möchte auf einem Server mehrere IPs nutzen. Diese sind bereits eingerichtet und ich kann auch die ausgehende IP wechseln. Allerdings kann ich immer nur eine IP zur selben Zeit benutzen. Ich würde gerne für verschiedene Programme, verschiedene IPs nutzen. Gibt es da eine Lösung für. Virtue...
von kruppa
31. Jan 2013, 23:03
Forum: Internet und Netzwerk
Thema: Mail aus Cronjob-Script versenden
Antworten: 3
Zugriffe: 784

Mail aus Cronjob-Script versenden

Seit ich auf die Version openSUSE 12.2 64bit umgestellt habe, sendet ein Script was per cronjob ausgeführt keine Mail. Der Code ist: echo "Status-Report" | /usr/bin/mail -s"Status-Report" -a $logfile username Für username hab ich schon alles mögliche ausprobiert, wenn ich das Script normal starte ko...
von kruppa
19. Jan 2013, 22:26
Forum: Systemverwaltung, Administration und Konfiguration
Thema: USB-Festplatte wird sofort aus Standby geholt
Antworten: 3
Zugriffe: 575

Re: USB-Festplatte wird sofort aus Standby geholt

Platte ist nicht gemountet. /var/log/pm-powersave.log existiert nicht dmesg liefert: [ 0.000000] ACPI: IRQ0 used by override. [ 0.000000] ACPI: IRQ2 used by override. [ 0.000000] ACPI: IRQ9 used by override. [ 0.000000] spurious 8259A interrupt: IRQ7. [ 0.001999] Marking TSC unstable due to check_ts...
von kruppa
19. Jan 2013, 22:09
Forum: Systemverwaltung, Administration und Konfiguration
Thema: USB-Festplatte wird sofort aus Standby geholt
Antworten: 3
Zugriffe: 575

USB-Festplatte wird sofort aus Standby geholt

Ich möchte meine USB-Festplatte in den Standby-Modus versetzen. Dies gelingt auch mit dem Befehl: sg_start -S /dev/disk/by-id/usb-Initio_HD160JJ_0010101640000000W-0:0 Allerdings wird sie sofort wieder in Betrieb gesetzt. Ich habe mein System neu aufgesetzt, vorher hat es funktioniert. Jetzt habe ich...