Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] Leap 15.0 - YAST 2 startet nicht mehr

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
thio
Hacker
Hacker
Beiträge: 403
Registriert: 13. Jan 2006, 12:14

[gelöst] Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von thio » 22. Jul 2018, 12:20

Hallo,

mein YAST2 - bzw. die Funktion "Software Management" startet unter Lep 15.0 nicht mehr

ich bekomme folgende Fehlermeldung:

- wo liegt das Problem?
- ruby
- python
- perl
- oder Kernel?

Code: Alles auswählen

linux:~ # yast2
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Run command: /sbin/yast2 sw_single &
Traceback (most recent call last):
        5: from /usr/lib/YaST2/bin/y2start:11:in `<main>'
        4: from /usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
        3: from /usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
        2: from /usr/lib64/ruby/vendor_ruby/2.5.0/yast.rb:22:in `<top (required)>'
        1: from /usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
/usr/lib64/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require': libpy2scr.so.2: cannot open shared object file: No such file or directory - /usr/lib64/ruby/vendor_ruby/2.5.0/x86_64-linux-gnu/yastx.so (LoadError)
Zuletzt geändert von thio am 17. Sep 2018, 19:54, insgesamt 1-mal geändert.

Werbung:
Sauerland
Guru
Guru
Beiträge: 3230
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von Sauerland » 22. Jul 2018, 13:01

Als root:

Code: Alles auswählen

zypper in -f yast2-ruby-bindings yast2-core
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

thio
Hacker
Hacker
Beiträge: 403
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von thio » 22. Jul 2018, 13:46

Danke für den Tip, aber (noch) nicht ganz erfolgreich..

Code: Alles auswählen

oading repository data...                                                                                                                                                                                                                                                                                                   
Reading installed packages...                                                                                                                                                                                                                                                                                                
Forcing installation of 'yast2-core-4.0.2-lp150.1.3.x86_64' from repository 'Lokale RPM'.                                                                                                                                                                                                                                    
Forcing installation of 'yast2-ruby-bindings-4.0.6-lp150.1.1.x86_64' from repository 'rpm_cloud'.                                                                                                                                                                                                                            
Resolving package dependencies...                                                                                                                                                                                                                                                                                            
                                                                                                                                                                                                                                                                                                                             
The following NEW package is going to be installed:                                                                                                                                                                                                                                                                          
  libjemalloc2                                                                                                                                                                                                                                                                                                               
                                                                                                                                                                                                                                                                                                                             
The following 2 packages are going to be reinstalled:                                                                                                                                                                                                                                                                        
  yast2-core yast2-ruby-bindings                                                                                                                                                                                                                                                                                             
                                                                                                                                                                                                                                                                                                                             
The following package is going to change vendor:                                                                                                                                                                                                                                                                             
  yast2-ruby-bindings  obs://build.opensuse.org/YaST -> openSUSE                                                                                                                                                                                                                                                             
                                                                                                                                                                                                                                                                                                                             
1 new package to install, 2 to reinstall, 1 to change vendor.                                                                                                                                                                                                                                                                
Overall download size: 1.2 MiB. Already cached: 0 B. After the operation, additional 527.5 KiB will be used.                                                                                                                                                                                                                 
Continue? [y/n/...? shows all options] (y): y
Retrieving package libjemalloc2-5.0.1-lp150.1.12.x86_64                                                                                                                                                                                                                                 (1/3), 220.4 KiB (605.7 KiB unpacked)
Retrieving package yast2-core-4.0.2-lp150.1.3.x86_64                                                                                                                                                                                                                                    (2/3), 902.5 KiB (  3.1 MiB unpacked)
Retrieving package yast2-ruby-bindings-4.0.6-lp150.1.1.x86_64                                                                                                                                                                                                                           (3/3), 135.1 KiB (421.9 KiB unpacked)
Checking for file conflicts: ..........................................................................................................................................................................................................................................................................................[done]
(1/3) Installing: libjemalloc2-5.0.1-lp150.1.12.x86_64 ................................................................................................................................................................................................................................................................[done]
(2/3) Installing: yast2-core-4.0.2-lp150.1.3.x86_64 ...................................................................................................................................................................................................................................................................[done]
(3/3) Installing: yast2-ruby-bindings-4.0.6-lp150.1.1.x86_64 ..........................................................................................................................................................................................................................................................[done]
Problem occurred during or after installation or removal of packages:                                                                                                                                                                                                                                                        
Failed to cache rpm database (1).                                                                                                                                                                                                                                                                                            
Please see the above error message for a hint.                                                                                                                                                                                                                                                                               
linux:~ #                                                                                                                                                                                                                                                                                                                    

Sauerland
Guru
Guru
Beiträge: 3230
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von Sauerland » 22. Jul 2018, 13:50

The following package is going to change vendor:
yast2-ruby-bindings obs://build.opensuse.org/YaST -> openSUSE
Da wundert mich nichts....

Poste:

Code: Alles auswählen

zypper lr -d
Problem occurred during or after installation or removal of packages:
Failed to cache rpm database (1).
Please see the above error message for a hint.
Als root:

Code: Alles auswählen

zypper clean -a && rpm --rebuilddb
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

thio
Hacker
Hacker
Beiträge: 403
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von thio » 25. Jul 2018, 20:29

Habe ich soweit alles gemacht...
habe dann auch mit zypper dup noch weitere Pakete aktualisiert..

Jetzt ist die Fehlermeldung die folgende:

Code: Alles auswählen

yast2                                                                                                                                                                                                  
Traceback (most recent call last):                                                                                                                                                                               
        1: from <internal:gem_prelude>:2:in `<internal:gem_prelude>'                                                                                                                                             
<internal:gem_prelude>:2:in `require': cannot load such file -- rubygems.rb (LoadError)    
Ach ja, mittlerweile startet aber auch zypper nicht mehr :

Code: Alles auswählen

yast2                                                                                                                                                                                                  
Traceback (most recent call last):                                                                                                                                                                               
        1: from <internal:gem_prelude>:2:in `<internal:gem_prelude>'                                                                                                                                             
<internal:gem_prelude>:2:in `require': cannot load such file -- rubygems.rb (LoadError)    
Jetzt kann ich nur noch über Komandezeile oder "smart" installieren...

Weis jemand Rat?

Sauerland
Guru
Guru
Beiträge: 3230
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von Sauerland » 25. Jul 2018, 20:52

habe dann auch mit zypper dup noch weitere Pakete aktualisiert..
Ne, nicht aktualisiert sondern umgestellt auf ein mir unbekanntes Repo......

Und das hatte ich auch nicht angemerkt......
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

thio
Hacker
Hacker
Beiträge: 403
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von thio » 1. Sep 2018, 13:23

So nach langem startet jetzt YAST zumindest wieder..

Allerdings bekomme ich die Fehlermeldung:

"Cannot read the list of installed packages"


:-(


Zypper wil auch nicht :

Code: Alles auswählen

linux:~ # zypper ref
Target initialization failed:
Failed to cache rpm database (127).



Code: Alles auswählen

rpm --rebuilddb
Ohne Fehlermeldung mehrmals durchgeführt,

Aber hier gibts Probleme:

Code: Alles auswählen

linux:~ # zypper clean -a
Target initialization failed:
Failed to cache rpm database (127).
Cannot clean installed packages cache because of an error.
Some of the repositories have not been cleaned up because of an error.
Was kann ich noch machen?
Zuletzt geändert von thio am 1. Sep 2018, 14:08, insgesamt 3-mal geändert.

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5169
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von tomm.fa » 1. Sep 2018, 13:52

Und nach einem

Code: Alles auswählen

rpm --rebuilddb
, wie schaut es dann aus?

Wie schaut es eigentlich mit den restlichen Antworten zu Sauerlands Fragen und Informationen aus?
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

thio
Hacker
Hacker
Beiträge: 403
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von thio » 1. Sep 2018, 14:04

Sorry, da hat mir mein PC ein eingelegt.

So soll es heißen:

Code: Alles auswählen

rpm --rebuilddb
Ohne Felermeldung mehrmals durchgeführt, aber zypper (und Yast) wollen auch danach trotzdem nicht...

Gibt es noch andere Möglichkeiten die?

Benutzeravatar
tomm.fa
Moderator
Moderator
Beiträge: 5169
Registriert: 21. Jan 2006, 17:18
Wohnort: OWL - Kreis Gütersloh
Kontaktdaten:

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von tomm.fa » 1. Sep 2018, 16:24

Viele Möglichkeiten gibt es nicht mehr. Da du ja auch (nebenbei) andere Dinge als gefordert ausführst und nicht erst das machst was dir geschrieben wird, wird es schwer werden Helfer zu finden die dir noch helfen wollen.
Verwendest du als Dateisystem BTRFS und die Funktion der Schnappschüsse?
Was ergibt die Ausgabe von

Code: Alles auswählen

rpm -qa "*yast*|*zypp*|*rpm*"
?
Linupedia - Wiki des Linux-Club.
Keine Unterstützung/Hilfestellung per PN!

thio
Hacker
Hacker
Beiträge: 403
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von thio » 1. Sep 2018, 17:25

Mein Dateisystem ist ext4 (??)

Code: Alles auswählen

linux:~ # rpm -qa "*yast*|*zypp*|*rpm*"
yast2-ruby-bindings-4.0.6-lp150.1.1.x86_64
python3-rpmconf-1.0.19-lp150.1.4.noarch
yast2-branding-openSUSE-4.0.4-lp150.1.1.noarch
yast2-4.0.79-lp150.2.6.1.x86_64
yast2-installation-4.0.67-lp150.2.9.1.noarch
systemd-rpm-macros-3-lp150.5.20.noarch
yast2-x11-4.0.0-lp150.1.3.x86_64
ruby2.5-rubygem-yast-rake-0.2.21-lp150.1.1.x86_64
yast2-firewall-4.0.25-lp150.1.1.noarch
patterns-yast-x11_yast-20180409-lp150.3.1.x86_64
yast2-firstboot-4.0.5-lp150.2.3.1.noarch
yast2-metapackage-handler-4.0.0-lp150.1.3.noarch
python-rpm-macros-2017.12.22.d9968ab-lp150.1.6.noarch
yast2-update-4.0.17-lp150.2.3.1.x86_64
yast2-nfs-client-4.0.6-lp150.2.3.1.noarch
yast2-sound-3.1.10-lp150.1.24.x86_64
yast2-installation-control-4.0.10-lp150.1.1.noarch
yast2-online-update-4.0.0-lp150.1.1.noarch
yast2-rmt-1.0.0-lp150.2.3.2.noarch
yast2-control-center-qt-4.0.3-lp150.1.1.x86_64
yast2-storage-ng-4.0.200-lp150.2.9.1.x86_64
yast2-add-on-4.0.8-lp150.1.1.noarch
ruby2.5-rubygem-gem2rpm-0.10.1-lp150.3.30.x86_64
patterns-kde-kde_yast-20170319-lp150.7.1.noarch
yast2-auth-server-4.0.0-lp150.1.1.noarch
yast2-network-4.0.31-lp150.1.1.noarch
yast2-ntp-client-4.0.12-lp150.1.1.noarch
yast2-vpn-3.1.5-lp150.1.5.noarch
yast2-online-update-frontend-4.0.0-lp150.1.1.noarch
yast2-trans-en-84.87.20180514.157a0650d-lp150.1.1.noarch
patterns-yast-yast2_basis-20180409-lp150.3.1.x86_64
yast2-tune-4.0.0-lp150.1.7.x86_64
yast2-ldap-4.0.0-lp150.1.1.x86_64
yast2-bootloader-4.0.35-lp150.2.5.1.x86_64
yast2-scanner-4.0.1-lp150.1.1.x86_64
yast2-trans-de-84.87.20180514.157a0650d-lp150.1.1.noarch
yast2-auth-client-4.0.0-lp150.1.1.noarch
python2-zypp-plugin-0.6.3-lp150.1.2.noarch
yast2-trans-stats-2.19.0-lp150.1.6.noarch                                                                                                                                                                                                                                                                                    
yast2-control-center-4.0.3-lp150.1.1.x86_64                                                                                                                                                                                                                                                                                  
yast2-nfs-common-4.0.0-lp150.1.4.noarch                                                                                                                                                                                                                                                                                      
PackageKit-backend-zypp-1.1.10-lp150.2.1.x86_64                                                                                                                                                                                                                                                                              
yast2-iscsi-client-4.0.0-lp150.1.1.noarch                                                                                                                                                                                                                                                                                    
zypper-aptitude-1.14.5-lp150.1.1.noarch                                                                                                                                                                                                                                                                                      
yast2-pam-4.0.0-lp150.1.1.noarch                                                                                                                                                                                                                                                                                             
yast2-proxy-4.0.1-lp150.2.3.1.noarch                                                                                                                                                                                                                                                                                         
yast2-hardware-detection-4.0.0-lp150.1.1.x86_64                                                                                                                                                                                                                                                                              
deltarpm-3.6.1-lp150.3.2.x86_64                                                                                                                                                                                                                                                                                              
yast2-samba-client-4.0.1-lp150.1.1.noarch                                                                                                                                                                                                                                                                                    
patterns-yast-yast2_install_wf-20180409-lp150.3.1.x86_64                                                                                                                                                                                                                                                                     
yast2-support-3.2.0-lp150.1.5.noarch                                                                                                                                                                                                                                                                                         
yast2-journal-4.0.0-lp150.1.1.noarch                                                                                                                                                                                                                                                                                         
python3-rpm-4.14.1-lp150.9.3.1.x86_64                                                                                                                                                                                                                                                                                        
yast2-squid-4.0.1-lp150.1.4.x86_64                                                                                                                                                                                                                                                                                           
yast2-sudo-3.1.2-lp150.1.9.noarch                                                                                                                                                                                                                                                                                            
yast2-apparmor-4.0.4-lp150.1.3.noarch                                                                                                                                                                                                                                                                                        
yast2-country-4.0.22-lp150.2.3.1.x86_64                                                                                                                                                                                                                                                                                      
rpm-4.14.1-lp150.9.3.1.x86_64                                                                                                                                                                                                                                                                                                
yast2-core-4.0.3-lp150.2.3.1.x86_64                                                                                                                                                                                                                                                                                          
rpm-32bit-4.14.1-lp150.9.3.1.x86_64                                                                                                                                                                                                                                                                                          
yast2-xml-4.0.0-lp150.1.1.x86_64                                                                                                                                                                                                                                                                                             
yast2-slp-4.0.0-lp150.1.1.x86_64                                                                                                                                                                                                                                                                                             
yast2-qt-branding-openSUSE-15.0-lp150.6.1.noarch                                                                                                                                                                                                                                                                             
yast2-users-4.0.5-lp150.1.1.x86_64                                                                                                                                                                                                                                                                                           
autoyast2-installation-4.0.55-lp150.2.3.1.noarch                                                                                                                                                                                                                                                                             
yast2-country-data-4.0.22-lp150.2.3.1.x86_64                                                                                                                                                                                                                                                                                 
yast2-vm-4.0.1-lp150.1.1.x86_64                                                                                                                                                                                                                                                                                              
yast2-samba-server-4.0.1-lp150.1.2.noarch                                                                                                                                                                                                                                                                                    
yast2-perl-bindings-4.0.1-lp150.2.1.x86_64                                                                                                                                                                                                                                                                                   
yast2-printer-4.0.2-lp150.2.3.1.x86_64                                                                                                                                                                                                                                                                                       
python2-rpm-4.14.1-lp150.9.3.1.x86_64                                                                                                                                                                                                                                                                                        
zypper-1.14.5-lp150.1.1.x86_64                                                                                                                                                                                                                                                                                               
yast2-configuration-management-4.0.2-lp150.1.3.noarch                                                                                                                                                                                                                                                                        
yast2-packager-4.0.67-lp150.2.6.2.x86_64                                                                                                                                                                                                                                                                                     
yast2-security-4.0.0-lp150.1.1.noarch                                                                                                                                                                                                                                                                                        
yast2-sysconfig-4.0.0-lp150.1.1.noarch                                                                                                                                                                                                                                                                                       
yast2-ycp-ui-bindings-4.0.0-lp150.1.4.x86_64                                                                                                                                                                                                                                                                                 
yast2-fonts-4.0.0-lp150.1.1.x86_64                                                                                                                                                                                                                                                                                           
yast2-branding-openSUSE-Oxygen-4.0.4-lp150.1.1.noarch                                                                                                                                                                                                                                                                        
yast2-buildtools-4.0.5-lp150.1.1.noarch                                                                                                                                                                                                                                                                                      
yast2-pkg-bindings-4.0.11-lp150.2.6.1.x86_64                                                                                                                                                                                                                                                                                 
yast2-transfer-4.0.0-lp150.1.1.x86_64                                                                                                                                                                                                                                                                                        
libzypp-17.3.1-lp150.1.1.x86_64                                                                                                                                                                                                                                                                                              
yast2-services-manager-4.0.3-lp150.1.3.noarch                                                                                                                                                                                                                                                                                
yast2-nis-client-4.0.2-lp150.1.4.x86_64                                                                                                                                                                                                                                                                                      
python3-zypp-plugin-0.6.3-lp150.1.2.noarch                                                                                                                                                                                                                                                                                   
yast2-online-update-configuration-4.0.0-lp150.1.5.noarch
rpm-build-4.14.1-lp150.9.3.1.x86_64
zypper-log-1.14.5-lp150.1.1.noarch
yast2-schema-4.0.2-lp150.1.2.x86_64
yast2-mail-4.0.3-lp150.1.2.noarch

thio
Hacker
Hacker
Beiträge: 403
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von thio » 1. Sep 2018, 17:34

Wenn man ein bisserl "radikaler" ran geht?

Code: Alles auswählen

/var/lib/rpm,
hier alles darin liegenden Dateien löschen?

Und dann

Code: Alles auswählen

rpm --rebuilddb
Kann das Efolg bringen?

(falls nein, kann ich ja alle Dateien wieder aus dem Papierkorb zurückschieben, oder?

thio
Hacker
Hacker
Beiträge: 403
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von thio » 1. Sep 2018, 18:02

Hat zunächst keine Erfolg gebracht, aber ich befürchte, das ich ein Problem mit dem "Pfad" habe...

Die entsprechenden Dateien sollen doch hier liegen,oder ?

Code: Alles auswählen

/var/lib/rpm/
Offensichtlich wird bei mir aber weitergelikt auf:

Code: Alles auswählen

/usr/lib/sysimage/rpm/
Ist das so korrekt?

Daruf komme ich wenn ich folgenden Befehl aufrufe:

Code: Alles auswählen

linux:~ # rpm -vv --rebuilddb
ufdio:       1 reads,    19077 total bytes in 0.000006 secs
D: rebuilding database /usr/lib/sysimage/rpm into /usr/lib/sysimage/rpmrebuilddb.3792
D: opening  db environment /usr/lib/sysimage/rpm private:0x201
D: opening  db index       /usr/lib/sysimage/rpm/Packages 0x400 mode=0x0
D: opening  db index       /usr/lib/sysimage/rpm/Packages 0x1 mode=0x0
D: locked   db index       /usr/lib/sysimage/rpm/Packages
D: disabling fsync on database
D: opening  db environment /usr/lib/sysimage/rpmrebuilddb.3792 private:0x201
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Packages (none) mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Packages 0x1 mode=0x42
D: disabling fsync on database
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Name nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Name nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Basenames nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Basenames nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Group nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Group nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Requirename nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Requirename nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Providename nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Providename nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Conflictname nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Conflictname nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Obsoletename nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Obsoletename nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Triggername nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Triggername nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Dirnames nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Dirnames nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Installtid nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Installtid nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Sigmd5 nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Sigmd5 nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Sha1header nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Sha1header nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Filetriggername nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Filetriggername nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Transfiletriggername nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Transfiletriggername nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Recommendname nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Recommendname nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Suggestname nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Suggestname nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Supplementname nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Supplementname nofsync:0x1 mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Enhancename nofsync mode=0x42
D: opening  db index       /usr/lib/sysimage/rpmrebuilddb.3792/Enhancename nofsync:0x1 mode=0x42
D: closed   db index       /usr/lib/sysimage/rpm/Packages
D: closed   db environment /usr/lib/sysimage/rpm
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Packages
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Enhancename
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Supplementname
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Suggestname
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Recommendname
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Transfiletriggername
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Filetriggername
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Sha1header
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Sigmd5
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Installtid
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Dirnames
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Triggername
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Obsoletename
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Conflictname
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Providename
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Requirename
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Group
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Basenames
D: closed   db index       /usr/lib/sysimage/rpmrebuilddb.3792/Name
D: closed   db environment /usr/lib/sysimage/rpmrebuilddb.3792

Sauerland
Guru
Guru
Beiträge: 3230
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von Sauerland » 1. Sep 2018, 19:24

Mal eine Frage:
Hast du nicht mitbekommen, das du ein Mischmasch aus verschiedenen Repos hast?????

Und hier zwar anfragst, dann aber einfach nur das machst, was du meinst machen zu müssen und nicht was dir gesagt wird?

Übrigens:

Code: Alles auswählen

ls -al /var/lib/ | grep -i rpm
lrwxrwxrwx 1 root          root            26 Jul 26 18:12 rpm -> ../../usr/lib/sysimage/rpm
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

josef-wien
Ultimate Guru
Ultimate Guru
Beiträge: 5107
Registriert: 23. Sep 2008, 17:09

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von josef-wien » 1. Sep 2018, 22:21

Mit chaotischem Löschen wichtiger Dateien löst Du keine Probleme, sondern Du schaffst neue. Deine RPM-Datenbank war bis zu Deiner Löschorgie in Ordnung, die Probleme liegen woanders. Wenn
tomm.fa hat geschrieben:
1. Sep 2018, 16:24

Code: Alles auswählen

rpm -qa "*yast*|*zypp*|*rpm*"
jetzt ein anderes Ergebnis als um 17:25 Uhr liefern sollte, ist es Dir gelungen, die Datenbank zu zerstören, und dann ist jede Aktion außer der Wiederherstellung der gesamten Systempartition von einer Sicherungskopie der Anfang neuer Probleme.

thio
Hacker
Hacker
Beiträge: 403
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von thio » 2. Sep 2018, 09:59

Von gerade eben:

Code: Alles auswählen

linux:~ # rpm -qa "*yast*|*zypp*|*rpm*"
yast2-nfs-client-4.0.6-lp150.2.3.1.noarch
yast2-x11-4.0.0-lp150.1.3.x86_64
yast2-ycp-ui-bindings-4.0.0-lp150.1.4.x86_64
yast2-perl-bindings-4.0.1-lp150.2.1.x86_64
yast2-scanner-4.0.1-lp150.1.1.x86_64
zypper-lifecycle-plugin-0.6.1490613702.a925823-lp150.2.4.noarch
yast2-pam-4.0.0-lp150.1.1.noarch
yast2-hardware-detection-4.0.0-lp150.1.1.x86_64
yast2-trans-de-84.87.20180514.157a0650d-lp150.1.1.noarch
rpm-4.14.1-lp150.9.3.1.x86_64
deltarpm-3.6.1-lp150.3.2.x86_64
yast2-slp-4.0.0-lp150.1.1.x86_64
yast2-schema-4.0.2-lp150.1.2.x86_64
yast2-fonts-4.0.0-lp150.1.1.x86_64
yast2-mail-4.0.3-lp150.1.2.noarch
yast2-sound-3.1.10-lp150.1.24.x86_64
yast2-branding-openSUSE-Oxygen-4.0.4-lp150.1.1.noarch
yast2-core-4.0.3-lp150.2.3.1.x86_64
yast2-iscsi-client-4.0.0-lp150.1.1.noarch
yast2-python-bindings-4.0.3-lp150.1.1.x86_64
ruby2.5-rubygem-gem2rpm-0.10.1-lp150.3.30.x86_64
yast2-country-data-4.0.22-lp150.2.3.1.x86_64
yast2-ldap-4.0.0-lp150.1.1.x86_64
yast2-trans-stats-2.19.0-lp150.1.6.noarch
yast2-firewall-4.0.25-lp150.1.1.noarch
zypper-log-1.14.5-lp150.1.1.noarch
yast2-control-center-qt-4.0.3-lp150.1.1.x86_64
yast2-auth-client-4.0.0-lp150.1.1.noarch
yast2-country-4.0.22-lp150.2.3.1.x86_64
yast2-support-3.2.0-lp150.1.5.noarch
yast2-branding-openSUSE-4.0.4-lp150.1.1.noarch
yast2-online-update-4.0.0-lp150.1.1.noarch
yast2-nfs-common-4.0.0-lp150.1.4.noarch
yast2-samba-server-4.0.1-lp150.1.2.noarch
rpm-32bit-4.14.1-lp150.9.3.1.x86_64
yast2-sysconfig-4.0.0-lp150.1.1.noarch
yast2-proxy-4.0.1-lp150.2.3.1.noarch
yast2-network-4.0.31-lp150.1.1.noarch
yast2-metapackage-handler-4.0.0-lp150.1.3.noarch                                                                                                                                                                 
yast2-ruby-bindings-4.0.6-lp150.1.1.x86_64                                                                                                                                                                       
python2-zypp-plugin-0.6.3-lp150.1.2.noarch                                                                                                                                                                       
yast2-4.0.79-lp150.2.6.1.x86_64                                                                                                                                                                                  
yast2-online-update-frontend-4.0.0-lp150.1.1.noarch                                                                                                                                                              
yast2-update-4.0.17-lp150.2.3.1.x86_64                                                                                                                                                                           
yast2-control-center-4.0.3-lp150.1.1.x86_64                                                                                                                                                                      
yast2-python3-bindings-4.0.3-lp150.1.1.x86_64                                                                                                                                                                    
yast2-transfer-4.0.0-lp150.1.1.x86_64                                                                                                                                                                            
yast2-services-manager-4.0.3-lp150.1.3.noarch                                                                                                                                                                    
yast2-auth-server-4.0.0-lp150.1.1.noarch                                                                                                                                                                         
yast2-pkg-bindings-4.0.11-lp150.2.6.1.x86_64                                                                                                                                                                     
yast2-security-4.0.0-lp150.1.1.noarch                                                                                                                                                                            
yast2-storage-ng-4.0.200-lp150.2.9.1.x86_64                                                                                                                                                                      
python2-rpm-4.14.1-lp150.9.3.1.x86_64                                                                                                                                                                            
yast2-packager-4.0.67-lp150.2.6.2.x86_64
yast2-nis-client-4.0.2-lp150.1.4.x86_64
systemd-rpm-macros-3-lp150.5.20.noarch
yast2-trans-en-84.87.20180514.157a0650d-lp150.1.1.noarch
yast2-sudo-3.1.2-lp150.1.9.noarch
yast2-tune-4.0.0-lp150.1.7.x86_64
zypper-aptitude-1.14.5-lp150.1.1.noarch
libzypp-17.3.1-lp150.1.1.x86_64
yast2-qt-branding-openSUSE-15.0-lp150.6.1.noarch
patterns-yast-yast2_basis-20180409-lp150.3.1.x86_64
python3-rpm-4.14.1-lp150.9.3.1.x86_64
python3-rpmconf-1.0.19-lp150.1.4.noarch
autoyast2-installation-4.0.55-lp150.2.3.1.noarch
yast2-ntp-client-4.0.12-lp150.1.1.noarch
PackageKit-backend-zypp-1.1.10-lp150.2.1.x86_64
ruby2.5-rubygem-yast-rake-0.2.21-lp150.1.1.x86_64
yast2-vpn-3.1.5-lp150.1.5.noarch
zypper-1.14.5-lp150.1.1.x86_64
patterns-yast-yast2_install_wf-20180409-lp150.3.1.x86_64
yast2-journal-4.0.0-lp150.1.1.noarch
yast2-bootloader-4.0.35-lp150.2.5.1.x86_64
yast2-users-4.0.5-lp150.2.1.x86_64
python-rpm-macros-2017.12.22.d9968ab-lp150.1.6.noarch
yast2-vm-4.0.1-lp150.1.1.x86_64
yast2-samba-client-4.0.1-lp150.1.1.noarch
yast2-printer-4.0.2-lp150.2.3.1.x86_64
yast2-add-on-4.0.8-lp150.1.1.noarch
patterns-yast-x11_yast-20180409-lp150.3.1.x86_64
yast2-installation-4.0.67-lp150.2.9.1.noarch
python3-zypp-plugin-0.6.3-lp150.1.2.noarch
yast2-xml-4.0.0-lp150.1.1.x86_64
yast2-apparmor-4.0.4-lp150.1.3.noarch
patterns-kde-kde_yast-20170319-lp150.7.1.noarch
P.s. Mit dem Smart-Paket Manager kann ich immer noch Pakete aktualisieren/ löschen etc...

Sauerland
Guru
Guru
Beiträge: 3230
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von Sauerland » 2. Sep 2018, 10:07

P.s. Mit dem Smart-Paket Manager kann ich immer noch Pakete aktualisieren/ löschen etc...
Den es jedoch nicht in den offiziellen Repos gibt.
Daher wäre das hier eigentlich nötig:
Sauerland hat geschrieben:
22. Jul 2018, 13:50

Poste:

Code: Alles auswählen

zypper lr -d
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

thio
Hacker
Hacker
Beiträge: 403
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von thio » 2. Sep 2018, 10:50

Code: Alles auswählen

Passwort: 
linux:~ # zypper lr -d
Repository priorities in effect:                                                                                                                                                 (See 'zypper lr -P' for details)
      98 (raised priority)  :  1 repository  
      99 (default priority) : 12 repositories

#  | Alias                                          | Name                                           | Enabled | GPG Check | Refresh | Priority | Type     | URI                                                                                                     | Service
---+------------------------------------------------+------------------------------------------------+---------+-----------+---------+----------+----------+---------------------------------------------------------------------------------------------------------+--------
 1 | KDE_"Distro_Factory"_-_openSUSE_Factory        | KDE "Distro Factory" - openSUSE_Factory        | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/KDE:/Distro:/Factory/openSUSE_Factory/                        |        
 2 | KDE_3_-_Opensuse_13.2                          | KDE 3 - Opensuse 42.3                          | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_Leap_42.3                                  |        
 3 | Leap42.3                                       | Leap42.3                                       | No      | ----      | ----    |   99     | yast2    | iso:///?iso=openSUSE-Leap-42.3-DVD-x86_64.iso&url=dir%3A%2Fhome%2Fdavid%2Fopensuse                      |        
 4 | Leap_15.0_ISO                                  | Leap 15.0 ISO                                  | Yes     | ( p) Yes  | No      |   99     | rpm-md   | iso:///?iso=openSUSE-Leap-15.0-DVD-x86_64.iso&url=dir%3A%2Fhome%2Fdavid%2Fopensuse                      |        
 5 | Leap_42.2_OSS_Repo                             | Leap 42.3 OSS Repo                             | No      | ----      | ----    |   99     | yast2    | http://download.opensuse.org/distribution/leap/42.3/repo/oss/                                           |        
 6 | Lokale_RPM                                     | Lokale RPM                                     | No      | ----      | ----    |   99     | plaindir | dir:///home/david/opensuse/rpm                                                                          |        
 7 | Mozilla_Repository_-_Opensuse_13.2             | Mozilla Repository - Opensuse Leap_15.0        | Yes     | ( p) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.0                                    |        
 8 | Multimedia_Apps_-_Opensuse_13.2                | MultimediaApps_Opensuse Leap_15.0              | Yes     | ( p) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/multimedia:/apps/openSUSE_Leap_15.0                           |        
 9 | Multimedia_Libs_-_Opensuse_13.2                | MultimediaLibs_Opensuse_Leap_15.0              | Yes     | ( p) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_Leap_15.0                           |        
10 | Packman Repository                             | Packman Repository - 42.3                      | No      | ----      | ----    |   99     | rpm-md   | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.3                                            |        
11 | Packman_Repository_-_Tumbleweed                | Packman Repository - openSUSE_Leap_15.0        | Yes     | ( p) Yes  | Yes     |   99     | rpm-md   | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.0/                                      |        
12 | Printing_Repository_-_Opensuse_13.2            | Printing Repository - Opensuse Leap 15.0       | Yes     | ( p) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/Printing/openSUSE_Leap_15.0                                   |        
13 | Update_Leap_42.2_OSS                           | Update Leap 42.3 OSS                           | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/update/leap/42.3/oss/                                                      |        
14 | VideoLan_Repository_-_Opensuse_13.2            | VideoLan Repository - Opensuse Leap_15.0       | Yes     | ( p) Yes  | Yes     |   99     | rpm-md   | http://download.videolan.org/pub/videolan/vlc/SuSE/Leap_15.0                                            |        
15 | chromium_-_Opensuse_13.2                       | chromium - Opensuse Leap_15.0                  | Yes     | ( p) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/network:/chromium/openSUSE_Leap_15.0                          |        
16 | google-chrome                                  | google-chrome                                  | Yes     | ( p) Yes  | Yes     |   99     | rpm-md   | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                                     |                                                                                                                                                            
17 | google-earth                                   | google-earth                                   | Yes     | ( p) Yes  | Yes     |   99     | rpm-md   | http://dl.google.com/linux/earth/rpm/stable/x86_64                                                      |                                                                                                                                                            
18 | hardware_-_OpenSUSE_13.2                       | hardware - OpenSUSE_42.3                       | Yes     | ( p) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/hardware/openSUSE_Leap_42.3                                   |                                                                                                                                                            
19 | home:doiggl                                    | home:doiggl -/openSUSE_Factory                 | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/home:/doiggl/openSUSE_Factory/                                |                                                                                                                                                            
20 | http-download.opensuse.org-3a1885ac            | X11:Utilities - 42.3                           | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/X11:/Utilities/openSUSE_Leap_42.3                             |                                                                                                                                                            
21 | http-download.opensuse.org-65eae52c            | Mono - openSUSE_Leap_42.3                      | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/Mono/openSUSE_Leap_42.3                                       |                                                                                                                                                            
22 | http-download.opensuse.org-6f5bbd02            | home:cwx_holle "Java" - openSUSE_Leap_42.2     | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/home:/cwx_holle/openSUSE_Leap_42.2/                           |                                                                                                                                                            
23 | http-download.opensuse.org-80900ef8            | GNOME:Apps -openSUSE_Leap_15.0                 | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_Leap_15.0                                |        
24 | http-download.opensuse.org-98fadd6f            | isv:ownCloud:desktop - openSUSE_Leap_15.0      | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/isv:/ownCloud:/desktop/openSUSE_Leap_15.0                     |        
25 | http-download.opensuse.org-c2cdc925            | home:mnhauke:sdr - 42.3                        | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/home:/mnhauke:/sdr/openSUSE_Leap_42.3/                        |        
26 | http-download.opensuse.org-e0755369            | home:mnhauke:ODR-mmbTools - 42.3               | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/home:/mnhauke:/ODR-mmbTools/openSUSE_Leap_42.3/               |        
27 | http-download.opensuse.org-ea420061            | home:pgnd:Kernel:stable 42.3                   | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/home:/pgnd:/Kernel:/stable/openSUSE_Leap_42.3/                |        
28 | kde4_repo                                      | kde4_repo                                      | No      | ----      | ----    |   99     | plaindir | dir:///home/david/opensuse/rpm/kde4_repo/                                                               |        
29 | libdvdcss repository                           | libdvdcss repository - 42.3                    | No      | ----      | ----    |   99     | rpm-md   | http://opensuse-guide.org/repo/openSUSE_Leap_42.3                                                       |        
30 | malcolmlewis_-_openSUSE_Leap_42.2              | malcolmlewis - openSUSE_Leap_42.3              | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/home:/malcolmlewis:/TESTING/openSUSE_Leap_42.3                |        
31 | marceloatie_-_openSUSE_Leap_42.2               | marceloatie - openSUSE_Leap_42.3               | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/home:/marceloatie/openSUSE_Leap_42.3                          |        
32 | network                                        | network - openSUSE_Leap_42.3                   | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/network/openSUSE_Leap_42.3                                    |        
33 | polyconvex_-"JAVA_Oracle"_-_openSUSE_Leap_42.3 | polyconvex -"JAVA Oracle" - openSUSE_Leap_42.3 | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/home:/polyconvex/openSUSE_Leap_42.3                           |        
34 | repo-update-non-oss                            | openSUSE-42.3-Update-Non-Oss                   | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/update/leap/42.3/non-oss/                                                  |        
35 | rpm_cloud                                      | rpm_cloud                                      | No      | ----      | ----    |   99     | plaindir | dir:///home/david/ownCloud/rpm_cloud/                                                                   |        
36 | tumbleweed                                     | tumbleweed                                     | No      | ----      | ----    |   99     | yast2    | http://download.opensuse.org/tumbleweed/repo/oss/                                                       |        
37 | wolfi2                                         | KDE 4 "Wolfi323" - Opensuse Leap_15.0          | Yes     | ( p) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/home:/wolfi323:/branches:/KDE:/Frameworks5/openSUSE_Leap_15.0 |        
38 | xorg_-_Opensuse_13.2                           | xorg - Opensuse Leap_15.0                      | Yes     | ( p) Yes  | Yes     |   98     | rpm-md   | http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_Leap_15.0/                                 |        
39 | yast132                                        | yast132                                        | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/YaST:/openSUSE:/13.2/openSUSE_13.2/                           |        
40 | yasthead                                       | yasthead                                       | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/repositories/YaST:/Head/openSUSE_13.2_Update/     

Sauerland
Guru
Guru
Beiträge: 3230
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von Sauerland » 2. Sep 2018, 11:04

Schau dir mal die ganzen URLs an.......

Ich würde erst mal alle, die kein 15.0 in der URL haben, löschen.......

Sowie Multimedia-libs-Repo und VLC-Repo. Die ergeben bei unsachgemäßem Gebrauch eh nur Schwierigkeiten mit dem Packman Repo.....

Sodann fehlt das OSS und Update-OSS Repo für Leap15.0............
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

thio
Hacker
Hacker
Beiträge: 403
Registriert: 13. Jan 2006, 12:14

Re: Leap 15.0 - YAST 2 startet nicht mehr

Beitrag von thio » 17. Sep 2018, 19:53

So Yast2 & zypper starten wieder :-)

Dank dem smart-paketmanager..

Heute habe ich aktualisierte Pakete für "zypper" und "zsh" in Update-Repo gefunden.

Wie ich die aktualisieren wollte, hat smart zusätzlich noch das Paket "libzstd1" installieren...
Seitdem starten Yast2 & zypper wieder und können auch die Datenbank der installierten Pakete wieder lesen....

Antworten