Diese Website existiert nur weil wir Werbung mit AdSense ausliefern.
Bitte den AdBlocker daher auf dieser Website ausschalten! Danke.

[gelöst] leap 42.2 kernel panic bei shutdown

Alles rund um die Installation Eures Linuxsystems, sowie die Updatefunktionen des Systems und das Paketmanagement

Moderator: Moderatoren

Antworten
gorgonz
Member
Member
Beiträge: 166
Registriert: 13. Mai 2006, 19:37
Wohnort: Frankenland

[gelöst] leap 42.2 kernel panic bei shutdown

Beitrag von gorgonz » 13. Jul 2017, 13:23

muss gestehen, hab mich nicht gleich drum gekümmert. Seit 2 kernel updates fährt leap 42.2 nicht mehr sauber runter resp. stoppt mit kernel panic.

Ich kann leider nicht unterscheiden, ob es ein HW Problem ist oder SW, hier ein Screenshot:

https://postimg.org/image/7iiilvhfv/

Kann jemand etwas dazu sagen, ob HW oder SW? Wenn letzteres zutrifft, wie könnte eine Behebung aussehen?

Vorab schon thxalot :-)
Zuletzt geändert von gorgonz am 31. Aug 2017, 03:08, insgesamt 1-mal geändert.
Meine Systeme:
PC (I7-2600K): openSUSE leap 15.0 (64bit), QT 5.9.4, KDE Frameworks 5.45.0, 4.12.14-lp150.12.13-default
Laptop: Samsung RC530 (I7-2670QM), openSUSE tumbleweed, QT 5.11.0, KDE Frameworks 5.47.0, kernel 4.17.5-1-default

Werbung:
Benutzeravatar
susejunky
Hacker
Hacker
Beiträge: 422
Registriert: 19. Sep 2014, 18:22

Re: leap 42.2 kernel panic bei shutdown

Beitrag von susejunky » 14. Jul 2017, 13:10

Hallo gorgonz,
gorgonz hat geschrieben:
13. Jul 2017, 13:23
muss gestehen, hab mich nicht gleich drum gekümmert. Seit 2 kernel updates fährt leap 42.2 nicht mehr sauber runter resp. stoppt mit kernel panic.

Ich kann leider nicht unterscheiden, ob es ein HW Problem ist oder SW, hier ein Screenshot:

https://postimg.org/image/7iiilvhfv/

Kann jemand etwas dazu sagen, ob HW oder SW? Wenn letzteres zutrifft, wie könnte eine Behebung aussehen?

Vorab schon thxalot :-)
Da ich eine neuere Kernelversion (http://download.opensuse.org/repositori ... /standard/) nutze, kann ich Dein Problem bei mir nicht nachvollziehen.

Aber auf der openSUSE-Mailingliste wird ein sehr ähnliches Problem diskutiert:

https://lists.opensuse.org/opensuse/201 ... 00202.html

Vielleicht findest Du dort eine Lösung.

Viele Grüße

susejunky

gorgonz
Member
Member
Beiträge: 166
Registriert: 13. Mai 2006, 19:37
Wohnort: Frankenland

Re: leap 42.2 kernel panic bei shutdown

Beitrag von gorgonz » 14. Jul 2017, 20:14

Hey susejunky,

das scheint echt die richtige Spur zu sein, vielen Dank :-).
Ich hoffte anfangs, das das mit dem nächsten Kernel update verschwinden würde, aber so nach 2 weiteren Updates glaube ich nicht mehr dran ;-).

Dass ich einen anderen Kernel drunter heben könnte, hat mir schon mal jemand (in anderem Zusammenhang) gesagt. Kann ich das einfach umstellen und die ganzen Programme ersp. Treiber laufen dann auch wieder?
Meine Systeme:
PC (I7-2600K): openSUSE leap 15.0 (64bit), QT 5.9.4, KDE Frameworks 5.45.0, 4.12.14-lp150.12.13-default
Laptop: Samsung RC530 (I7-2670QM), openSUSE tumbleweed, QT 5.11.0, KDE Frameworks 5.47.0, kernel 4.17.5-1-default

Freddie62
Guru
Guru
Beiträge: 1548
Registriert: 24. Jan 2006, 14:21

Re: leap 42.2 kernel panic bei shutdown

Beitrag von Freddie62 » 14. Jul 2017, 20:32

Solange Du keine proprietären Grafiktreiber (Nvidia, AMD) nutzt, ist das bis auf wenige Ausnahmen völlig problemlos (Spezielle dazugeladene Kerneltreiber). Falls Du jedoch derartige Grafiktreiber nutzt, mußt Du zunächst den benötigten Graka-Treiber von der Homepage des Herstellers herunterladen. Dann fügst Du das Kernel-Repo hinzu und stellst die Priorität so ein, daß Sie höher ist, als die des "Update-Repos". Dann bootest Du in "init 3" (Textmodus), deinstallierst mit YaST den Grafiktreiber. Nun installierst Du den aktuellen Kernel sowie die Kernel-Sourcen, make und gcc per YaST. Anschließend installierst Du den heruntergeladenen Treiber (Meist ein Script). Anschließend muß ein Neustart durchgeführt werden. Dann sollte Alles wieder gehen. Falls es Probleme gibt, findest Du den Grund im install.log des Graka-Treibers.

CU Freddie
Leap 42.3, Kernel: 4.4, LXDE. Schleppi: Dell Latitude 5520 mit Win7 Prof./Leap42.3-X64, Kernel: 4.14.15-5.g9a6fca5-default, LXDE

gorgonz
Member
Member
Beiträge: 166
Registriert: 13. Mai 2006, 19:37
Wohnort: Frankenland

Re: leap 42.2 kernel panic bei shutdown

Beitrag von gorgonz » 14. Jul 2017, 22:57

Wow Freddie62,

vielen Dank für diese genaue Beschreibung :-).
Ich denke, dann probier ich das mal. Gerade, wo jetzt 42.3 vor der Tür steht, wird wohl nicht mehr viel passieren bei 42.2 ;-).
Meine Systeme:
PC (I7-2600K): openSUSE leap 15.0 (64bit), QT 5.9.4, KDE Frameworks 5.45.0, 4.12.14-lp150.12.13-default
Laptop: Samsung RC530 (I7-2670QM), openSUSE tumbleweed, QT 5.11.0, KDE Frameworks 5.47.0, kernel 4.17.5-1-default

Sauerland
Guru
Guru
Beiträge: 3209
Registriert: 5. Aug 2007, 17:57
Wohnort: Sauerland

Re: leap 42.2 kernel panic bei shutdown

Beitrag von Sauerland » 15. Jul 2017, 06:47

Nimm statt kernel-source besser kernel-devel und kernel-default-devel.
Dann funktioniert es sofort.

Und den Nvidia Treiber im Runlevel 3 (multi-user.target) installieren.
Evtl. würde auch Leap 42.3 funktionieren, obwohl der Kernel dort auch nur "4.4" ist, wurden dort einige Sachen aus neueren Kernel eingebaut. Das erschwert sogar das Packetieren neuerer Kernel-Treiber und Virtualbox von Oracle (aus dem Oracle Repo, nicht die Version von openSUSE) Version 5.1.22 funktioniert nicht.
Desktop: OpenSUSE Leap 15.0, Nvidia-Grafik Kernel 4.x
Laptop: OpenSUSE Leap 15.0, Intel-Skylake, Kernel 4.12

gorgonz
Member
Member
Beiträge: 166
Registriert: 13. Mai 2006, 19:37
Wohnort: Frankenland

Re: leap 42.2 kernel panic bei shutdown

Beitrag von gorgonz » 16. Jul 2017, 22:41

Servus sauerland,

danke Dir für diesen Hinweis! :-) Beim PC nehm hab ich AMD und nehme Standardtreiber, aber beim Laptop ist das ein guter Tipp!
Meine Systeme:
PC (I7-2600K): openSUSE leap 15.0 (64bit), QT 5.9.4, KDE Frameworks 5.45.0, 4.12.14-lp150.12.13-default
Laptop: Samsung RC530 (I7-2670QM), openSUSE tumbleweed, QT 5.11.0, KDE Frameworks 5.47.0, kernel 4.17.5-1-default

spoensche
Moderator
Moderator
Beiträge: 7391
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: leap 42.2 kernel panic bei shutdown

Beitrag von spoensche » 27. Jul 2017, 08:08

Das Problem oder zumindest ein ähnliches Problem haben auch schon andere User mit anderer Hardware gehabt.
Siehe: https://bbs.archlinux.org/viewtopic.php?id=207658

Es handelt sich dabei um einen Bug im Kernel. Patch(e) sind in Arbeit.

Kannst du bitte mal noch die Ausgabe des Befehls

Code: Alles auswählen

dmesg | egrep -i "err|warn|fail|bug|acpi|apic"

gorgonz
Member
Member
Beiträge: 166
Registriert: 13. Mai 2006, 19:37
Wohnort: Frankenland

Re: leap 42.2 kernel panic bei shutdown

Beitrag von gorgonz » 27. Jul 2017, 14:50

Hi spoensche,
danke, dass Du dran geblieben bist :-). Klar mach ich den dmesg:

Code: Alles auswählen

[    0.000000] BIOS-e820: [mem 0x00000000de1f6000-0x00000000de1f6fff] ACPI data
[    0.000000] BIOS-e820: [mem 0x00000000de1f7000-0x00000000de320fff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000deae4000-0x00000000deb26fff] ACPI NVS
[    0.000000] ACPI: Early table checksum verification disabled
[    0.000000] ACPI: RSDP 0x00000000000F0490 000024 (v02 ALASKA)
[    0.000000] ACPI: XSDT 0x00000000DE302070 00005C (v01 ALASKA A M I    01072009 AMI  00010013)
[    0.000000] ACPI: FACP 0x00000000DE30BA80 0000F4 (v04 ALASKA A M I    01072009 AMI  00010013)
[    0.000000] ACPI: DSDT 0x00000000DE302160 00991D (v02 ALASKA A M I    00000012 INTL 20051117)
[    0.000000] ACPI: FACS 0x00000000DE31FF80 000040
[    0.000000] ACPI: APIC 0x00000000DE30BB78 000092 (v03 ALASKA A M I    01072009 AMI  00010013)
[    0.000000] ACPI: MCFG 0x00000000DE30BC10 00003C (v01                 01072009 MSFT 00000097)
[    0.000000] ACPI: HPET 0x00000000DE30BC50 000038 (v01 ALASKA A M I    01072009 AMI. 00000005)
[    0.000000] ACPI: SSDT 0x00000000DE30BC88 00036D (v01 SataRe SataTabl 00001000 INTL 20091112)
[    0.000000] ACPI: SSDT 0x00000000DE30BFF8 0009AA (v01 PmRef  Cpu0Ist  00003000 INTL 20051117)
[    0.000000] ACPI: SSDT 0x00000000DE30C9A8 000A92 (v01 PmRef  CpuPm    00003000 INTL 20051117)
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] ACPI: PM-Timer IO Port: 0x408
[    0.000000] ACPI: Local APIC address 0xfee00000
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0xff] high edge lint[0x1])
[    0.000000] IOAPIC[0]: apic_id 2, version 32, address 0xfec00000, GSI 0-23
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[    0.000000] ACPI: IRQ0 used by override.
[    0.000000] ACPI: IRQ9 used by override.
[    0.000000] Using ACPI (MADT) for SMP configuration information
[    0.000000] ACPI: HPET id: 0x8086a701 base: 0xfed00000
[    0.000032] ACPI: Core revision 20150930
[    0.008259] ACPI: 4 ACPI AML tables successfully acquired and loaded
[    0.025424] ..TIMER: vector=0x30 apic1=0 pin1=2 apic2=-1 pin2=-1
[    0.099962] PM: Registering ACPI NVS region [mem 0xde1f7000-0xde320fff] (1220608 bytes)
[    0.099986] PM: Registering ACPI NVS region [mem 0xdeae4000-0xdeb26fff] (274432 bytes)
[    0.121428] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it
[    0.121430] ACPI: bus type PCI registered
[    0.121431] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
[    0.121504] pmd_set_huge: Cannot satisfy [mem 0xf8000000-0xf8200000] with a huge-page mapping due to MTRR override.
[    0.121842] perf_event_intel: PMU erratum BJ122, BV98, HSD29 worked around, HT is on
[    0.169666] ACPI: Added _OSI(Module Device)
[    0.169667] ACPI: Added _OSI(Processor Device)
[    0.169668] ACPI: Added _OSI(3.0 _SCP Extensions)
[    0.169669] ACPI: Added _OSI(Processor Aggregator Device)
[    0.171952] ACPI: Executed 1 blocks of module-level executable AML code
[    0.175358] ACPI: Dynamic OEM Table Load:
[    0.175363] ACPI: SSDT 0xFFFF88018FCA2000 00083B (v01 PmRef  Cpu0Cst  00003001 INTL 20051117)
[    0.175894] ACPI: Dynamic OEM Table Load:
[    0.175897] ACPI: SSDT 0xFFFF88018EACB000 000303 (v01 PmRef  ApIst    00003000 INTL 20051117)
[    0.176336] ACPI: Dynamic OEM Table Load:
[    0.176338] ACPI: SSDT 0xFFFF88018EAC3600 000119 (v01 PmRef  ApCst    00003000 INTL 20051117)
[    0.178174] ACPI: Interpreter enabled
[    0.178190] ACPI: (supports S0 S3 S4 S5)
[    0.178191] ACPI: Using IOAPIC for interrupt routing
[    0.178215] PCI: Using host bridge windows from ACPI; if necessary, use "pci=nocrs" and report a bug
[    0.185318] ACPI: Power Resource [FN00] (off)
[    0.185410] ACPI: Power Resource [FN01] (off)
[    0.185490] ACPI: Power Resource [FN02] (off)
[    0.185571] ACPI: Power Resource [FN03] (off)
[    0.185651] ACPI: Power Resource [FN04] (off)
[    0.186282] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-3e])
[    0.186286] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
[    0.186556] acpi PNP0A08:00: _OSC: platform does not support [PCIeHotplug PME]
[    0.186731] acpi PNP0A08:00: _OSC: OS now controls [AER PCIeCapability]
[    0.186732] acpi PNP0A08:00: FADT indicates ASPM is unsupported, using BIOS configuration
[    0.187462] pci 0000:00:01.0: System wakeup disabled by ACPI
[    0.187650] pci 0000:00:14.0: System wakeup disabled by ACPI
[    0.188016] pci 0000:00:1a.0: System wakeup disabled by ACPI
[    0.188188] pci 0000:00:1b.0: System wakeup disabled by ACPI
[    0.188346] pci 0000:00:1c.0: System wakeup disabled by ACPI
[    0.188506] pci 0000:00:1c.5: System wakeup disabled by ACPI
[    0.188663] pci 0000:00:1c.6: System wakeup disabled by ACPI
[    0.188821] pci 0000:00:1c.7: System wakeup disabled by ACPI
[    0.189014] pci 0000:00:1d.0: System wakeup disabled by ACPI
[    0.197744] pci 0000:02:00.0: System wakeup disabled by ACPI
[    0.205654] pci 0000:03:00.0: System wakeup disabled by ACPI
[    0.206155] pci 0000:05:00.0: System wakeup disabled by ACPI
[    0.213683] pci 0000:06:00.0: System wakeup disabled by ACPI
[    0.222012] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 10 *11 12 14 15)
[    0.222073] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 *10 11 12 14 15)
[    0.222132] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 10 *11 12 14 15)
[    0.222192] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 *5 6 10 11 12 14 15)
[    0.222250] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 10 11 12 14 15) *0, disabled.
[    0.222309] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 10 11 12 14 15) *0, disabled.
[    0.222368] ACPI: PCI Interrupt Link [LNKG] (IRQs *3 4 5 6 10 11 12 14 15)
[    0.222427] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 *10 11 12 14 15)
[    0.222640] ACPI: Enabled 4 GPEs in block 00 to 3F
[    0.222792] PCI: Using ACPI for IRQ routing
[    0.231791] pnp: PnP ACPI init
[    0.231881] system 00:00: Plug and Play ACPI device, IDs PNP0c01 (active)
[    0.231964] system 00:01: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.231987] pnp 00:02: Plug and Play ACPI device, IDs PNP0b00 (active)
[    0.232035] system 00:03: Plug and Play ACPI device, IDs INT3f0d PNP0c02 (active)
[    0.232180] system 00:04: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.232488] pnp 00:05: Plug and Play ACPI device, IDs PNP0501 (active)
[    0.232536] system 00:06: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.232792] system 00:07: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.232936] pnp: PnP ACPI: found 8 devices
[    0.238826] clocksource: acpi_pm: mask: 0xffffff max_cycles: 0xffffff, max_idle_ns: 2085701024 ns
[    0.279548] pci 0000:05:00.0: set MSI_INTX_DISABLE_BUG flag
[    1.406213] intel_idle: lapic_timer_reliable_states 0xffffffff
[    1.437972] acpi IFX0102:00: hash matches
[    1.822914] ACPI: bus type USB registered
[    1.823988] ehci-pci 0000:00:1a.0: debug port 2
[    1.840147] ehci-pci 0000:00:1d.0: debug port 2
[    2.670808] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[    2.670810] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT5._GTF] (Node ffff88018fcc4310), AE_NOT_FOUND (20150930/psparse-542)
[    2.670863] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[    2.670871] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT0._GTF] (Node ffff88018fcc4568), AE_NOT_FOUND (20150930/psparse-542)
[    2.671085] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[    2.671094] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT2._GTF] (Node ffff88018fcc4478), AE_NOT_FOUND (20150930/psparse-542)
[    2.671146] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[    2.671158] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT3._GTF] (Node ffff88018fcc4400), AE_NOT_FOUND (20150930/psparse-542)
[    2.671459] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[    2.671473] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT0._GTF] (Node ffff88018fcc4568), AE_NOT_FOUND (20150930/psparse-542)
[    2.671909] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[    2.671911] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT5._GTF] (Node ffff88018fcc4310), AE_NOT_FOUND (20150930/psparse-542)
[    2.672491] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[    2.672493] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT2._GTF] (Node ffff88018fcc4478), AE_NOT_FOUND (20150930/psparse-542)
[    2.672574] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[    2.672588] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT4._GTF] (Node ffff88018fcc4388), AE_NOT_FOUND (20150930/psparse-542)
[    2.672633] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[    2.672644] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT3._GTF] (Node ffff88018fcc4400), AE_NOT_FOUND (20150930/psparse-542)
[    2.674173] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20150930/psargs-359)
[    2.674179] ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT4._GTF] (Node ffff88018fcc4388), AE_NOT_FOUND (20150930/psparse-542)
[    4.547072] ACPI: Power Button [PWRB]
[    4.547197] ACPI: Power Button [PWRF]
[    4.567536] ACPI: Thermal Zone [TZ00] (28 C)
[    4.568039] ACPI: Thermal Zone [TZ01] (30 C)
[    4.585376] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20150930/utaddress-254)
[    4.585378] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.585383] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20150930/utaddress-254)
[    4.585384] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.585387] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20150930/utaddress-254)
[    4.585387] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.585391] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x000000000000051F (\LED_) (20150930/utaddress-254)
[    4.585394] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20150930/utaddress-254)
[    4.585394] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.592525] i801_smbus 0000:00:1f.3: SMBus using PCI interrupt
Hilft das weiter?
Meine Systeme:
PC (I7-2600K): openSUSE leap 15.0 (64bit), QT 5.9.4, KDE Frameworks 5.45.0, 4.12.14-lp150.12.13-default
Laptop: Samsung RC530 (I7-2670QM), openSUSE tumbleweed, QT 5.11.0, KDE Frameworks 5.47.0, kernel 4.17.5-1-default

spoensche
Moderator
Moderator
Beiträge: 7391
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: leap 42.2 kernel panic bei shutdown

Beitrag von spoensche » 29. Jul 2017, 15:27

gorgonz hat geschrieben:
27. Jul 2017, 14:50

Code: Alles auswählen

[    4.585376] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20150930/utaddress-254)
[    4.585378] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.585383] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20150930/utaddress-254)
[    4.585384] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.585387] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20150930/utaddress-254)
[    4.585387] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.585391] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x000000000000051F (\LED_) (20150930/utaddress-254)
[    4.585394] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20150930/utaddress-254)
[    4.585394] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.592525] i801_smbus 0000:00:1f.3: SMBus using PCI interrupt

https://bugs.launchpad.net/ubuntu/+sour ... ug/1666652

Diese Meldungen deuten evtl. auf einen BIOS Firmware-Bug hin.

\PMIO betrifft das Powermanagement und je nach dem, welche Geräte über die darauffolgenden GPIO' s angesprochen werden und dabei ein Fehler auftritt kann es dazu führen, dass der Rechner, wie bei dir, eben nicht ausgeschaltet wird.

Kannst du mal die vollständige Ausgabe

Code: Alles auswählen

dmesg
posten?

Wenn du die Ausgabe des Befehls hast, dann machst du mal folgendes:

1. Reboot
2. Im Bootmenü im Feld Bootoptionen

Code: Alles auswählen

acpi_osi=Linux
eintragen und Enter drücken
3. Ausgabe von

Code: Alles auswählen

dmesg | egrep -i "err|warn|fail|bug|acpi|apic"
posten
4. Den Rechner testweise mal ausschalten und kurz Bescheid geben, ob es funktioniert.

EDIT:

Installiere mal die Firmware Testsuite https://software.opensuse.org/package/f ... _term=fwts und führe es danach mal mit

Code: Alles auswählen

sudo fwts
. Danach liegt im aktuellen Verzeichnis die Datei results.log. Den Inhalt der Datei stellst du bitte mittels Pastebin o.ä. bereit und postest den Link hier.

gorgonz
Member
Member
Beiträge: 166
Registriert: 13. Mai 2006, 19:37
Wohnort: Frankenland

gelöst

Beitrag von gorgonz » 30. Aug 2017, 01:29

Sorry, das hat sich jetzt mit dem Urlaub überschnitten. Kurze Zusammenfassung:
Ich habe nach dem Urlaub nicht gleich dran gedacht und so kam nach dem Hochfahren ein Updatewunsch, dem ich stattgegeben habe. Beim Herunterfahren hab ich zum ersten Mal gemerkt, dass es jetzt wieder geht - und so ist es auch geblieben.

@spoensche: Ich denke, das bestätigt Deinen Verdacht mit dem kernel module. Auch wenn es sich gerade anders gelöst hat, nochmal vielen Dank für Deine Unterstützung :thumbs: :-D
Meine Systeme:
PC (I7-2600K): openSUSE leap 15.0 (64bit), QT 5.9.4, KDE Frameworks 5.45.0, 4.12.14-lp150.12.13-default
Laptop: Samsung RC530 (I7-2670QM), openSUSE tumbleweed, QT 5.11.0, KDE Frameworks 5.47.0, kernel 4.17.5-1-default

spoensche
Moderator
Moderator
Beiträge: 7391
Registriert: 30. Okt 2004, 23:53
Wohnort: Siegen

Re: leap 42.2 kernel panic bei shutdown

Beitrag von spoensche » 30. Aug 2017, 19:46

Ich hoffe du hast dich im Urlaub erholt.

Ich muss dir jetzt leider mit den "Formalitäten auf den Sack" gehen. Setze den Thread bitte noch auf gelöst.

gorgonz
Member
Member
Beiträge: 166
Registriert: 13. Mai 2006, 19:37
Wohnort: Frankenland

Re: [gelöst] leap 42.2 kernel panic bei shutdown

Beitrag von gorgonz » 31. Aug 2017, 03:10

Selbstverständlich gehst Du mir NICHT auf den Sack ;-). Das ist vollkommen richtig, war wohl doch schon etwas spät ;-)
=> Habs erledigt
Meine Systeme:
PC (I7-2600K): openSUSE leap 15.0 (64bit), QT 5.9.4, KDE Frameworks 5.45.0, 4.12.14-lp150.12.13-default
Laptop: Samsung RC530 (I7-2670QM), openSUSE tumbleweed, QT 5.11.0, KDE Frameworks 5.47.0, kernel 4.17.5-1-default

Antworten