Seite 1 von 1

leap 42.2 h264 video wiedergeben

Verfasst: 8. Jan 2017, 10:27
von klaus-dieter
Hallo,

ich möchte ein mkv File wieder geben dessen Video Daten mit h264 kodiert sind. z.B. http://jell.yfish.us/ dort den ersten Link. Dragon Player zeigt kein Bild, VLC zeigt ein Bild, aber total kaputt. Codecs habe ich von Packman installiert.

Funktioniert das bei euch? Falls ja, was könnte bei mir falsch sein und was kann ich an Infos posten um den Fehler zu finden?

Danke!

Re: leap 42.2 h264 video wiedergeben

Verfasst: 8. Jan 2017, 10:42
von swannema
libx264 ist installiert?

Bei mir läuft das Video.

Re: leap 42.2 h264 video wiedergeben

Verfasst: 8. Jan 2017, 10:46
von klaus-dieter
libx264-148 von packman ist installiert Yast zeigt 0148svn20161219-3.1-x86_64 an.

Welchen Player hast du genommen?

Re: leap 42.2 h264 video wiedergeben

Verfasst: 8. Jan 2017, 11:26
von tomm.fa
Wenn du VLC (nicht VLC Beta) installiert hast und verwendest, was ergibt dann die Ausgabe von

Code: Alles auswählen

zypper se -si vlc
?
Wenn vlc-codec-gstreamer und vlc-codecs installiert sind, dann lösche mal das Paket vlc-codecs und versuche es mit dem Stream nochmal.

Re: leap 42.2 h264 video wiedergeben

Verfasst: 8. Jan 2017, 11:40
von klaus-dieter
vlc-codecs war installiert, habe es gelöscht. Jetzt funktioniert es in VLC. Habe ich jetzt auch noch eine Chance es im Dragon Player hin zu bekommen?

Re: leap 42.2 h264 video wiedergeben

Verfasst: 8. Jan 2017, 12:03
von tomm.fa
Damit sollte/könnte dir wohl besser jemand helfen der diesen auch installiert hat und verwendet.

Re: leap 42.2 h264 video wiedergeben

Verfasst: 8. Jan 2017, 12:26
von Sauerland
Gstreamer-plugins-bad sind installiert?

Installiere auch noch phonon4qt5-backend-vlc. Ohne dies läuft es nicht.

Re: leap 42.2 h264 video wiedergeben

Verfasst: 8. Jan 2017, 13:07
von klaus-dieter

Code: Alles auswählen

 zypper se -si gstreamer
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S | Name                              | Typ       | Version    | Arch   | Repository               
--+-----------------------------------+-----------+------------+--------+--------------------------
i | GStreamer Multimedia Codecs       | Anwendung |            | noarch | openSUSE-Leap-42.2-Update
i | PackageKit-gstreamer-plugin       | Paket     | 1.1.3-2.3  | x86_64 | openSUSE-42.2-0          
i | gstreamer                         | Paket     | 1.8.3-1.8  | x86_64 | openSUSE-42.2-0          
i | gstreamer-lang                    | Paket     | 1.8.3-1.8  | noarch | openSUSE-42.2-0          
i | gstreamer-libnice                 | Paket     | 0.1.13-4.5 | x86_64 | openSUSE-42.2-0          
i | gstreamer-plugins-bad             | Paket     | 1.8.3-5.1  | x86_64 | Packman Repository       
i | gstreamer-plugins-bad-lang        | Paket     | 1.8.3-5.1  | noarch | Packman Repository       
i | gstreamer-plugins-base            | Paket     | 1.8.3-1.4  | x86_64 | openSUSE-42.2-0          
i | gstreamer-plugins-base-lang       | Paket     | 1.8.3-1.4  | noarch | openSUSE-42.2-0          
i | gstreamer-plugins-farstream       | Paket     | 0.2.8-1.5  | x86_64 | openSUSE-42.2-0          
i | gstreamer-plugins-good            | Paket     | 1.8.3-1.3  | x86_64 | openSUSE-42.2-0          
i | gstreamer-plugins-good-lang       | Paket     | 1.8.3-1.3  | noarch | openSUSE-42.2-0          
i | gstreamer-plugins-libav           | Paket     | 1.8.3-2.5  | x86_64 | Packman Repository       
i | gstreamer-plugins-ugly            | Paket     | 1.8.3-2.2  | x86_64 | Packman Repository       
i | gstreamer-plugins-ugly-orig-addon | Paket     | 1.8.3-2.2  | x86_64 | Packman Repository       
i | libgstreamer-1_0-0                | Paket     | 1.8.3-1.8  | x86_64 | openSUSE-42.2-0          
i | phonon-backend-gstreamer          | Paket     | 4.8.2-4.1  | x86_64 | openSUSE-42.2-0          
i | phonon4qt5-backend-gstreamer      | Paket     | 4.9.0-1.2  | x86_64 | openSUSE-42.2-0          
i | vlc-codec-gstreamer               | Paket     | 2.2.4-29.1 | x86_64 | Packman Repository       
war installiert, dragon player tut es trotzdem nicht. Dragon Player benutzt doch auch gstreamer, wie auch VLC, sollten die nicht am Ende auf den gleichen Codec damit zugreifen?

Re: leap 42.2 h264 video wiedergeben

Verfasst: 8. Jan 2017, 13:33
von tomm.fa
Könnte es sein das der Dragon Player noch die 0.10er statt der 1.0er Versionen von Gstreamer benötigt?

Re: leap 42.2 h264 video wiedergeben

Verfasst: 8. Jan 2017, 15:33
von Sauerland
Öffne Dragonplayer als User in der Konsole und starte dann das Video:

Code: Alles auswählen

dragon

Re: leap 42.2 h264 video wiedergeben

Verfasst: 10. Jan 2017, 09:37
von klaus-dieter

Code: Alles auswählen

** Message: PackageKit: xid = 130023428
** Message: PackageKit: desktop_id = (null)
** Message: PackageKit: Codec nice name: H.264 (High Profile)-Decoder
** Message: PackageKit: ignoring field named level
** Message: PackageKit: ignoring field named profile
** Message: PackageKit: structure: gstreamer1(decoder-video/x-h264)()(64bit)
** Message: PackageKit: Did not install codec: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.PackageKit was not provided by any .service files
PackageKit ist natürlich installiert.

Re: leap 42.2 h264 video wiedergeben

Verfasst: 13. Jan 2017, 22:55
von tomm.fa
Schaue mal ob es nach der Installation von gstreamer-0_10-plugins-ugly-orig-addon funktioniert.

Re: leap 42.2 h264 video wiedergeben

Verfasst: 14. Jan 2017, 13:28
von klaus-dieter
Wo bekomme ich das her? Ich habe in Yast nur die Version 1.8.3 (und die ist bereits installiert).

Re: leap 42.2 h264 video wiedergeben

Verfasst: 14. Jan 2017, 13:44
von tomm.fa

Code: Alles auswählen

zypper se -s gstreamer-0_10-plugins-ugly-orig-addon
Loading repository data...
Reading installed packages...

S | Name                                             | Type    | Version      | Arch   | Repository          
--+--------------------------------------------------+---------+--------------+--------+---------------------
i | gstreamer-0_10-plugins-ugly-orig-addon           | package | 0.10.19-18.2 | x86_64 | PackMan Repositorium
  | gstreamer-0_10-plugins-ugly-orig-addon-debuginfo | package | 0.10.19-18.2 | x86_64 | PackMan Repositorium
Du hast doch anscheinend auch das Repositorium von PackMan eingebunden.
klaus-dieter hat geschrieben:

Code: Alles auswählen

 i | […]| Paket     | 1.8.3-2.2  | x86_64 | Packman Repository 
Daher sollte sich auch gstreamer-0_10-plugins-ugly-orig-addon finden und installieren lassen. Kann man auch über Zypper mit

Code: Alles auswählen

zypper in gstreamer-0_10-plugins-ugly-orig-addon
installieren lassen.

Ansonsten die Ausgaben von

Code: Alles auswählen

zypper se -s gstreamer-0_10-plugins-ugly-orig-addon

Code: Alles auswählen

zypper lr -d
hier vorführen.